problem with UEFI install on Sony Vaio Pro 13 w/Windows-8.1

Hi guys, I’ve recently buyed a Sony Vaio Pro 13. After following this post ( https://forums.opensuse.org/showthread.php/491333-Sony-vaio-pro-13-with-Windows-8-1-install-opensuse-12-3-from-USB-boot-problem?p=2601524#post2601524 ) I’ve been succefull in Installing Grub, but at the first start of opensuse 13.1 x64 I get this error:


Waiting for device /dev/root to appear:............................. Could not find /dev/root.
Want me to fall back to /dev/disk/by-id/ata-SAMUNG_MZHPU128HCHGM-00000_S1ACNYADB01045-part7 ? (Y/n)

Thank you in advance

I’ve done a photo of the error with my phone because after hitting F1 as soon as possible at start-up I’ve seen that there is more.

I underline the fact that this is the first boot after installation so, if I remember correctly, during this time the installation process start again to complete the last part in any case I’ve tried even with the installation media connected to the usb port but nothing changes.

http://s30.postimg.org/vsnpbinqp/IMG_20140207_093355.jpg

Can you tell us a bit more about your install.

In particular, are you using grub2-efi or just grub2?

Was your EFI partition mounted at “/boot/efi”?

Is “/boot” a separate partition? Did you install on the internal drive? Do you have more than one hard drive (perhaps an SSD)?

My quick guess from your error message, is that either the “initrd” is not being read, or it is missing a driver. But I would like to know more about your setup, so that I can get beyond guessing.

  1. I’m using grub2-efi, even checked that on the installation process to be sure of that.

  2. I’m quite sure about since to let GRUB boots I had to move /boot/EFI/opensuse contenent in /boot/EFI/Windows ecc. as described in the first link I’ve posted. Also during the installation process opensuse partitioner select the mount-point to /boot/EFI

3.It is a separate partition

I have installed on the ssd that is the only drive I have (one SSD 128gb flash unit), FROM a usb live stick

Here is what I can get from a liveUSB KDE session:

linux:~ # gdisk /dev/sda -l
GPT fdisk (gdisk) version 0.8.7

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 250069680 sectors, 119.2 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): BDADBE25-2F52-4DB8-BBD2-F8AB84BBA5B3
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 250069646
Partitions will be aligned on 2048-sector boundaries
Total free space is 3711 sectors (1.8 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          534527   260.0 MiB   ED00  
   2          534528         3553279   1.4 GiB     2700  
   3         3553280         4085759   260.0 MiB   EF00  EFI system partition
   4         4085760         4347903   128.0 MiB   0C01  Microsoft reserved part
   5         4347904       123093997   56.6 GiB    0700  Basic data partition
   6       220749824       250068991   14.0 GiB    2700  
   7       123095040       220749823   46.6 GiB    0700  primary


(No swap partition is my choice to preserve SSD life and because I have 8gb of RAM)

Honestly, I think that a bad approach. I know one user claimed it worked for them, but i do not think it a good idea.

My recommendation would be to restore /boot/EFI/Windows from the backup you made prior to copying /boot/EFI/opensuse content to that partition. And then you should be able to boot Windows-8.1 again, and then this problem can be sorted.

You did make a backup of the EFI partition first, I hope.

Yes I have the backup.

I must say that with a past install, with a total wipe of the partitions (except the boot one), I booted GRUB without that trick and I remember a similar error, by the way I will try.

Oldcpu, ok I’ve restored the Microsoft folder, now:

do I have to copy /EFI/opensuse content in /EFI/Boot or in /Boot folder ? Because I have two Boot folders one is a sub-folder of EFI one not.

Then I have to rename shim.efi to bootx64.efi right ?

There is even /EFI/Microsoft/Boot

so:

/Boot
/EFI/Boot
/EFI/Microsoft/Boot

which one ? And what file to rename ?

My recommendation was to restore /boot/EFI/Windows (ie the /EFI/Microsoft) from the backup you made prior to copying /boot/EFI/opensuse. It was not to remove the /boot/EFI/opensuse.

If you removed the /EFI/opensuse, then please restore it (unless you also removed openSUSE).

Please also confirm, with the /EFI/Boot and /EFI/Microsoft/Boot in place that you are now able to boot MS-Windows ?

Next question - are you able to boot openSUSE from a liveDVD or liveUSB stick ?

I’ve restored /EFI/Windows and windows boots correctly. The fact is that now grub2 doesn’t appear and I can’t boot the opensuse installation, windows starts directly.
/EFI/opensuse is there (I make everytime a backup folder of everything).

I can boot a opensuse live session KDE or DVD from usbdrive, is from there that I edit the EFI folder.

Now the problem is to boot opensuse installation on the harddrive.

Glad to read your PC can now boot again, even if it is only to MS-Windows.

Now user nrickert is FAR more knowledgeable than I on this subject. I recommend you provide him a bit more information and boot to a liveDVD of openSUSE and with root permissions send the command:


efibootmgr -v

that should list what your firmware can see wrt various bootable operating systems (my description may be less than accurate). Please either copy and paste that output here (ie while booted to liveDVD) or take a picture of it with your camera and post the picture.

I also note its possible in windows-8 to check what windows can see wrt firmware boot options (take a look at post#78 in this thread: https://forums.opensuse.org/showthread.php/485517-openSUSE-Windows8-dual-boot-installation-Questions-for-Secure-Boot-UEFI-and-GPT?p=2566773#post2566773 ) . A picture of that output may also help.

That ‘may’ help put our more knowledgeable UEFI users on the right path.

I’ll note that I am following this thread, even if I haven’t commented much. You seemed to be giving good advice, so I didn’t want to have too many voices speaking.

Yes, additional information would help.

What I want to know at this point:

  1. What’s in the NVRAM boot entries;
  2. does your BIOS follow NVRAM boot entries, or is it hard coded to boot Windows or to boot what is in “\EFI\Boot”.

Those seem to be the issues that are probably involved here.

I have done this from a linux mint live usb because I am in the rail and I can not find the suse live usb

mint@mint ~ $ sudo efibootmgr -v
BootCurrent: 000B
Timeout: 0 seconds
BootOrder: 000B,0005,0008,0000,0009,000A,0001
Boot0000* Windows Boot Manager    HD(3,363800,82000,a8cbe460-7d81-474d-98d1-0f9d16187834)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0001* ubuntu    HD(3,363800,82000,a8cbe460-7d81-474d-98d1-0f9d16187834)File(\EFI\ubuntu\shimx64.efi)
Boot0005* Sony Original    HD(1,800,82000,2c0476f5-f682-42fc-b18a-bac07c7f4751)File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0008* Windows Boot Manager    HD(5,425800,708c000,45493273-e85b-47a6-ab1f-d43cc1a7cf35)File(\EFI\Boot\bootx64.efi)
Boot0009* Windows Boot Manager    HD(5,425800,ce60800,45493273-e85b-47a6-ab1f-d43cc1a7cf35)File(\EFI\Boot\bootx64.efi)
Boot000A* Windows Boot Manager    HD(5,425800,713ebee,45493273-e85b-47a6-ab1f-d43cc1a7cf35)File(\EFI\Boot\bootx64.efi)
Boot000B* UEFI: SanDisk U3 Cruzer Micro 4.05    ACPI(a0341d0,0)PCI(1d,0)USB(1,0)USB(1,0)HD(1,145f4,11c0,5e6605dc)..BO


“ubuntu” referes to an old attempt to install linux mint

I don’t have a way forward, but i have some observations. I note you previously posted this:


Number  Start (sector)    End (sector)  Size       Code  Name
**   1            2048          534527   260.0 MiB   ED00  **
   2          534528         3553279   1.4 GiB     2700  
**   3         3553280         4085759   260.0 MiB   EF00  EFI system partition**
   4         4085760         4347903   128.0 MiB   0C01  Microsoft reserved part
**   5         4347904       123093997   56.6 GiB    0700  Basic data partition**
   6       220749824       250068991   14.0 GiB    2700  
   7       123095040       220749823   46.6 GiB    0700  primary

Where I tried to match the gdisk entries with the efibootmgr entries by colour coding. The sony boot partition (?) appears to be on sda1. Windows-8.1 on sda3. And some ** bizarre windows entries on your data partition ** sda5. The left over Ubuntu points to sda3. And I see no openSUSE entry. On my PC my openSUSE ext4 partitions are code 8300 and I don’t see that on your PC.

An update to that. My desktop has code 8300 for my / but my Ultrabook has code 0700. I don’t know enough to explain the difference.

I’m uncertain of this, but it seems to be the explanation.

Partition type coding is different for GPT disks. There’s presumably a defined GUID for the partition type. Software such as “gdisk” and “parted” abbreviates that to “8300” for linux partitions.

Apparently the type code for linux is a relatively recent addition to the standard, and some of the code (probably in Yast) hasn’t caught up. So it has been using the NTFS type code as a standby.

Or, to say it different, the difference in type codes does not seem to be important.

Added note: Like you, I would like to see a clear statement of which partition is which. It’s hard to know how to proceed without that.

@Oldcpu: The partition that contains /EFI/Boots ecc is /dev/sda3 .

@nrickert: I don’t know how to bring you these information

  1. What’s in the NVRAM boot entries;
  2. does your BIOS follow NVRAM boot entries, or is it hard coded to boot Windows or to boot what is in “\EFI\Boot”.

You’ve already provided some of that (the “efibootmgr -v” output).

Can you provide a list of what is on each partition. Such as “opensuse home” or “mint root” etc.

Also, can you provide a list of directories in the efi partition. We can already see that there is “\EFI\Boot”, “\EFI\Microsoft” and “\EFI\ubuntu”. Is there a “\EFI\opensuse”?

About the last question yes there is /EFI/opensuse, here is the list of EFI partition contenent ( sda3 ):
/Boot
/EFI
/EFI/Boot
/EFI/opensuse
/EFI/Windows
/EFI/Windows/Boot/
/EFI/ubuntu

About the first one: at the moment there is no more ubuntu/linux mint installation just windows and opensuse.
Opensuse has / and /home in the same partition (so no separate home partition).
The list of partitions is:

sda1 called SONYSYS is an uknown partition about sony tools for system restore i suppose, It is formatted fat32
sda2 NTFS Partition called WINOWS RE TOOLS I think this is also for system restore
sda3 EFI partition
sda4 ext4 partition called “Microsoft Reserved” 128mb I don’t know if this is the result of the disk resize on the linux mint past installation
sda5 Windows primary partition
sda6 Windows ntfs recovery partition (this is not the tools I think is a snapshot of the system)
sda7 SWAP (in the last installation I’ve tried an installation with swap
sda8 / (main opensuse partition)

Okay. That’s all useful information.

Can you provide a listing “ls -l” of “/EFI/opensuse” in the EFI partition.

We can probably use “efibootmgr” from a live boot or rescue boot, to add an opensuse entry to NVRAM and to delete the ubuntu entry. Then we can test whether the opensuse entry works.