Problem with TW rollback

I’m using openSUSE Tumbleweed, and I find I can’t rollback to a previous snapshot. I see them listed in the boot menu, but they don’t actually work. The reason I say that is: somehow my lock screen got broken, so I have to ctrl-alt-f2 to get to the terminal(?) login and then log in, loginctl unlock-session 3, ctrl-d, then ctrl-alt-f7, and the screen (this is another issue now) says that I can always return to those instructions, by pressing ctrl-alt-f3, which I do at the login prompt and it doesn’t work, do it at the terminal prompt, doesn’t work. So, broken lock screen, can’t click the Terminal icon for it to open, display settings messed up, can’t open Dolphin, can’t open Kate, so I tried booting to an older snapshot in the boot menu, and same problems. I even opened YaST, looked at my snapshots, chose that latest one that had pre and post, and selected all the files to restore, then booted off of the oldest available snapshot, still had same problems. I even opened YaST again and deleted all the lines with just pre in it, all the lines after the last one that had pre and post, and booted again, still the same problems. So I think that snapshots are not actually working. It’s 2023-06-23 today. I mean, wouldn’t it make sense in the YaST snapshot program, to select a snapshot and have a button that says “boot to this snapshot”?

So 1) snapshots still don’t work
2) the broken lock screen instructions can’t be reached again by pressing ctrl-alt-f3

And what’s interesting is that the initial login screen works, so I can log in to my system, but that the lock screen is different from the log in screen, even though they look the same. That seems suspicious to me.

It is usually better to start a new topic for your own problem, rather than append to an existing thread.

I’ve moved your post to a new topic.