Problem with Thinkpad T410 and Gobi 2000 Qualcomm

Hello all,
I am fairly new to using Linux as a desktop and just started using OpenSuse for a few days.
I have a Thinkpad T410 with an integrated Gobi 2000 Qualcomm WAN adapter which worked alright in Kubuntu and Ubuntu.
I can not seem to be able to make the OS recognize it. “Mobile Broadband” seems to be disabled in the Network Manager.
I am using OpenSuse 11.3 64 bit version with KDE 4.4.4 (KDE 4.4.4) “release 3”.

Any help is highly appreciated,


I found this link that might help.

Qualcomm Gobi 2000 - ThinkWiki

On the other Linux distros where this Qualcomm adapter worked, what kernel version were they using? Was it higher than 2.6.34 in openSUSE 11.3? It is possible to upgrade your Kernel version if required. Read message #17 here:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

Thank You,

Looking at the think wiki that jdmcdaniel3 quoted, and I note this comment in the thinkwiki:

The firmware for this device must be loaded prior to using the device. The firmware loading interface is exposed over USB as id 05c6:9204 which can be accessed as a character (TTYUSB) device under Linux using the qcserial driver (modified to include correct USB IDs). …

Typically, if the firmware has any ‘non-free’ (ie NOT free as in “free beer”, but rather open source free) then the firmware will not be included with openSUSE. This may mean you need to download the firmware for ‘Gobi’. I note someone in the build service has created an rpm with the firmware: Search Results for gobi

You could try installing gobi_loader and check to see if that helps ?

To quote the ‘gobi_loader’ description:

gobi_loader is a firmware loader for Qualcomm Gobi USB chipsets. These devices
appear in an uninitialised state when power is applied and require firmware
to be loaded before they can be used as modems. gobi_loader adds a udev rule
that will trigger loading of the firmware and make the modem usable. 

I had this problem on my T400s. You will need to have three things to make the Gobi WAN card work an updated kernel, the gobi_loader, and the drivers from your Windows install. I use the KOTD from the OBS to get a kernel that has the updated modules. You can get the gobi_loader and windows drivers from the web.

what is a KOTD? and a OBS?
i have the same modem and also am not able to get it running. the thing about the kernels is they need to be patched as far as i know but i cant seem to find a patch for kernel >= 2.6.35
with the firmware i can help. contact me via private msg and send me ur emailadress.

i am looking for a kernel patch for the newest 2.6.37 kernel. i need this because my laptop has a new i915 intel card that is not supported by older kernel.

maybe someone can help us?

i was wrong. i got it running now. have kernel 2.6.37 rc7
i got the firmware files mixed up

just download gobi_loader. not from the opensuse page but from

build and install

you may need to check if your device is in the rules files.
if it still doesnt work check if its in the kernel source file. may have to rebuild kernel. but i doubt that will be neccessary for you.

happy new year