Problem with suspend-to-ram option

Hi everyone again,
I have another problem I can’t solve. I installed Leap 42.1 (dualboot with windows 10) on my Lenovo Z50-70, and everything seems to be right (I had a problem with nvidia drivers already solved thanks to this forum), except the fact that “suspend-to-ram” option doesn’t work, both closing lid or selecting it from menu.
I mean, if I try to suspend (and if I close the lid with “suspend-to-ram” option enabled in the power options), my pc can’t wake up anymore: it completely freezes on a black screen, I can only see the mouse cursor, but I can’t move it, and I can’t type anything (such as CTRL-Alt-F1, which, if I understood well, should start console mode or stuff like that, I’m a newbie so maybe I’m wrong).
On my other thread an user told me to add a /etc/modprobe.d/50-nouveau.conf with the option ignorelid=1 on it, but it doesn’t work.
I really can’t understand what could be the problem, I read a lot of conflicting opinions on the internet: someone says it is a graphics driver problem, someone says it’s a swap problem, and other thousand things, so I would be really glad if someone could help me to understand something more.
Thanks in advance!

This is likely due to the behaviour of the nvidia graphics driver, but I don’t have such hardware, so not familiar with any solutions or workarounds that may be available.

On my other thread an user told me to add a /etc/modprobe.d/50-nouveau.conf with the option ignorelid=1 on it, but it doesn’t work.

Well, this option isn’t relevant if you’re using the proprietary nvidia driver. :wink:

Is you machine using hybrid (Intel and NVidia) graphics perhaps? If so, the following advice may be useful to you

In particular

||Found the solution on another forum. Technically speaking Z50-70 has two GPU’s, Intel & nvidia. If nvdia is the default GPU, suspend and hibernate will have issues.

  1. Run “nvidia-settings” on terminal.
  2. In “PRIME Profiles” tab, select the GPU as “Intel” instead of “NVIDIA”.
  3. Save and restart your machine.



There is also a workaround mentioned in the same thread suggesting to disable the nvidia device in the BIOS, but of course this means that only the integrated Intel graphics card will be in use (again assuming that you have a hybrid graphics system).

I explained not so well, my fault. I don’t use the proprietary nvidia driver, they caused me problems, so I turned back to open source ones. But yes, I have hybrid graphics system Nvidia + Intel.
So I couldn’t follow the instruction of the link you gave me, because it needs proprietary drivers.
However I tried to follow again (the first time this wasn’t helping) this link that another user posted to me in my previous thread ( and if i follow all before installing nvidia drivers (so using only the main intel graphics card) it seems to work now. Before I made a typo putting nouveau in the blacklist, because I didn’t see I put that into a line that started with #.
I’m so sorry because I feel like I wasted your time (and I also feel so stupid making mistakes like this one), however thank you so much!

No worries. At least you’ve got Bumblebee and suspend/resume working for you now. :slight_smile: