Problem with sound

I am completely new to Linux. I got a very old machine with an NVida board and installed OpenSuse 11.1 based only on the intuitive GNOME graphics interface, which is quite friendly, without any problem. Everything works fine except sound. Part of my problem is that I dont have any manuals about the boards, I only know it’s an NVidia board, and the machine was home-assembled by purchasing CPU, etc…, so it doesn’t have a brand.
So far, I have done the following:
a) Downloaded/installed all the Linux NVidia Legacy Drivers for OpenSuse 11.1 from NVidia’s web site.
b) Today, automatically, configured at YAST/SOUND I have as board 0 (default), nForce2 AC97 Audio Controller (MCP), with the default values. This produces no sound whatsoever. Video is 100% right, so I am guessing the the OS automatic choice of NVidia card is good.
c) Since the system advices to install ALSA or OSS/Free if there are problems with sound, I did try those. I have 3 options at ALSA, but none of them achieves installation. I get the following message:
An error occurred during the installation of
“Dummy soundcard” (or whatever option I try)
The kernel module snd-dummy for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
d) I went to Software Manager and installed all software/drivers related to ALSA and repeated the procedure, without success.
e) I have also tried playing with the configuration of the sound options (i.e PCM devices, PCM substreams for ALSA, or the NVidia parameters like AC97 workaround for strange hardware, without results).
f) I have tried installing other options of the NVidia board, i.e. nForce2 Audio, but I get the same error message, indicating that module snd-intel8x0 for sound support could not be loaded).

All advice will be welcome. I am aware that it might be necessary to send outputs from some command lines, but I haven’t used any so far :P, so please be very specific in the instructions (so far, all I know is how to access the terminal mode!).

Thanks in advance :). Regards,
G. Ganem

Have look here
SDB:AudioTroubleshooting - openSUSE

gganem, thankyou for your post. I try to help users with their sound, but openSUSE-11.2 which was just released, relative to other releases, has been rather boring for support, from a sound perspective. Not enough sound problems ! (although ATI graphics driver problems and some KDE4 wireless hiccups are keeping things entertaining) … So its refreshing to have an 11.1 sound problem again ! :slight_smile:

Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide which is the URL caf4926 provided:SDB:AudioTroubleshooting - openSUSE .

Further to (or rather highlighting aspects of) that guide, please do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will ask you if you wish to share the information (select UPLOAD/SHARE) and when it is complete it will post its output on the Internet/web and it will give you the URL of the web site where the information is posted. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.