problem with sound card and monitor settings

I have installed a -rather old- version of openSuSe (11.3) on a brand-new desktop. I have managed to solve several problems myself (as I am quite new to Linux), but now I have the following two problems:a) i cannot make the sound work. the sound card is an onboard sound card on an intel motherboard. i tried through configuration of sound, but could not find anything for onboard there.b) i have a brand new samsung monitor, which i had tried with windows and was great, but i can only get an analusis of 1280x1024 with linux. And it doesn’t look really great. How can i improve that?Thank you all.

Install a newer version you do not have the needed drivers for your new hardware and 11.3 is well out of support. ie no new stuff. Current ver 12.3

You may also try YAST sound card and turn and turn off pulse also try re setting the driver but really that is very old openSUSE and you do not get any new stuff with it

11.3 is old.

It may be possible to get it to work. But I can no longer remember much about 11.3. Please run a diagnostic script to provide more information so to increase the probability of being able to help.

Open a konsole/terminal, while your pc is connected to the internet, and send the command as a regular user:


/usr/sbin/alsa-info.sh

select the UPLOAD/SHARE option. Run the script to completion. When it is complete, in the konsole/terminal it will give you a web address/url where a detailed summary of your PC’s audio configuration was uploaded. Please post here that web address/url. With that information we may be able to provide some suggestions.

Note since your 11.3 is so old, you may be told there is an update available. To update you need to run /usr/share/alsa-info.sh with root permissions, and select the update option. Then after the update is complete run the /usr/share/alsa-info.sh as a regular user, following the guidance above.

good luck.

Thanks for the replies. Well, I found a wiki page saying how to upgrade to a newer distribution. I followed all instructions, updated a large number of repos (took almost 1 hour to do that), and when I rebooted, it asks me for my root password, which I am sure I write correctly and does not recognise it!!
What can i do ??

Please excuse a rather basic suggestion, but please note that GNU/Linux is case sensitive. So pay attention to where you place upper case and lower case.

No worries for the ‘basic’ suggestion. I can guarantee, though, that after several years of dealing with computers, I would never ‘intentionally’ confuse lower and upper case.
In fact, searching online, I found several similar posts from others. Following some of the suggestions I found, I entered grub (finally I realised how you do it!) and typed several command, like passwd, but all I got is: “passwd: module is unknown”.

I am afraid I will need to reinstall them :frowning:

You probably will not be successful doing a 11.3 to 12.3 (if that is what you did) it is too large of a jump. Do a fresh install.

Well, following your suggestion that that version (11.3) is too old, I installed the newest one (12.3) and everything works just great…apart from the sound. I still have not been able to make it work. Although Amarok seems to play a song, there is no sound coming out of the pc. I tried both the headset plug in front and the sound plug on the back of the tower but nothing.
Any recommendations??

Please run a diagnostic script to provide more information so to increase the probability of being able to help.

Open a konsole/terminal, while your pc is connected to the internet, and send the command as a regular user:


 	/usr/sbin/alsa-info.sh 

select the UPLOAD/SHARE option. Run the script to completion. When it is complete, in the konsole/terminal it will give you a web address/url where a detailed summary of your PC’s audio configuration was uploaded. Please post here that web address/url. With that information we may be able to provide some suggestions.

Also, note that with openSUSE-12.3, you are now using pulse audio. You could install the application ‘pavucontrol’ (pulse audio volume control) and follow some suggestions from my blog where I tried to make this easier to understand: https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

Thank you for that. I entered the first command
/usr/sbin/alsa-info.sh

and a message came that a new version of alsa (0.4.62) was available which i donwloaded. now it says

Newer version detected: 0.4.62
To view the ChangeLog, please visit git.alsa-project.org Git - alsa-driver.git/history - alsa/utils/alsa-info.sh
ALSA-Info script has been downloaded as /tmp/alsa-info.6hYC1e8RPd.
Please re-run the script from new location.

how do i re-run this?

ok, i found that. here is the link:

http://www.alsa-project.org/db/?f=389097efe7191dfd1cf6675bf88c5ee74b2ca255

This is supposed to be a High Definition Audio, 5.1 channel soundcard (i think on board). I wonder why it recognises two soundcards.

The diagnostic script points to a mixer misconfiguration, that is contributing to your difficult on obtaining sound.

According to the diagnostic script, your PC is reporting 2 sound devices, one being HDMI and the other a nominal sound device.


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
**card 0:** MID [HDA Intel MID], device 3:** HDMI 0 **[HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: PCH [HDA Intel PCH], device 0: **ALC887-VD Analog** [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: PCH [HDA Intel PCH], device 1: **ALC887-VD Digital** [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Note the aplay indicates HDMI is sound-card-0. Sound-card-0 is the ‘default’ sound card, and unless set otherwise with pavucontrol, all sound will go out the HDMI device. My guess is you do not want that. To change and have HDMI sound-card-1, and the ALC887-VD Analog/Digital to sound-card-0, go to YaST > Hardware > Sound and select the ALC887-VD Analog/Digital (it will likely have a different name in YaST) and NOT the HDMI. With the ALC887-VD Analog/Digital selected, go to ‘other’ and select ‘Set as the Primary Card’.

That still will not enough. Look now at your PC’s mixer settings:


**Simple mixer control 'Master',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 64 [100%] [0.00dB] **[off]**
**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] **[off]**
  Front Right: Playback 64 [100%] [0.00dB] **[off]**
**Simple mixer control 'Front',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] **[off]**
  Front Right: Playback 64 [100%] [0.00dB] **[off]**
**Simple mixer control 'Surround',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 0 [0%] -64.00dB] **[off]**
  Front Right: Playback 0 [0%] -64.00dB] **[off]**
**Simple mixer control 'Center',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] -64.00dB] **[off]**
**Simple mixer control 'LFE',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 0 [0%] -64.00dB] **[off]**
**Simple mixer control 'Auto-Mute Mode',0**
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
**Simple mixer control 'Channel Mode',0**
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'

Master volume is OFF. ie Your PC’s sound is muted. That will stop all sound.

Headphone is OFF. That will also stop all sound through the headphones.

I do not know if your system is surround sound, but it is OFF, as is FRONT OFF, as is Center OFF, as is LFE OFF. ie practically everything is switched OFF. The Channel mode is set to 2ch, so I assume that means you are not trying to use surround sound.

You need to unmute the Master and headphone as a minimum.

Do you need help to know how to do that ?

I have set the analog as the primary card. I could not find the mixer settings. I tried the speaker at the lower right end of the desktop, but not much luck.

Please run the diagnostic script again as a regular user, so I can see output and confirm the correct setup:


/usr/sbin/alsa-info.sh

and again paste the output URL/web address here.

http://www.alsa-project.org/db/?f=f568a7eeba5439083ce4c1506e19801bee020f73

it asked me again for downloading the new alsa version, but this time i said no. i don’t know if it makes any difference.

i have a window asking me :

Do you want KDE to permanently forget about these devices?

Capture: Default ALSA Output
Output: Default ALSA Output

Yes No Manage_Devices

What should i do and why can i not insert an image here in this window? It only lets me do so from a URL link.

Thanks

It should not matter.

To get rid of that, run the script with root permissions, and select ‘yes’ to upgrade.

After the upgrade is complete you can exit root permissions, and run it again as a regular user.

I typically tell it to forget.

You have a configuration that does not work. why save it ?

Did you go to Yast and change the order of the sound cards? Also try playing a test sound

At the speaker on bottom right there should be a button that says mixer. The mute button is at the bottom of the slider looks like a speaker