Problem with new GeForce 8600 GTS card

I have a machine I put together about 4 years ago with the following hardware:
Mainboard: Biostar TForce4U 939
CPU: AMD Athlon 64 X2 3800+ Manchester 2.0GHz

I previously had a GeForce 7600GS video card on my one PCI Express x16 1.0 slot that I ran for 4 years with the proprietary nvidia drivers. This system has seen every opensuse version since 10.0 and has been stable the entire time.

Two weeks ago on a Saturday, I was relaxing and playing VegaStrike, and I heard a SNAP sound. I didn’t know what it was and figured a cat had gotten into something; didn’t think much of it.

The next day (Sunday), I started having major issues with video. I was working, and didn’t get time to figure out what was happening until that Tuesday. The computer ran during this time. I took a look at my machine and saw that three capacitors on my video card were split open. I immediately removed the card from my system, and the machine ran headless for a while.

I ordered a new card from Newegg the next day, a GeForce 8600 GTS 256MB. I put it into my slot, and here is where my problem really starts. The card works… until I start anything involving opengl. If I start VegaStrike, some KDE effects, or even glxgears, here is what happens: The screen goes black, I hear fan screen increase, all input from keyboard, mouse, or ssh stops, and all I can do is hit reset or hold down the power button. This occurs on every OpenGL action.

Here is what I have tried:
I have thrown out and started new xorg.conf files.
I have checked to see if I have the lasted G02 rpm from the nvidia repo; I already did.
I have used the nvidia driver from “the hard way”.
I have used the nv open drivers; I have no crash when I use them, but of course 3d is non-existent.
I have checked my PSU, and everything checks good out with voltages in BIOS; the PSU is more than adequate for this card (I have already ran this by the manufactures’ support).
I have looked through log files, and I have found nothing to suggest my problem. Although, I admit I am not 100% sure where to look. I have used opensuse as my primary os for a very long time, but I only have experience diagnosing/fixing problems on Windows, since I have never had any hardware/software problems while using opensuse.

I have an RMA ready, but I am faced with the following possible problems:

(1) I just had a bad run of luck and got a bad card.
(2) My PCI Express x16 slot died either when the last card snapped or during that time I didn’t remove my card. This basically means new computer or attempt to find a mainboard replacement with similar specs.
(3) There some other software or hardware problem I haven’t figured out yet.

Does anyone have any thoughts on this? I am hoping for some good news…

I am not a gamer, and games are not the primary purpose of this machine. It is currently running right now and doing its thing just fine without a video card.

Have you seen this
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

How old is this PSU ? They degrade over years and your symptoms do read to be a lack of power.

Yes, I did look at that thread earlier, but I am already familiar with the material discussed in that thread.

My PSU is as old as the machine (4 years). I thought the same thing you were thinking. Here are my stats:

Power supply: APEVIA ATX-AS520W-BK
Maximum power: 520W
Single +12V rail
Input: 10A @ 115V, 5A @ 230V
Output: +3.3V@30A, +5V@32A, +12V@35A, -5V@0.3A, -12V@0.8A, +5VSB@2A

From BIOS:
NB/SB V: 1.53V
+3.3V: 3.28V
+5.0V: 4.94V
+12.0V: 12.09V

Also, note that my new card has a 6 pin connector, but my power supply doesn’t have one. I’m using a Y connector that came with the card.

When did you buy this PC ? Its not uncommon for an old power supply to put out less than 50% of its rated power after a number of years. I’ve been told by our local PC shop technicians, that a lot depends on the make of the power supply, where some have a much better reputation than others.

For example, my PCI (not PCI-e) GeForce 8400GS is recommended to be used in a PC with at least a 300 watt power supply. One of my older PCs with a much larger power supply than that requirement could not power that card properly (it worked fully with the VESA driver and mostly with the nv opensource driver but not properly at all with the proprietary driver). Problem ? A lack of power.

I put the same card in a slightly newer PC with a power supply with substantially less output, and the card worked fine with VESA, nv, and nvidia proprietary driver. But I recall the PC shop technician telling me upon purchase that this second PC had a far superior power supply in terms of life time output. It also cost more than the other PC’s purported more powerful powersupply.

Reference the BIOS output - thats only voltage, and without a current reading to go along with it, in all due honesty I do not think it very relevant.

4 years ago.
So it still might be the PSU… hmm… I do have 4 year old spare PSU that has never been used, but it isn’t a very good one. Maybe I should test it out with that one and see what happens.

Nevermind. It isn’t rated high enough anyway.

Did you also try to reconfigure the X-server, i.e. use sax2?

On which openSUSE is this?

I just replaced the PSU with a brand new one. Unfortunately, this did not solve the problem. I think I can rule out PSU now.


OpenSuse 11.2 with KDE 4.4.1.

You did remember to plug in the power supply to the Graphics card?
Just there was a user here the other week with the same sort of issue.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 4 days 19:51, 4 users, load average: 0.28, 0.20, 0.19
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Do this:
boot into runlevel 3 ( put a ‘3’ on the options line at boot. You’ll see the console’s login prompt.
Login with username and password and issue these commands, post results here:

su -c 'mv /etc/X11/xorg.conf /etc/X11/xorg.conf.obsolete'
(enter root password)
su -c 'init 5 && exit'
(enter root password)

At the login screen, which should be displayed by now, login with username and password. KDE4 should start now.

If this start X attempt with no xorg.conf file does not work, I would like to see what drivers (and kernel) you have installed …

i.e what is the output of:

rpm -qa '*Mesa*'
rpm -qa '*driver*'
rpm -q kernel

Also, noting this possibility:

I don’t suppose you have another PCI-e slot?

I contacted a local friend and tested this video card in his machine. His machine crashed too.
I’m sending this card back.

I would still be worried about that PCI-e slot. Any chance it fried the new card?

Well, that would be a horrible chain of events, wouldn’t it…
I’ll wait for the replacement card, and see what happens from there.
I am very grateful for the assistance. I’ll post back later to let you know how it turns out.

I received a replacement card.
Everything is running perfectly now.

Thanks again everyone.

Good news !! Congratulations.

Thanks for keep us appraised.