Problem with keepassxc

Leap 15.4

Just did upgrade from 15.3 to 15.4 on three desktops and one laptop.
All went well except for keepassxc

Problem repeatable on all machines

Open a web page in firefox.
Navigate to a page requiring a login.
Ensure the cursor is in the username block.
Bring up keepassxc.
Right click on the applicable entry.
Highlight Preform Auto-Type.
Click on Username and Password.
System crashes! Completely.

This action is new for 15.4. It has worked very well in 15.3

I am quite surprised I’m the first to mention this!

Where can I file a bug report for/with Keepass?


Thanks for the link.
I really wish I could figure out the search function so I don’t create duplicate threads! I used the search button and typed Keepassxc. Nothing came up. Where’s a document about using the search?


Uhhhm if you type keepassxc in the upper right corner search field and hit enter you get 42 hits.

Yup! You’re right.
I know I tried that! :slight_smile:
I guess my friend is right when he tells me “That’s what happens when you give kid’s toys to adults”
So, I’ll just hang my head in embarrassment and be quiet.


A followup.

I downgraded my version of keepassxc to 2.6.6 which is still shown in yast. All is well.
I also used zypper al kepassxc to prevent an upgrade.


Not necessarily your fault: if you are not logged in and try to find anything you will find nothing. Been there, done that.

This bug does not appear in Tumbleweed 20220709 with KeepassXC v 2.7.1

I noticed that. Thought it a little strange, but then there are a lot of differences between Leap and Tumbleweed.

Fyi the problem was in the X-Server not in keepassxc 2.7.1. The fix in xorg-x11-server-1.20.3-150400.38.5.1 is now available in the Leap 15.4 update repository.

I have waited for nearly two weeks and still do not find that version as available.

Using yast->Software Management->Search->xorg-x11-server I see under the Installed (Available) column:
xorg-x11-server 1.20.3-150400.36.7 (1.20.3-150200.
xorg-x11-server-extra 1.20.3-150400.36.7 (1.20.3-150200.


zypper lr -d

I think, you have not enabled the SLE-Update Repo:

zypper se -si xorg-x11-server

S  | Name                  | Type  | Version              | Arch   | Repository
i+ | xorg-x11-server       | Paket | 1.20.3-150400.38.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | xorg-x11-server-extra | Paket | 1.20.3-150400.38.5.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
11 | repo-sle-update                       | Update repository with updates from SUSE Linux Enterprise 15                                | Ja        | (r ) Ja         | Ja             |   99      | rpm-md   |    

I found the problem!

A while ago, I had a problem with 15.3 and, somewhere, I found a recommendation to create a text file in /etc/zypp/vars.d/ called releasever that contained a single line with the desired release version. Example ‘15.3’. I did that.

Now, when I do zypper lr -d I can see all the repositories as 15.4 but when I look at them using yast, they are shown as 15.3

That’s why I could not see the correct versions in yast!

Now, I guess I can update the x11 server, remove the lock on keepass and hopefully prevent more problems like this in the future.

Thanks Sauerland for setting me on the correct path!