Problem with IceWM and login screen

Hi everyone, I’m new to OpenSuse,
I use KDE as desktop environment, today when I log into opensuse, I saw there’s “IceWM” available as session type, so I selected “IceWM” and type my password, it didn’t log in and screen went totally black.

I press the power button, it shuts down as usual, i could see the shutdown procedure by pressing “esc”.

So I restarted computer, it boots as usual, everything seems normal in terminal, and I could even see the big logo of nvidia as usual.
But When it goes to login screen, the screen is totally black, but cursor’s able to move, there’s nothing on screen but the cursor. I tried to type my password and hit enter, but nothing happens, I press the power button, it could shutdown as normal.

I restarted in failsafe mode, still the same, screen is black only cursor’s able to move.

Could anyone help me solve this problem?

Thanks a lot!

You are basically booting into your previously booted desktop,

to boot into KDE again you need to choose this option in the same way you did IceWM

Assuming no hardware failure, I’m guessing two possible problems … although the fact failsafe does not work puzzles me.

My guess of 2 possible causes are either:

  • you did a kernel update and your graphic driver was broken, or
  • your PC hard drive is full

Can you boot to run level 3 (full text mode) at all ?

What happens when you reboot and the boot/splash screen first appears and you press 3 so that 3 ends up in the option line. Then select the regular boot.

Does that take you to a log in prompt? If so, login as a regular user. Do NOT login as root. (although if out of space as a regular user, you may have no choice and you may be forced to log in as root). Then type:

df -Th

Note Linux is case sensitive.
do you have lots of space available in both / and /home ?

Can you also type:

rpm -qa --last | grep kernel

that will tell you if there was recent kernel update. Was there one ?

To shutdown/halt from run level 3 as a regular user, type:

su -c 'shutdown -h now'

as root it would be

shutdown -r now

Hi oldcpu:
Thank you very much indeed!
I booted into run level 3
and login as usual
and typed startx
it works!!
Everything works perfectly now !

have a good day!

wow I solved this problem…
I could go into KDE by boot linux in run level 3 and manually “startx”
but my sound card couldn’t work, and if i didn’t boot it in run level3, the black screen still came out…

I just solved this problem by reviewing sysconfig, and reset most settings under “Display manager” to their defaults.

Problem solved, thank you all.
Have a good day!