Problem with FLAC in Amarok

Hi there,

I am having problems with FLAC playback in Amarok, using the Xine backend under 12.1 in KDE4. Xine is from packman and I have tried the last release and the latest one. MP3 playback is fine but FLAC files “play” with no sound. I can use the gstreamer backend as a workaround, but playback isn’t as good, for example replaygain does not work as well and every time I pause and play a track the volume pulsates until I switch track…

Any ideas what is the problem here, it worked until recently

I have no problem playing flac files with Xine/Gstreamer backend in 11.4. You can try the vlc backend.

Xine backend is deprecated & no longer recommended afaik. Gstreamer is OK, but I had crackly sound from it. VLC backend works very nicely, and is actively developed. Try that instead.

Also check your multimedia setup (search mmcheck on the forums, think a user called jcmdaniels has put a lot of work into making it easy).


Thanks for that, had no idea that Xine had been dropped, VLC works better than gstreamer, but replay gain does not seem to be supported, is this correct?


12.1 > Amarok > FLAC > Xine

work here

Note that if one has the user interface for xine called ‘xine-ui’ installed, one can select the xine audio output model.

I tried to install Xine-UI but it doesn’t seem to have any options that are of use, and from what I see the Xine output goes through phonon, obviously this is an issue with Xine not Amarok

??? How so ?? What is your xine video output mode set to ?

an image from xine-ui on my pc](

and a closer look](

Yes. which is why I am focused on helping you tune xine.

Have you installed libxine1-pulse ? libxine1-codecs ? … you ARE using the Packman packaged version of libxine ?


In the “General” Tab in Xine I had to change to “Expert” before I could see all the settings you have available, tried the output on OSS, Pulse and Auto but no luck with any of these, silence in Amarok followed by a crash (segmentation fault)

I have libxine1, -codecs, -gnome-vfs, -jack, -pulse from packman, and phonon-backend-xine, xine-ui and xinetd from Suse OSS repo, all latest version available

From the SuSE OSS repo ? … If there is a Packman packaged version, you need to grab that instead of a SuSE OSS repo version. The SuSE OSS versions are mostly crippled for codecs.