Problem with blender 2.53 on OpenSuse 11.2 (32bit) undefined symbol: gzopen64

Hi Everyone… I have been looking on the net to get a solution to my problem, but I have not found anything. I downloaded the Blender 2.53 Beta Version from, when I run it for first time it run good after made a link to (it requires but opensuse 11.2 doesnot have it)… I used blender for a while and I tried to modify the preference… when I saved and I run blender again it showed it:

./blender: symbol lookup error: ./blender: undefined symbol: gzopen64

Any Idea?.. Thanks so much…

Hello santiagoshang,

After some searching I found this thread on the blender forums: :: View topic - Feedback for 1114_blender25_r23617_64bit on openSUSE 11.1
The problem seems that this version of blender is build for Ubuntu.
Because Ubuntu uses his own modified version of zlib and has AFAIK

The third post explains how to solve it.
Download the Ubuntu zlib source from here:
Extract it somewhere and enter the directory.
Enter these commands:


And now copy these files:

To your blender directory.

Don’t run make install.
This will install that version of zlib over your current install which could cause dependency problems!

If you have any questions feel free to ask!

Good luck!:wink:

Why don’t you simply use the version from the oss-repo? Yafray is offered by oss as well.

Hi Edward… It doesnot work :|… I already had tried that solution… however I retry again with your instructions… The problem comes when I tried to save some configuration or to load a previous saved file.

santiago@linux-ivls:~/Download/blender-2.53-beta-linux-glibc27-i686> ./blender
./blender: symbol lookup error: ./blender: undefined symbol: gzopen64

Answering to gropiuskalle… I don’t use the version of the repository, becuase it’s blender 2.4X… I’m able to use blender 2.49 downloading from the website directly. But now I need to use the 2.53 :|… Oh!, the 2.5 Alpha 2 works fine too :expressionless:

On Ubuntu it works perfectly, however, I don’t wanna chance openSuse. :expressionless:

Hello santiagoshang,

Hi I tried it myself using my own howto and discovered that there are two flaws in it.

  1. The link has a dot on the end causing a 404 error. Here’s the correct link:
  2. I didn’t tell you how to start blender when you’ve installed Ubuntu’s zlib. You need to run this command:

I haven’t tried it on Ubuntu but I noticed that it’s build for Ubuntu causing two problems.
The error and this error.

Good luck!:wink:

Thanks so Much… It worked now… Now I need to learn how to make an script to do it for using it with the Menu :slight_smile: hehehe…

Thank you Edward :slight_smile:

I’m not a Suse user, but a blender activist and I had the same gzopen64 problem; solved it just the same way as Edward_Iii said =)) also made a script and menu entry for the windowmanager. The following text explains how i did it, assuming that blender is not a system-wide installed, but living in my home directory /home/USER/soft/blnder-2.53

Using the supplied script “blender-softwaregl” as referance , I made this (I know it could be simplier, just export and exec, but I decided to follow blender’s developers style =)) ), so here we are:

BF_DIST_BIN=`dirname "$0"`
"$BF_DIST_BIN/$BF_PROGRAM" ${1+"$@"}
exit $exitcode

put those into a new file, in your blender dir, just near the blender executable, name it, for example, “blender-starter”, and make it executable

chmod +x blender-starter

If you wants Menu entry, crate an empty file, name it “blender.desktop”, it should contain something like this

[Desktop Entry]
Comment=3D Content Renderer

and put this file into /usr/share/applications/ or /usr/local/share/applications/ or /home/USER/.local/share/applications/