problem with any USB flash drive

first of all, I just come from windows, so I dont know too much about this S.O

every time I connect any USB flash drive I get the next message:

org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I tried with 2 Kingston USB, and i pod classic and an i pod shuffle, and with all of them I get this message.

this started happening now, in the morning it was working fine,I restarted my PC 3 times and I still get the same message.

please help!

First make sure you have run all updates

open a terminal and type su and then the root password

now type the following:

zypper ref


zypper up

no it did not work:( still having the same problem

Do you have these installed



zorry for the time I take to reply, yeah i have those installed

btw in /media I have lots of folders, 5 for ipod shuffle and the others for my ipod classic, the folders have theyr name but have “_” after the name, it is like this


do you think this have has something with my problem???

/media is where usb devices can be found mounted when plugged in

yahh i know but all this folders have an X and i cant open or delete them

hey guess what

after lots of days looking for the answer, I couldnt find the answer rotfl!rotfl!rotfl!

but is now working, today asked me about some updates, so I update the computer and now it works lol!

thx for the help anyway

I am not sure if I should ask this question, sorry if its the wrong place but my problem is very similar except I made my USB bootable to load opensuse and now I want to remove these files so I can use the USB as normal again. My problem is that I cannot seem to remove any folders or files from the USB as it says I don’t have any permission. I have added myself to the users permission group, tried changing the permissions on the drive, tried reformatting the drive with partition manager but nothing seems to work.
I would be very grateful for your help with regards to this.
Many thanks in advance.

As su -

be careful to enter the right device: eg: sdb, sdc… whatever the usb is

dd if=/dev/urandom of=/dev/sdb

(where sdb is the usb)

You can now format with gparted or similar