Problem with Anjuta

I’ve updated OpenSUSE 11.0 to 11.1 and when I run Anjuta (version 2.24.1 included in OpenSUSE 11.1) don’t appear text editor. In OpenSUSE 11.0 Anjuta (version 2.4.0) runs correctly.


By text editor, you mean the program that you are asked to choose when you open an existing project? If so, I recall there are 2 of them (sorry I have not used Anjuta in a while so I don’t remember their names), you might try installing them from YaST.


Thanks for your answer. I have installed GTKSourceView and the problem continues. In my case Anjuta doesn’t ask me about text editor. I think that problem is with plugins because with OpenSUSE 11.0 and Anjuta 2.4.0 in preferences menu appeared Scintilla Plugin and now no. I don’t know if this problem is only in my computer or happens everybody.



so does it work now? I hope it does. Otherwise, I think you should check if you can add the needed editors one by one (or just the one you wish to use) and then restart Anjuta. Or is it any dependency problem?

I installed Anjuta time ago with openSUSE 11 and never had a problem with the editors so you are right, it works there ;). Now I don’t have installed GNOME so I could not tell if there is any problem with the openSUSE latest release =(.

Kind regards.

No, Anjuta doesn’t work in 11.1. I’ve tried as well. The editor does not show, it cannot open files, it cannot create files. I’d report the errors to OpenSuse, but I’m not sure where to forward them.

While opening Anjuta:

(anjuta:13361): GLib-GIO-CRITICAL **: g_file_get_uri: assertion `G_IS_FILE (file)’ failed

(anjuta:13361): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)’ failed
I/O warning : failed to load external entity “/home/blahblahblah/.local/share/anjuta/macro.xml”

While trying to create a file:

(anjuta:13361): libanjuta-WARNING **: No plugin found implementing IAnjutaEditorFactory Interface.

(anjuta:13361): libanjuta-interfaces-CRITICAL **: ianjuta_editor_factory_new_editor: assertion `IANJUTA_IS_EDITOR_FACTORY(obj)’ failed

Eclipse is looking like a good alternative right now. :wink:


seems like not even google knows the answer =(. What if you try ot to install this version of Anjuta but an older release?

Sorry I cannot be helpful.

Kind regards.

Thanks for answers

I work full time and am currently taking 4 university level courses. Trust me when I say that I don’t have the time to mess around with the system. I installed a few other IDEs and am using Eclipse right now. Plus, I’ve got Visual Studio in a VirtualBox install of Windows. Between those two IDEs all my school projects are covered. :wink: That’s good enough for me.

Hopefully OpenSuse will fix Anjuta and some of the other bugs I’ve been seeing some time before the next release. :slight_smile:

I was talking about an older version of Anjuta, I dont think I explained myself well there =D.

I remember (a year ago or so) I was yet another ubuntu user and had problems with the latest release of Anjuta, and installing the older one worked fine. Never cared about messing with the system ;).

How fast does Eclipse run on your machine? On mine it’s just slow, so Netbeans (for java projects) is a better choice for me (con is that you need the JDK). Sometimes I use Geany for C/C++.


Eclipse actually runs faster than Netbeans on my machine. Netbeans was really sluggish the first few times I used it. Not it runs well though. Both are nice IDEs.

Yes, both are nice, but I just could never get used to Eclipse, which has a lot of plugins. Netbeans seems to be more straight forward and runs faster on my machine.


There is a version of Anjuta that runs correctly in OpenSUSE WebPage. You need to enter in Get Software, now in the right side of the screen there is a link “Package Search”, you click it. At this moment appears a dialog search, you select OpenSUSE 11.1 and search Anjuta. There are several results, now you must install Anjuta-2.24.1-11.1.i586.rpm, and all is correct.

Nice, I’m going to try that right now.:slight_smile:

Please, let us know how it went.

No go. No matter which version I install from the official repositories I get the same result. So sad. >:(

You must download rpm file and install it manually. Don’t use button “1-click install” my first choice was to use it and result was bad.


>:)I have the same trouble at my openSUSE 11.1>:)

You could always install alien using Yast and then download the latest Ubuntu package for anjuta.

Then execute alien -r anjuta-x.x.deb

This will transform the debian package into an rpm

Then install the rpm using rpm -Uvh anjuta-x.x.x.rpm

Thanks. But I think it’s not a correct solution (dependencies, etc.).

Well thats how I installed it.

Also note that being an rpm it will ensure that any needed dependencies are there before installing ( just like the original deb package), thats how yast manages dependencies is via the rpm database.

Your only other option is building it from source which if you can get it to build on 11.1 please let me know how you did it because I could not get it to build. Note if you go this root you’ll have to create a new sym link in /usr/lib/pkgconfig ( /usr/lib64/pkgconfig on 64 bit)from gdl-1.0.pc to gdl-gnome-1.0.pc. Or configure will say gdl isn’t there.