Problem upgrading xen guest from 11.0

Hello,
I have been trying for the last couple of days to upgrade a Xen guest running on Xen Server 5.5 from 11.0 to a more recent version. I have tried both 11.3 and 11.1.

The upgrade seems to take, but it fails on the initial boot. It seems that it is expecting the root partition to be on /dev/sda2 - however I believe it is supposed to be /dev/xvda2.

Initially when fstab had /dev/xvda2 I had a warning, so I changed fstab through yast to use the drives uuid.

I’ve also tried zypper dup - but that gave all sorts of dependancy errors.

For kicks, I thought I might try 11.4 next.

Am I out of luck and should just go with a fresh install?

Thanks.

Don’t know how useful this is - especially the first part. Here’s the latest output from trying to upgrade 11.0 to 11.3:

0.000000] Initializing cgroup subsys cpuset
0.000000] Initializing cgroup subsys cpu
0.000000] Linux version 2.6.34-12-xen (geeko@buildhost) (gcc version 4.5.0 20100604 [gcc-4_5-branch revision 160292] (SUSE Linux) ) #1 SMP 2010-06-29 02:39:08 +0200
0.000000] Command line: xencons=ttyS console=ttyS
0.000000] Xen-provided physical RAM map:
0.000000]  Xen: 0000000000000000 - 0000000100000000 (usable)
0.000000] NX (Execute Disable) protection: active
0.000000] last_pfn = 0x100000 max_arch_pfn = 0x80000000
0.000000] init_memory_mapping: 0000000000000000-0000000100000000
0.000000] RAMDISK: 008af000 - 02048000
0.000000] ACPI in unprivileged domain disabled
0.000000] Zone PFN ranges:
0.000000]   DMA      0x00000000 -> 0x00001000
0.000000]   DMA32    0x00001000 -> 0x00100000
0.000000]   Normal   empty
0.000000] Movable zone start PFN for each node
0.000000] early_node_map[1] active PFN ranges
0.000000]     0: 0x00000000 -> 0x00100000
0.000000] setup_percpu: NR_CPUS:512 nr_cpumask_bits:512 nr_cpu_ids:4 nr_node_ids:1
0.000000] PERCPU: Embedded 19 pages/cpu @ffff88000204f000 s46952 r8192 d22680 u77824
0.000000] pcpu-alloc: s46952 r8192 d22680 u77824 alloc=19*4096
0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
0.000000] Swapping MFNs for PFN 75b and 2055 (MFN 211b5d and 371463)
0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 1034240
0.000000] Kernel command line: xencons=ttyS console=ttyS
0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
0.000000] Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
0.000000] Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
0.000000] Software IO TLB disabled
0.000000] Subtract (33 early reservations)
0.000000]   #1 [00008af000 - 0002048000]    Xen provided
0.000000]   #2 [0000002000 - 000088e068]   TEXT DATA BSS
0.000000]   #3 [0002864000 - 0003069000]         PGTABLE
0.000000]   #4 [0003069000 - 0006869000]         BOOTMEM
0.000000]   #5 [0006869000 - 0006869008]         BOOTMEM
0.000000]   #6 [0006869040 - 00068691c0]         BOOTMEM
0.000000]   #7 [00068691c0 - 0006869340]         BOOTMEM
0.000000]   #8 [0006869340 - 0006881340]         BOOTMEM
0.000000]   #9 [0006882000 - 0006883000]         BOOTMEM
0.000000]   #10 [0006883000 - 0006884000]         BOOTMEM
0.000000]   #11 [0006884000 - 0006885000]         BOOTMEM
0.000000]   #12 [0006885000 - 0007085000]         BOOTMEM
0.000000]   #13 [0002848000 - 0002864000]    Xen provided
0.000000]   #14 [0002048000 - 0002048028]         BOOTMEM
0.000000]   #15 [0002048040 - 0002048060]         BOOTMEM
0.000000]   #16 [0002049000 - 000204a000]         BOOTMEM
0.000000]   #17 [000204a000 - 000204b000]         BOOTMEM
0.000000]   #18 [000204b000 - 000204c000]         BOOTMEM
0.000000]   #19 [000204c000 - 000204d000]         BOOTMEM
0.000000]   #20 [0002048080 - 000204809a]         BOOTMEM
0.000000]   #21 [00020480c0 - 00020480da]         BOOTMEM
0.000000]   #22 [000204f000 - 000209b000]         BOOTMEM
0.000000]   #23 [0002048100 - 0002048108]         BOOTMEM
0.000000]   #24 [0002048140 - 0002048148]         BOOTMEM
0.000000]   #25 [0002048180 - 0002048190]         BOOTMEM
0.000000]   #26 [00020481c0 - 00020481e0]         BOOTMEM
0.000000]   #27 [0002048200 - 0002048300]         BOOTMEM
0.000000]   #28 [0002048300 - 0002048348]         BOOTMEM
0.000000]   #29 [0002048380 - 00020483c8]         BOOTMEM
0.000000]   #30 [000209b000 - 00020a3000]         BOOTMEM
0.000000]   #31 [00020a3000 - 00024a3000]         BOOTMEM
0.000000]   #32 [00024a3000 - 00026a3000]         BOOTMEM
0.000000] Memory: 4080912k/4194304k available (4180k kernel code, 0k absent, 113392k reserved, 3313k data, 356k init)
0.000000] Hierarchical RCU implementation.
0.000000] NR_IRQS:34880 nr_irqs:2416
0.000000] Xen reported: 2493.780 MHz processor.
0.000000] Console: colour dummy device 80x25
0.000000] console [ttyS0] enabled
0.080016] Calibrating delay using timer specific routine.. 4990.57 BogoMIPS (lpj=9981147)
0.080129] Security Framework initialized
0.080157] AppArmor: AppArmor initialized
0.080188] Mount-cache hash table entries: 256
0.080316] Initializing cgroup subsys ns
0.080321] Initializing cgroup subsys cpuacct
0.080324] Initializing cgroup subsys memory
0.080335] Initializing cgroup subsys devices
0.080338] Initializing cgroup subsys freezer
0.080340] Initializing cgroup subsys net_cls
0.080343] Initializing cgroup subsys blkio
0.080424] SMP alternatives: switching to UP code
0.101105] Unpacking initramfs...
0.122247] Freeing initrd memory: 24164k freed
0.131705] Brought up 1 CPUs
0.131832] devtmpfs: initialized
0.132066] regulator: core version 0.5
0.132097] regulator: dummy: 
0.151961] Time: 165:165:165  Date: 165/165/65
0.152090] NET: Registered protocol family 16
0.152268] SMP alternatives: switching to SMP code
0.256039] Brought up 4 CPUs
0.256511] PCI: Fatal: No config space access function found
0.256517] PCI: setting up Xen PCI frontend stub
0.256860] bio: create slab <bio-0> at 0
0.256860] ACPI: Interpreter disabled.
0.256860] suspend: event channel 15
0.256860] xen_mem: Initialising balloon driver.
0.256860] vgaarb: loaded
0.256860] PCI: System does not support PCI
0.256860] PCI: System does not support PCI
0.256860] NetLabel: Initializing
0.256860] NetLabel:  domain hash size = 128
0.256860] NetLabel:  protocols = UNLABELED CIPSOv4
0.256860] NetLabel:  unlabeled traffic allowed by default
0.256860] Switching to clocksource xen
0.257524] AppArmor: AppArmor Filesystem Enabled
0.257545] pnp: PnP ACPI: disabled
0.257868] NET: Registered protocol family 2
0.257973] IP route cache hash table entries: 131072 (order: 8, 1048576 bytes)
0.258614] TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
0.260144] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
0.260553] TCP: Hash tables configured (established 262144 bind 65536)
0.260563] TCP reno registered
0.260570] UDP hash table entries: 2048 (order: 5, 131072 bytes)
0.260621] UDP-Lite hash table entries: 2048 (order: 5, 131072 bytes)
0.260835] NET: Registered protocol family 1
0.261018] platform rtc_cmos: registered platform RTC device (no PNP device found)
0.261478] audit: initializing netlink socket (disabled)
0.261495] type=2000 audit(1286306673.029:1): initialized
0.288296] VFS: Disk quotas dquot_6.5.2
0.288336] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
0.288566] msgmni has been set to 2048
0.288998] alg: No test for stdrng (krng)
0.289066] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
0.289071] io scheduler noop registered
0.289073] io scheduler deadline registered
0.289114] io scheduler cfq registered (default)
0.289233] pci-stub: invalid id string ""
0.290338] Non-volatile memory driver v1.3
0.290404] Xen virtual console successfully installed as ttyS0
0.290446] Fixed MDIO Bus: probed
0.290479] PNP: No PS/2 controller found. Probing ports directly.
0.291297] i8042.c: No controller found.
0.291338] mice: PS/2 mouse device common for all mice
0.291487] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
0.291732] TCP cubic registered
0.291860] NET: Registered protocol family 10
0.292278] lo: Disabled Privacy Extensions
0.292532] registered taskstats version 1
0.292564] PCI IO multiplexer device installed.
0.292576]   Magic number: 1:252:3141
0.292587] XENBUS: Device with no driver: device/vbd/51728
0.292589] XENBUS: Device with no driver: device/vbd/51712
0.292591] XENBUS: Device with no driver: device/vbd/51760
0.292593] XENBUS: Device with no driver: device/vif/0
0.292594] XENBUS: Device with no driver: device/vif/1
0.292597] /usr/src/packages/BUILD/kernel-xen-2.6.34/linux-2.6.34/drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
0.292741] Freeing unused kernel memory: 356k freed
0.292918] Write protecting the kernel read-only data: 7100k

doing fast boot
FATAL: Error inserting thermal (/lib/modules/2.6.34-12-xen/kernel/drivers/acpi/thermal.ko): No such device
0.361102] SCSI subsystem initialized
FATAL: Error inserting fan (/lib/modules/2.6.34-12-xen/kernel/drivers/acpi/fan.ko): No such device
0.426123] xen-vbd: registered block device major 202
0.426495] xvdb: xvdb1
0.435869] Setting capacity to 20971520
0.435874] xvdb: detected capacity change from 0 to 10737418240
0.436485] xvda: xvda1 xvda2 xvda3
0.444056] Setting capacity to 146800640
0.444062] xvda: detected capacity change from 0 to 75161927680
0.448355] blkfront: xvdd: barriers enabled
0.467014] Setting capacity to 8776436
0.467020] xvdd: detected capacity change from 0 to 4493535232
0.531183] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
0.531189] EDD information not available.
FATAL: Error inserting edd (/lib/modules/2.6.34-12-xen/kernel/drivers/firmware/edd.ko): No such device
0.547748] netfront: Initialising virtual ethernet driver.
Creating device nodes with udev
udevd[124]: can not read ‘/etc/udev/rules.d/70-persistent-net.rules’

0.658089] udev: starting version 157

mount: devpts already mounted or /dev/pts busy
mount: according to mtab, devpts is already mounted on /dev/pts
Boot logging started on /dev/char/…/ttyS0(/dev/console) at Tue Oct 5 15:24:33 2010
Waiting for device /dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2 to appear: …Could not find /dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2.
Want me to fall back to /dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2? (Y/n)
y
Waiting for device /dev/disk/by-id/ata-QEMU_HARDDISK_QM00001-part2 to appear: …not found – exiting to /bin/sh
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell