Problem updating Suse 10.3

Whenever i try to update, i get this message. i dont really know what to do, i googled it and i didnt get anything that really helped. so yeah, any help is greatly appreciated.

"2 Problems: Problem: No valid solution found with just resolvables of best architecture. Problem: atom:glibc-devel cannot be installed due to missing dependencies Problem: No valid solution found with just resolvables of best architecture. With this run only resolvables with the best architecture have been regarded. Regarding all possible resolvables takes time, but can come to a valid result. Solution 1: Make a solver run with ALL possibilities. Regarding all resolvables with a compatible architecture. "

Apparently some of your updates require other packages, and these requirements cannot be met. We need a little bit more info about the system concerned, see my signature.
Please also post which repos you’ve got enabled.

Intel P4 2.8 GHz, 1.7 gb Ram , 2 40 gb hdds, and one 80 gb(windows). Vanta tnt2 videocard, Opensuse 10.3, and Windows XP, kernel, kde 3.5.7

Thank you for your reply. It didn’t help much though. See, what we need, other than that info is, what are you updating? What repos do you have?

idk what is being updated. i just reinstalled Suse for the first time in like 10 months. i got my wireless working, then i go to update, and theres like 200 updates. when i click okay or whatever, it says the package might install a new kernel or somethin like that. i click accept like 5 or 6 times to that and then i enter the root password. then i get that error.

my repos are
Index of /update/10.3
Index of /distribution/10.3/repo/oss

Find the YaST log and paste that. (Yes I know where it is, but I want you to find it). Second, open up YaST>Software Management, and use the drop down menu on the left to change to update. Then click to update each package one at a time. Yes, time consuming, but then you’ll know what’s causing the problem. You also need more repos. Additional YaST Package Repositories - openSUSE

Update zypp or whatever backend there is first then update all packages?

i see alot of yast logs in var/log/yast, but which one should i copy and paste? one of them is like 6 mb

oh, and i just disabled the packages that require reboot, and it worked, but idk if those packages will still install

If you disabled those packages, then no. Now go back and install those 6 packages, one at a time. When you get an error read the entire dialog box. Then search for the dependencies here This will reveal if there are any other repos you need, other than the previous page I gave you.

As to which log, it’s this one /var/log/YaST2/y2log
Another good file to look at is /var/log/zypp/history

Is there a reason you stick to 10.3 ? Updating all files that have been updated since release date must last hours. Why not download 11.1 and install that. It will handle your hardware fine.

Let’s focus on the issue at hand. If the OP wanted to go to 11.1 they would have. Whatever the reason is, at this point, it doesn’t matter and is irrelevant to us. Having said that, EOL maybe coming soon, so upgrading to 11.1 or 11.2 (when it is released) would be wise.

The best advise on this would be to upgrade to 11 series it will know the system automatically and it will take care of the problem for you also enable the community repositories this seems to handle most dependency problems just fine , and it will work on most systems.