Problem printing to a Canon Mx330 series printer.

I am running KDE under openSUSE 11.1 and am having problems printing to a Canon MX330 series printer.
I just re-installed Linux and went to Cups to define my printer.
I went to the Admin screen and selected “Find New Printers”.
There were four selections for my Canon Mx330.
I selected the one that read "Canon_Mx330_series_USB_1.
On the next screen, where I did not find my printer model, I selected the entry for an Mp380.
The next screen told me that my printer has been successfully defined.
I next selected the Printers tab in Cups and set the printer as default.
I then tried to print a test page.
While watching the printer, I saw the message “Printing from PC” and then nothing.
The job is flagged as complete under Linux.
This, and the fact that the printer works in Windows, leads me to believe that the print stream is reaching the printer, but is being rejected by that device, probably because the model is wrong.
Yast shows –

| Local | Canon_MX330_series_USB_1 | Canon MX330 series | Local printer | Yes | Ready |

Thanks in advance,

Canon driver support for Linux is not so good.
I have no idea if the MP380 driver (what you probably selected) is appropriate for the MX330

You may find a driver here:[SOLVED] Driver for Canon Pixma MX330 - Ubuntu Forums](

Of course you probably already know that openSUSE 11.1 is sort of out of date, so current help might be hard to come by.

Personally, I find adding/managing printers via YAST - Printers a bit easier than via CUPS interface, but the end result is the same.

Good luck

Driver for Canon MX 330:

It’s probably of no use to you in Opensuse 11.1 - but there does appear to be a driver for this printer included in 12.2

Thanks, Sauerland, for your reply.
I downloaded the driver labeled MX330series IJ Printer Driver Vre 3.10 for Linux (rpm…) and extracted the files to my /home directory under the directory name of cnijfilter-mx330series-3.10-1-i36-rpm.
When I was finished, I had an file and a directory named Packages.
In packages are two files: cnijfilter-common-3.10-1.i386.rpm and cnijfilter-mx330series-3.10-1.i386.rpm.
It so happens that last night I found a post I had entered a few years ago about setting up an Mx330. I can’t find the post today. (?)
In any case, the advice at the time was to copy the two files in packages to /usr/local/rpm after first creating the rpm directory.
Next, the advice said to execute YAST → SOFTWARE → SOFTWARE MANAGEMENT and search for “cnij”.
I did this, but the search found nothing.
Is this because I created /usr/local/rpm out of this air?

I believe that I have to setup /usr/local/rpm as a repository, but have no idea how to do that.

Your making this harder than it needs to be. Navigate with your file manager to the directory where the RPM’s are located, right-click on the the ‘common’ file and install with ‘Open With’>‘Install/Remove Software’. Then do the same with the other RPM. That should be all that is required. When you configure CUPS via the web interface or YaST, the new model should be available to choose from.

Thanks, Deano, for your reply.
As it turns out, the post I was quoting from was made by you, two years ago.
I did as you suggested and used Open With’>‘Install/Remove Software’ to install both drivers. I checked in Yast and saw that they were installed.
I next tried to print a test page, but got the message “Filter pstocanonij for printer canontest not available. No such file or directory”.
At this point, you wrote –
“I think there was a earlier post about this possible problem and the cause is that CUPS, on a 64 bit system, looks in /usr/lib64 for some components instead of /usr/lib where the Canon rpms store them. Decided to do a naughty and copied pstocanonif from /usr/lib/cups/filter to /usr/lib64/cups/filter.”
Made the copy, and successfully printed a test page.
Thanks again,

After you install the rpm you will not be able to print right away
You have to go to the yast printer then configure printing before you can print.
The rpm that you install will give you your canon printer model to be present
in your printer selections.

With the 64 bit looking from a different directory you have to link the two directories
so it will be able to function. This is what I did when I was still using a canon printer with 64 bit

Hi, for the solution of this problem you must have to re-install the canon printer’s driver and update it while connecting with the internet… By doing so your problem will surely be solved and you may get prints according to your requirements…

sticker printing

That’s dirty. Baaaad Canon. They suck. Nice Camera’s though. check out Canon Cameras Price in Pakistan