Problem Packman Repository

I’ve been having problems with the Packman Repository for a week, I tried to change Mirror, but the result doesn’t change

@enziosavio might be better to ask on their Support Mailing List https://lists.links2linux.de/cgi-bin/mailman/listinfo/packman

Thanks , first I would like to know if I am the only one who finds problems with the Packman Repository . Because if the problem is only mine I have to look for the solution elsewhere.

Everything OK here in Italy using mirror

(http://ftp5.gwdg.de/pub//linux/packman/suse/openSUSE_Tumbleweed/)
1 Like

As long as you do not show the URL you use, all here is guessing.

I don’t know what’s happening, all the repositories time out, and are not accessible, I did a connection test and it’s fine 95 mega Download 20 mega Upload

enziosavio@localhost:~> zypper lr -u
Priorità del repository effettive:                                                                                              (Vedere 'zypper lr -P per ulteriori dettagli)
      50 (priorità aumentata)  :  1 repository
      99 (priorità di default) :  2 repository
     105 (priorità diminuita)  :  1 repository

# | Alias                             | Name           | Enabled | GPG Check | Refresh | URI
--+-----------------------------------+----------------+---------+-----------+---------+-------------------------------------------------------------------------------------
1 | download.opensuse.org-non-oss     | Repository p-> | Sì      | (r ) Sì   | Sì      | http://download.opensuse.org/tumbleweed/repo/non-oss/
2 | download.opensuse.org-oss         | Repository p-> | Sì      | ( p) Sì   | Sì      | http://download.opensuse.org/tumbleweed/repo/oss/
3 | ftp.gwdg.de-openSUSE_Tumbleweed_1 | Packman Repo-> | Sì      | (r ) Sì   | Sì      | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
4 | home_wkazubski_G03                | home:wkazubs-> | Sì      | ( p) Sì   | Sì      | https://download.opensuse.org/repositories/home:/wkazubski:/G03/openSUSE_Tumbleweed/
enziosavio@localhost:~> 


A connection test is something like

henk@boven:~> ping -c1 ftp.gwdg.de
PING ftp.gwdg.de(ftp6.gwdg.de (2001:638:60f:110::1:2)) 56 data bytes
64 bytes from ftp6.gwdg.de (2001:638:60f:110::1:2): icmp_seq=1 ttl=50 time=21.3 ms

--- ftp.gwdg.de ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 21.298/21.298/21.298/0.000 ms
henk@boven:~> 

Another text you can do is putting this in the addressbar of a browser.

enziosavio@localhost:~> ping -c1 ftp.gwdg.de
PING ftp6.gwdg.de (134.76.12.6) 56(84) bytes of data.
64 bytes from ftp6.gwdg.de (134.76.12.6): icmp_seq=1 ttl=50 time=23.7 ms

--- ftp6.gwdg.de ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 23.658/23.658/23.658/0.000 ms

I don’t understand, I stop the updates, not only Packman but every repository times out.

@enziosavio What about;

curl -v http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/repodata/repomd.xml.asc
curl -v http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/repodata/repomd.xml.asc
* Host ftp.gwdg.de:80 was resolved.
* IPv6: 2001:638:60f:110::1:2
* IPv4: 134.76.12.6
*   Trying 134.76.12.6:80...
* Connected to ftp.gwdg.de (134.76.12.6) port 80
> GET /pub/linux/misc/packman/suse/openSUSE_Tumbleweed/repodata/repomd.xml.asc HTTP/1.1
> Host: ftp.gwdg.de
> User-Agent: curl/8.7.1
> Accept: */*
> 
* Request completely sent off
< HTTP/1.1 200 OK
< Server: nginx
< Date: Wed, 10 Apr 2024 16:38:13 GMT
< Content-Type: application/octet-stream
< Content-Length: 836
< Last-Modified: Tue, 09 Apr 2024 22:33:35 GMT
< Connection: keep-alive
< ETag: "6615c23f-344"
< Strict-Transport-Security: max-age=63072000; includeSubDomains; preload
< X-Frame-Options: SAMEORIGIN
< X-Content-Type-Options: nosniff
< Accept-Ranges: bytes
< 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAABAgAGBQJmFcI/AAoJEEWh0GcavRr7v0IQAJ02VUd6evlpbt98C9vdfud1
HwMIPCR5OBhTjzXaFHz/I16268Mc6CuqlM3z2FnnGB/ScHhOPnTvXMyp1afSQcSX
gmUHZ1wc5cmCIEWWXRn74dVE81Uu+URSsr99PQWQvolfzTOqgKpin8FAwS5Ae+bn
M3k6bQtxLPbaMBstZTNevHq4gyZ0EUx4aYz+G0jB8ppegiPJgR+oTFhl+BM70WTY
gp+hHwYzFNbbZp+6m4DHyaQTIM/D+nsf5thkIJNe2BjMvDUCalnyoYIxicdrPivl
QLTCFgFM5KOwYDHXukapishm0MVp2BcMgAautVN+QWsA7CrhfgkrCuD3h4KON/Bk
n9Xhx/0lc4roW2AinV2y/AdcqiCD27ShBRdP+8POhpf2f1l4ST6FTOzpBOqVEi7c
bsAXQP/kbE3R+qtSF3gB2RIdTqltufUN+Z7DyxHqiFf2vPcd+Ut9yOcrV4xa9TOT
uLntzmraaQtDFHfC0NSoIgQ1cSQxMKc+pWAfwpxafxRaKUsiUi8MtH4fuv0W54k4
v4laUkiF3m/eIllzRq1I++T6xWM14b4husv5X/Qg5enNBkI6HV7ppR7aF5egOvik
9DHR4ymreOGx+ETaaZEugjaf0Q9x+VMQeYTGAmFMmEZJSqKkNsAWHL/JPT6D7rwC
eJXhOxDKwFmXaCCxmvbs
=XmJ7
-----END PGP SIGNATURE-----
* Connection #0 to host ftp.gwdg.de left intact

@enziosavio so that’s all good then… If you force a refresh zypper -vvv ref -fdoes that work ok?

I’m updating now, it’s a strange thing, it downloads 5 or 20 very fast packages and then it times out, I have to keep ticking “r”, try again and start again

I can’t get out of this situation, I have to waste hours updating a few packages, it always times out

Never wasted time on packman repos. You may try and test:

erlangen:~ # zypper repos Packman
Alias          : Packman
Name           : Packman
URI            : https://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/
Enabled        : Yes
GPG Check      : (r ) Yes
Priority       : 90 (raised priority)
Autorefresh    : On
Keep Packages  : On
Type           : rpm-md
GPG Key URI    : 
Path Prefix    : 
Parent Service : 
Keywords       : ---
Repo Info Path : /etc/zypp/repos.d/Packman.repo
MD Cache Path  : /var/cache/zypp/raw/Packman
erlangen:~ # 

Their site has impressive reliability.

http://ftp.fau.de/about.html#english

Unable to find repository ‘Packman’ by alias, number or URI. This is the response to that command

May I please point to the fact that the OP already has an entry for the “Packman repo”, see from his post #

And that adding it anew with different Name an Alias will only make his repo list more messy?

@enziosavio
Please take care, @karlmistelberger tends to post things as they appear in his own shop. That may have nothing to do with your situation.

When you address the Packman repo in a zypper statement you should use the Nam, Alias or Number as they are in the repo list on your system. Nothing else.

1 Like

And to add, Karl did not even care to read the output from the TO and description, where easily can be seen that the timeout also occurs with OSS repo.

So the issue is not even related to packman only, but to some network issues in general…

Mhaa, I also called my internet provider, asking if there were problems with certain URLs or internet addresses, now I have also changed the oss and non/oss repositories, I deleted the keys and accepted them again, now I’m waiting for a new update to check