problem of bumblebee in 13.1 x86_64

And what was the last update?
Did you use Bumblebee when it was working or not?

File Xorg.0.log is too long I left only intel echos

Unfortunately you stripped out the (probably) interesting part.

Please upload the whole file to http://susepaste.org or something similar and post a link.

Does X work when you select “Recovery Mode” in “Advanced Options” in the boot menu?
You could boot to that after a failed standard boot, and post /var/log/Xorg.0.log.old then.

I worked in suspend mode for lot so I guess it is untill last kernel update to 3.11.10-7

Please upload the whole file to http://susepaste.org or something similar and post a link.

http://susepaste.org/38105052

Does X work when you select “Recovery Mode” in “Advanced Options” in the boot menu?
You could boot to that after a failed standard boot, and post /var/log/Xorg.0.log.old then.

No X doesen’t work either in recovery mode

Hm, there’s no error in that log.
But it is from Sunday Feb 23 17:58:25 2014, was this the last time you booted successfully?

So apparently X isn’t even started, the system hangs/crashes before that.
Could you please provide /var/log/messages then?

Can you login in text mode (press Ctrl+Alt+F1 f.e.) and start X manually?

sudo rcxdm start

I run the command to start manually X. Nothing happened the system response was:

redirecting to systemctl start xdm.service

With X not working I don’t know how to mount an USB pen to download the /var/log/messages file I’ll do it as soon as possible

Hm, what does “sudo systemctl status xdm.service” say?

Which display manager are you using? (DISPLAYMANAGER setting in /etc/sysconfig/displaymanager)
Try to set the to “xdm” as a test.

With X not working I don’t know how to mount an USB pen to download the /var/log/messages file I’ll do it as soon as possible

You should be able to mount it with something like:

sudo mount /dev/sdc1 /mnt

To find out which device you need to specify instead of /dev/sdc1, run “dmesg | tail” after you connected it.
You should see something like this:

dmesg|tail
 7339.530339] sd 5:0:0:0: [sdg] No Caching mode page found
 7339.530346] sd 5:0:0:0: [sdg] Assuming drive cache: write through
 7339.535227] sd 5:0:0:0: [sdg] No Caching mode page found
 7339.535237] sd 5:0:0:0: [sdg] Assuming drive cache: write through
 7339.679375]  sdg: sdg1
 7339.682199] sd 5:0:0:0: [sdg] No Caching mode page found
 7339.682208] sd 5:0:0:0: [sdg] Assuming drive cache: write through
 7339.682215] sd 5:0:0:0: [sdg] Attached SCSI removable disk

In this case it means that the newly connected device is /dev/sdg, and the partition /dev/sdg1 was found, so I would have to use /dev/sdg1 to mount it.

/var/log/boot.log might be helpful as well.

First of all thank you very much for your support.
This is the link of the messages file:

URL: http://susepaste.org/84689138

One of my try was to install the nvidia driver from the nvidia website.
Here the content of displaymanager file

## Path:        Desktop/Display manager
## Type:        string(Xorg)
## Default:     "Xorg"
#
DISPLAYMANAGER_XSERVER=X.x11-video-nvidiaG03
## Path:    Desktop/Display manager
## Description:    settings to generate a proper displaymanager config

## Type:    string(kdm,kdm3,kdm4,xdm,gdm,wdm,entrance,console)
## Default:    ""
#
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/entrance/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="gdm"

## Type:    yesno
## Default:    no
#
# Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note
# that a modified kdm or xdm configuration, e.g. by KDE control center
# will not be changed. For gdm, values will be updated after change.
# XDMCP service should run only on trusted networks and you have to disable
# firewall for interfaces, where you want to provide this service.
#
DISPLAYMANAGER_REMOTE_ACCESS="no"

## Type:    yesno
## Default:    no
#
# Allow remote access of the user root to your display manager. Note
# that root can never login if DISPLAYMANAGER_SHUTDOWN is "auto" and
# System/Security/Permissions/PERMISSION_SECURITY is "paranoid"
#
DISPLAYMANAGER_ROOT_LOGIN_REMOTE="no"

## Type:    yesno
## Default:    yes
#
# Let the displaymanager start a local Xserver.
# Set to "no" for remote-access only.
# Set to "no" on architectures without any Xserver (e.g. s390/s390x).
#
DISPLAYMANAGER_STARTS_XSERVER="yes"

## Type:        yesno
## Default:     no
#
# TCP port 6000 of Xserver. When set to "no" (default) Xserver is
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Remote X service should run only on trusted networks and
# you have to disable firewall for interfaces, where you want to
# provide this service. Use ssh X11 port forwarding whenever possible.
#
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="no"

## Type:    string
## Default:
#
# Define the user whom should get logged in without request. If string
# is empty, display standard login dialog.
#
DISPLAYMANAGER_AUTOLOGIN=""

## Type:        yesno
## Default:     no
#
# Allow all users to login without password, but ask for the user, if
# DISPLAYMANAGER_AUTOLOGIN is empty.
#
DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"

## Type:        yesno
## Default:     no
#
# Display a combobox for Active Directory domains.
#
DISPLAYMANAGER_AD_INTEGRATION="no"

## Type:    list(root,all,none,auto)
## Default: auto
#
# Determine who will be able to shutdown or reboot the system in kdm.  Valid
# values are: "root" (only root can shutdown), "all" (everybody can shutdown),
# "none" (nobody can shutdown from displaymanager), "auto" (follow
# System/Security/Permissions/PERMISSION_SECURITY to decide: "easy local" is
# equal to "all", everything else is equal to "root").  gdm respects the
# PolicyKit settings for ConsoleKit. Shutdown configuration can be done via
# the polkit-default-privs mechanism.
#
DISPLAYMANAGER_SHUTDOWN="auto"

The standard nvidia driver doesn’t work on Optimus systems.
Have you removed it again?

Here the content of displaymanager file

## Path:        Desktop/Display manager
## Type:        string(Xorg)
## Default:     "Xorg"
#
DISPLAYMANAGER_XSERVER=X.x11-video-nvidiaG03

I think this is the culprit.
This obviously can only work when the nvidia driver RPMs are installed.
So either you didn’t uninstall them correctly, or there is a bug in the uninstallation.

Change that to “Xorg” (with the quotes) and it should work again.

I haven’t yet looked at your /var/log/messages because I really think this is the issue.

I used the uninstall option of the nvidia shell script.

I did it but still not working. The Xorg.0.log file is still unchanged

That installer also overwrites some files needed by xorg, although I believe x should start anyway, but maybe your desktop requires DRI to start, run the following to restore it:

zypper in -f xorg-x11-server

I doubt that’s the reason in this case, as X does not even try to start (the log should be recreated otherwise).

@roberto60:
Your link to susepaste for the /var/log/messages files is empty unfortunately.

But can you try to start X again now after that change?

sudo systemctl restart xdm.service

And please post the output of this afterwards, if gdm doesn’t start:

sudo systemctl status xdm.service

And as I already suggested, please try to change DISPLAYMANAGER to “xdm”, maybe it’s gdm that fails to start for some reason?

I retry

			URL: http://susepaste.org/62039216

This has worked now, but I cannot find anything abnormal there either.

/var/log/gdm/:0.log maybe?

Can you please try with xdm as suggested earlier already to see if that would work?

After reinstalling the xorg server I got back my X windows system thank you very much.

Here the Xorg.0.log

URL: http://susepaste.org/66165861

Do you think I can try to reinstall nvidia driver from overman79 or it is safer to use the nouveau free driver?

Looks good now! :slight_smile:
The intel driver is in use as it should be.

Do you think I can try to reinstall nvidia driver from overman79 or it is safer to use the nouveau free driver?

I think the nvidia driver should work better normally.

And if you follow those instructions there should be no problem:
http://smithfarm-thebrain.blogspot.cz/2013/10/opensuse-131-nvidia-optimus-bumblebee.html

But i never used Bumblebee myself.

I tryed to install


zypper in dkms-bbswitch

(hoping to reduce the energy consumption …:slight_smile: )

but I still got the following error in the make porcess


DKMS make.log for bbswitch-0.8 for kernel 3.11.10-7-desktop (x86_64)
Mon Feb 24 15:33:55 CET 2014
make -C /lib/modules/3.11.10-7-desktop/build M="$(pwd)" modules
make[1]: Entering directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'
make[2]: *** No rule to make target `modules'.  Stop.
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'
make: *** [default] Error 2

Again, did you follow that article?
This tells you to run:

zypper in dkms dkms-nvidia dkms-bbswitch bumblebee primus x11-video-nvidia

Maybe one of those other packages is needed to install dkms-bbswitch and you miss it?
As I said, I have never used bumblebee myself, so I cannot give you any other advise than to follow that article.

but I still got the following error in the make porcess

DKMS make.log for bbswitch-0.8 for kernel 3.11.10-7-desktop (x86_64)
Mon Feb 24 15:33:55 CET 2014
make -C /lib/modules/3.11.10-7-desktop/build M=“$(pwd)” modules
make[1]: Entering directory /usr/src/linux-3.11.10-7-obj/x86_64/desktop' make[2]: *** No rule to make target modules’. Stop.
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop’
make: *** [default] Error 2

Is this the whole log?
I tried to run that make line manually on my (non-optimus) system and get this:

wolfi@amiga:/usr/src/linux-3.11.10-7-obj/x86_64/desktop> sudo make -C /lib/modules/3.11.10-7-desktop/build M="$(pwd)" modules
make: Entering directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'
  Building modules, stage 2.
  MODPOST 0 modules
make: Leaving directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'

So apparently your /usr/src/linux-3.11.10-7-obj/x86_64/desktop/Makefile is broken.
Could you post it?

Yes, I reported for brevity only the first one that report the error

Is this the whole log?

Yes

So apparently your /usr/src/linux-3.11.10-7-obj/x86_64/desktop/Makefile is broken.

I installed it following

Try to (re-)install it even if you do have it installed, since apparently that directory is missing.
Code:

sudo zypper in -f kernel-devel-3.11.10-7.1

I’ll post the Makefile soon

Here the Makefile

# Automatically generated by ../../../linux-3.11.10-7/scripts/mkmakefile: don't edit

VERSION = 3
PATCHLEVEL = 11

lastword = $(word $(words $(1)),$(1))
makedir := $(dir $(call lastword,$(MAKEFILE_LIST)))

ifeq ("$(origin V)", "command line")
VERBOSE := $(V)
endif
ifneq ($(VERBOSE),1)
Q := @
endif

MAKEARGS := -C ../../../linux-3.11.10-7
MAKEARGS += O=$(if $(patsubst /%,,$(makedir)),$(CURDIR)/)$(patsubst %/,%,$(makedir))

MAKEFLAGS += --no-print-directory

.PHONY: all $(MAKECMDGOALS)

all    := $(filter-out all Makefile,$(MAKECMDGOALS))

all:
    $(Q)$(MAKE) $(MAKEARGS) $(all)

Makefile:;

$(all): all
    @:

%/: all
    @:

That’s ok.
But in effect it only includes /usr/src/linux-3.11.10-7/Makefile, that is used to build “modules” and should have that target.
As it will be too big, just post the output of this please:

ls -l /usr/src/linux-3.11.10-7/Makefile
grep modules /usr/src/linux-3.11.10-7/Makefile

The file /usr/src/linux-3.11.10-7/Makefile doesn’t exist. The output of the grep on the file that exists is

vaio-i5:/home/robber # grep modules /usr/src/linux-3.11.10-7-obj/x86_64/default/Makefile
vaio-i5:/home/robber #