Problem mounting external server on boot

I am trying to get my computer to mount an external folder on a different machine with :

//	/mnt/Documents 	cifs	auto,users,username=user,password=useruser,uid=Alastairo,gid=users	0 0

I can mount using mount -a and use this folder, but it doesn’t work on bootup.

I’m hoping that someone can spot my mistake

I found a thread on something similar but it does not come up with a solution.

On boot also a mount -a is done, thus it seeems strange that it does not function then, but it does later. Any error messages in dmesg?

Edit: I assume your system uses a network configuration “traditional with fup”, because when networkmanager is used the network only starts later after login and thus mounting from remote at boot is impossible.

I will check dmesg tomorrow when I am with the machine.

I also think that this (from swerdna’s tutorial) is important :

The option _netdev is always recommended for cifs mounts in fstab. Option _netdev delays mounting until the network has been enabled. _netdev is known to the command “mount” but not to the command “mount.cifs”. Even though mount.cifs doesn’t recognise _netdev, you should include it in your mount command anyway.

Either you have not enabled the daemon that assists the mounting process, in 11.3 it’s called the smbfs helper daemon, or your network is coming up too slowly, for which there are several remedies.

For more on this, see the tutorial HowTo Mount a CIFS Network Share [Mapped Drive] in openSUSE.

To cut to the chase, I would enable smbfs in “runlevels” in Yast and create the executable file “after.local” with contents as follows:

#! /bin/sh
mount -a

as detailed in the following section of the above tutorial: A permanent mount fails at boot time

I went through step at a time and found that creating the script after.local did the trick. You have to wait a while after boot to try it, (a little beyond the boot sound) - and then it works perfectly.

Thanks guys