Problem installing on MacBook Pro 5.5 (2009)

Hey everybody,

I’m kinda new to OpenSUSE 13 but after using Debian and Ubuntu for the last few years I thought I was ready to try out new things. I wanted to install OpenSUSE in dual boot with OS X. I followed the instructions on the Wiki, got myself ReFit, updated and resized my OS X partition to 250GB (from 400GB total) and booted from the Install DVD.

First up I’m noticing that sometimes the loading of the DVD contents (either Live Desktop or Installer) gets stuck at some point with no console output about what’s happening (in the screen where it should display the chamelion but some graphics error creates a lot of artefacts so it’s all just a green blob. This happens kinda randomly. I tried three different disk burners on three DVDs and on flashing the ISO to two different USB drives.

At some point I got to the installation where I created three partitions: Swap (4GB), Boot (64mb mounted at /boot) and my root partition with the rest of the HD. I also made sure that the boot loader (GRUB2) was installed on the 64mb partition (I also tried larger sizes).

Now there is another odd thing because sometimes (I tried installing OpenSUSE for the last 3 days or so) the installation will completely freeze up at ~50%.
But even when it finishes and I reboot my computer Refit won’t see the new OS, even after using the partition tool to update it’s data. (Actually in the first installation that I did everything worked relatively fine until I updated ReFit. Then my SUSE wouldn’t boot anymore at all (before I had to boot via pressing alt at boot and selecting it).)

So I know that these are a bunch of problems I’m stating but I’m a bit confused on what’s going on. The laptop is a bit older (from 2009). Maybe somebody can help me out here, it’s getting a bit frustrating :frowning:


Too small of a boot. you need at lest 256 meg because you can have up to 3 kernels installed at any given time because of updates. Updates will keep the last kernel and if already 2 the next oldest for a total of 3 the third will go away after a successful boot to the newest.
You really don’t need a seperate boot not sure why you want one.

Sorry know nothing about Mac

Well my current boot partition is 512mb big. And I was following this article:

The thing that’s weird for me is that I’ve tried to install SUSE about 5 times now and each times it shows different signs of error. In this installation e.g. when I select Linux in Refit it just forever shows the “Show Legacy Boot” icon. And if I boot using alt and then select the other partition MBR tells me that there is nothing to boot…… :frowning: