problem installing nvidia driver - looped login

Hi i’ve just installed openSUSE on another laptop and couldnt login after installing the nvidia drivers. Its using the most recent public openSUSE DVD version. When i tried to install the nvidia driver for linux the login screen came up after rebooting and even with the right username and password the nvidia logo would flash and the login screen would appear again. It seems to be stuck in a loop. I’m using KDE on this laptop and i really need the drivers installed for using openCL.

I’ve reinstalled opensuse with KDE and updated any updates. Is there a way to install the nvidia driver without the same problem happening?

Well, on a standard openSUSE 12.3 installation you have to add your user to the “video” group for the nvidia driver to work correctly. Did you do that?
If you install all updates before you install the nvidia driver, this isn’t necessary anymore.

If your current session doesn’t start, you can select a different one by clicking on the “gear” symbol. IceWM is installed by default and should work in any case.

Please tell me what NVIDIA card you have and the output of “uname -a”.
I will then give you precise instructions how to correctly install the driver… :wink:

thanks. The laptop has nvidia gt 230M. Even on windows it was extremely difficult to install the driver. It seems that nvidia doesnt let you download laptop GPU drivers from their site anymore.

In total i need to run (though not all at once):
nvidia gt 230M (the one i have problem with in this thread)
quadro fx 570M (having problem but on another thread)
gt 630
gtx 285
gtx 580
GTS 250

Either through desktop or through laptop’s dock or expresscard. It seems that getting GPU drivers to work really is hard. As long as openCL runs on the GPU i’m happy.

Those are all supported by the latest G03 (319.xx) standard driver, see here under “Supported Products”: Drivers | GeForce
Except for the FX 570M, of course. For this you would need the older G02 (304.xx) driver, which supports ALL of the cards you listed.

You didn’t post the output of “uname -a”, so I’ll just assume you’re using kernel-desktop. If not, please change “desktop” accordingly in the following procedure.
And another note: I will show the procedure for the G03 driver. If you want to install the G02 driver, just change G03 to G02 everywhere.

If you have tried to install the nvidia driver before, completely remove it first.
Then do the following:

sudo zypper ar nvidia
sudo zypper in nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03

Or, if you prefer the GUI way:

  • Start YaST->Software Repositories, select “Add…”->“Community Repositories”, then add the “nVidia Graphics drivers” repo.
  • Start YaST->Software Management, type “nvidia” into the search field, and install those 3 packages:
nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03

As I said before, you would need to add your user to the “video” group as well on a fresh 12.3 installation, but that’s not necessary anymore if you have installed all online updates. But it can’t harm either, so maybe just do it:

sudo /usr/sbin/usermod -a -G video $USER

or use YaST->Security and Users->User and Group Management for that.

That’s all! After a reboot you should be using the nvidia driver.

Either through desktop or through laptop’s dock or expresscard. It seems that getting GPU drivers to work really is hard. As long as openCL runs on the GPU i’m happy.

The driver is not really hard to get to work, see above.
But I have no idea about openCL.

Thanks it worked. For openCL it seems i need to download additional libraries. Since my laptop with nvidia quadro 570M uses a G02 driver, would it work with a newer GPU such as GTX 580 connected through expresscard?

The G02 driver has support for upto GeForce 600 series, see here: NVIDIA DRIVERS 304.88Certified (click on “SUPPORTED PRODUCTS”)

So it should work with a GTX 580, yes.