problem during boot


I have had openSUSE 11.1 for a while now with no problems at all. Boot was done with Grub with all the defaults. This morning I wanted to change the resolution of the tty virtual terminals. I followed the following steps I found in another forum:

"You can do this by opening YaST and using System -> Boot Loader. Click
the ‘Edit’ button for the boot mode you want to change the res for, and
then use the “VGA Mode” drop-down menu. After that, you’ll have to reboot. "

After doing this, when I reboot, I got this message

Intel(R) Boot Agent PXE Base Code (PXE-2.1 build 084)

Yukon PXE v3.03 (20040915)
(C) Copyright…

Pre-boot eXecution Environment (PXE) v2.1
(C) Copyright…

(After DHCP waiting):
PXE-E35: No boot filename received

BC_Loader() == 0053
PXE-M0F: Exiting PXE ROM.
No bootable device – insert boot disk and press any key.

When I press Enter:
No Operating System :frowning:

I guess I messed up with the boot system. Is there anyway I can fix this? I dont see any menus or anything. Maybe a bootfile from external drive??

Any help is aprecieated!!!

Best wishes,


No operation

If possible boot a live cd, any live distro will do.
You need to go to: /boot/grub/menu.lst

In the folder /boot/grub
there should also be a menu.lst_old (something like that). Hopefully this is the file with your old settings. You need to right click open with kwrite or kate.

Do the same with the current menu.lst and compare the two. Change the current file accordingly.

Another thought. Did you try a failsafe boot. It should work shouldn’t it? So you may be able to boot from that and edit from your system, rather than from a live cd.

Are you actually using PXE boot (netbooting) for anything? If not, you can save yourself a fair amount of boot time by disabling your network device in your boot order. This will make it not go through the PXE sequence every time you boot.

Looks like his BIOS settings got changed to “Net Booting”. Can you see your BIOS settings and look for the Boot Order specified in it?

Have you always had this PXE boot sequence on startup, or did you make any changes in the BIOS at the same time you made the changes in GRUB?

PXE booting continues on to the next boot device if it does not successfully find a netboot source. In this case, it looks like the next boot device is the hard drive. It isn’t finding any boot options there, which indicates a problem with GRUB, as he already suspected.

At this point, you will want to use your OpenSUSE install disc to boot from, which will give you an option in its boot menu to repair the installed system. You can use that to repair your GRUB install so that your computer will boot normally again.

Found this in another forum:

Boot from CD/DVD, go Repair Installed system. It will detect the corrupted GRUB and repair it.