Problem Displaying Fonts and using HDMI audio drivers

So I’ve been trying to get audio through hdmi, and when i install the drivers from here:

SDB:NVIDIA drivers - openSUSE

the system fonts are displayed incredibly small and are not readable. If you want to follow my frustrations you can check it out here:

Here is a bit more system info:

OS: Linux 3.1.9-1.4-desktop i686
Current user: root@linux-qxtx
System: openSUSE 12.1 (i586)
KDE: 4.7.2 (4.7.2) “release 5”

Display Info
Vendor: nVidia Corporation
Model: C77 [GeForce 8200] *Windows drivers recognize as GeForce 9200
2D driver: nvidia
3D driver: NVIDIA 290.10

Let start with what brand of tv your machine is connected.
Was your tv has an incredible fonts in windows?
What resolution does your tv is supporting?

Thanks for taking the time to do this man,

I’m using a 32" LCD Samsung (1360x768)

not really sure what that means?

I see, did you check if you are presently using the 1360x768, because with that you should be having a larger gui and fonts.
When you are connected to that samsung 32" via HDMI it can force to accept 1680x1050 which is what I am using right now.

My advice to you to make it easier try taking out the hdmi and use the vga for now if you have an available vga chord in the house
Look at the difference. If fonts is okay we will deal with the HDMI later.

Correction to my post:
With HDMI it can be force to accept 1980X1020 sorry about that.

okay, so i tried the vga cable and it didn’t even work… which is weird because i used it for like a year until i got another hd cable for the pc… and yes it was 1360x768 before i tried the vga cable, and it is 1360x768 on Windows as well

You have to reboot your machine to re-read the new connection.
In your tv option also edit the name of your pc to pc ----pc

i was thinking that might be the case but in the past it has read it without rebooting. is using the vga really necessary?

It is and is not. The reason of trying the vga is, the 1360x768 is the highest resolution it can get
so your dead on to that resolution.

Also did you add the packman repositories in yast2 because if you able to add it you can install the nvidia-settings gui to make it easier for you to configure your resolution setting.
I am not sure when you use the 1-click install of nvidia driver if it is included in the installation.

You can try in the cli to command
If it shows-up it is installed on your machine.

I’m sorry what am I looking for after typing that command? just to see if nvidia x server settings opens up? because it did…

So nvidia-settings did show-up

Try playing with that as normal user
clck the x server configuration
and try changing your resolution to a readable gui and refresh rate.
if it work, close it open a cli su to become root and do the configuration of resolution and refresh rate and save it.
logout and login and will use the HDMI to figure how it will work for you.

I’m about ready to give up… I restarted my pc and the font is not readable again

Hang in there, here is an image of nvidia-settings to be configured
ImageShack - Best place for all of your image hosting and image sharing needs](ImageShack - Best place for all of your image hosting and image sharing needs)

Are you really following what I had told you, if you’re not clear just ask and we will clarify it.:slight_smile:

Also change the fonts to 120 dpi it might help
change also the sizes of the fonts to 14 for sure it will larger in configure desktop application appearance

When you configure the nvidia-settings you have to su to be root so your configuration will be save.

Okay i think i need to clarify something here; I could have adjusted the resolution without the nvida x server settings… I think maybe this whole time you are under the impression that I cannot read any text still. but after i logged in as runlevel 3, everything was a normal size again. So i’m not sure why we need to use nvidia to configure the display.

if it work, close it open a cli su to become root and do the configuration of resolution and refresh rate and save it.
logout and login and will use the HDMI to figure how it will work for you.

I have set the dpi to 120, and the font to size 14. Should I make the resolution smaller than 1360x768 to see if it displays correctly? I’m just not sure what to do after playing around with the different resolutions…

I’m just frustrated, thanks for bearing with me.

When you login from runlevel 3 my guess is you are being root and you force the dpi settings right?
I want you to configure the resolution using nvidia-settings as root so it will save the settings hoping
that when you login as a normal user it will become readable. Sorry with my english.

Don’t loss faith you’re getting there.:wink:

Don’t worry about your English, it’s very good on the assumption that it’s your second language.

Yes you’re right: I’m still logged in as root when I check the Konsole.

Do I click “Save to X Configuration File” ? Or will it save on its own when i click quit since I’m root?

If so, then I can reboot my pc now. Do you think I should try to add the repository for the nvidia driver or is it ok to try the “one click” option again?

Sorry for all those questions lol

Save it, Save to X Configuration File
and don’t login again as root it’s dangerous.
reboot and don’t use the runlevel 3, reboot the normal way and login as your user.

You can add the nvidia repository. But for now try to make it work first.

Okay one last question for nvidia settings, when i click save, where should I save it & what should i save it as?

To be honest I am using the nvidia propreitary driver and haven’t use the one you are using so it might be different, mine is save to /etc/X11/xorg.conf
Yours can be different it might be prompting you to save as in /etc/X11/xorg.conf.d/50-monitor.conf
can you post what does it says.

This is what it says when i click “show preview”

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 290.10 ( Wed Nov 16 20:31:58 PST 2011

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “SAMSUNG”
HorizSync 26.0 - 68.0
VertRefresh 23.0 - 61.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 9200”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “TwinView” “0”
Option “metamodes” “1360x768_60 +0+0”
SubSection “Display”
Depth 24

when i click “browse” is just says /root