problem booting with easyBCD

Hi,

I tried to install openSUSE 12.3 according to the instructions by TweakHound provided here:

Dual-Boot openSUSE 12.3 And Windows » TweakHound

After setting the boot loader settings,
At the “Installation settings” step, under the header “Booting”,
the following message was displayed:
“Unsupported combination of hardware platform x86_64 and bootloader grub2 Partition number > 3 is being used for booting with GPT partition table”

Unsure what else to do, I proceeded with the installation anyway.

After setting up easyBCD and restarting, the Windows Boot Manager starts, and I have the option of choosing windows 8 or opensuse 12.3.

If I choose windows, that works fine. If I choose opensuse, I come to a new menu, saying:

“Windows failed to start… [instructions on repairing windows]”
and at the bottom:
"File: \NST\AutoNeoGrub0.mbr

Status: 0xc000007b

Info: the application or operating system couldn’t be loaded because a required file is missing or contains errors."

\NST\AutoNeoGrub0.mbr is the bootloader path set for opensuse 12.3 in easybcd.

What to do?

To be clear, I just want to be able to dual boot Windows 8 and openSUSE 12.3. I don’t particularly prefer to use easyBCD over Grub 2 or other alternatives.

Should I delete the partitions created for openSUSE, then reinstall with different boot settings, or is there some other way to fix this?

Best regards,
Chris

PS: Sorry for double post.

On 2013-09-15 09:46, ChrisAT wrote:
>
> Hi,
>
> I tried to install openSUSE 12.3 according to the instructions by
> TweakHound provided here:
>
> ‘Dual-Boot openSUSE 12.3 And Windows » TweakHound’
> (http://tinyurl.com/cckzjv7)
>
> After setting the boot loader settings,
> At the “Installation settings” step, under the header “Booting”,
> the following message was displayed:
> “Unsupported combination of hardware platform x86_64 and bootloader
> grub2 Partition number > 3 is being used for booting with GPT partition
> table”
>
> Unsure what else to do, I proceeded with the installation anyway.

AFAIK, easyBCD does not work with GPT partitions (UEFI).

> What to do?

There are howtos here, but I don’t have links ready. Maybe someone has
them. Try READ on the … just found a link:


> https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/487837-how-dual-boot-preinstalled-windows-8-linux-uefi-etc.html


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Some points:

  1. All of the evidence that I have seen, suggests that Windows 8 on a GPT partitioned disk will only work in a UEFI system;
  2. Since Windows 8 worked for you, then it follows that you have a UEFI system;
  3. All of the evidence that I have seen indicates that easyBCD cannot cope with UEFI booting. It can only handle MBR booting, which is not what you need to do. This is not entirely the fault of the easyBCD software. As best I can tell, in a UEFI based system the Windows Boot Manager can only boot Windows systems – it cannot boot other UEFI systems.

I am posting this from a UEFI box with both Windows 8 and opensuse 12.3. The combination that you want is likely possible, but you may need to change your plans on how to do it.

I’ll also note that UEFI is new, and vendor implementations vary. Some cause more problems than others.

Step 1: Make sure that Windows 8 is booting. Perhaps undo the easyBCD stuff, or just continue to not expect it to work for booting opensuse.

Step 2: Make sure that you are using 64-bit opensuse.

If you install opensuse 12.3 with the DVD there is a good chance that it will work. If you install with the live KDE or live Gnome media, you would probably get that message “Unsupported combination of hardware platform x86_64 and bootloader grub2 Partition number > 3 is being used for booting with GPT partition table”. So I am guessing that you used live media for your install. In that case, it might be easiest to just reinstall.

To install with live media:

  1. Identify the EFI partition on your box. It is probably either “/dev/sda1” or “/dev/sda2”. While running from the live media, you can use the command
parted -l

which will probably tell you which partition is the EFI partition (or the ESP, for “EFI System Partition”). Alternatively, you could use

gdisk -l /dev/sda

and look for the partition with typecode EF00.

  1. During install, at the partitioning section, you will need to make sure that the EFI partition is mounted at “/boot/efi”. And DO NOT REFORMAT that partition.
  2. During the boot section of install, you should select grub2-efi to handle the booting, and you should check the box to install secure-boot support.

You might still have problems after that. If you do, post back here and we will try to help.

Thanks for the kind and informative answers,

Windows did boot, but I wanted to get rid of easyBCD since I would not need it. To prepare for getting rid of that program, I first tried to reset the changes done with easyBCD by starting the program, and in its ‘edit boot menu’, I deleted the entry for openSUSE and set Windows 8 as default. Then I restarted.

At the boot menu, I now had the choice between openSUSE (still doesn’t work) and… nothing else. no Windows option.

Not exactly what I had planned for. Any suggestions? At this point, is it feasible to just forget about the dual booting scenario, install using the automatic configuration and be done with it, or would this problem (or other ones) remain?

PS: I tried asking about this problem on the neosmart (easybcd) forum, but that place seems a little dead.

OK what menu? Grub? EasyBCD?

You can always wipe and start again assuming you have no data you want or you have backed up any important data.

Installing Windows in a VM is a viable option assuming you are not wanting to play high end Windows games.

Sorry, I was imprecise: in the Windows boot manager, the only OS i can choose to start is openSUSE 12.3. Well, at least it has the header Windows Boot Manager.
(I can also start Windows Memory Diagnostic, but that does not seem to do anything, or I can exit to a Boot Menu allowing me to access firmware settings, boot from USB etc.)

I was mainly wondering if reinstalling would wipe whatever settings I might have changed with easyBCD or during the first openSUSE installation.

Reinstalling openSUSE will not change a thing in Windows. It may replace the MBR if you wnat/let it assuming a MBR BIOS setup and not UEFI.

Given a UEFI setup rather than BIOS? must confess that to me, booting, firmware etc. is something that just happens, and works - except when it doesn’t.

Well if UEFI then we need to get someone else in here. I currently don’t have a UEFI machine and probably not the best to give advice.
Just reinstalling openSUSE though will not fix what you have done to Windows You can probably get openSUSE up and running though. From there salvage anything you need from Windows reinstall windows and copy the data back.

I think you need to boot from Windows 8 install media, and go into “repair boot” options.

You can check if there’s a free trial version available at the Microsoft site – that would probably be good enough for repairing.

@gogalthorp: Thanks, I’ll wait and see if someone more familiar with UEFI drops by.

If you are getting the Windows boot manager menu, then the UEFI part is working well enough to get to Windows. It’s your Windows boot configuration that is messed up. I don’t know how to repair that, except from Windows. And since you cannot get into the full Windows, that’s why you will probably need a Windows boot setup repair.

tl;dr - It worked, everything is well in the world. Yay! And thanks, especially to nrickert.

Slightly longer: Using a usb stick with a Widows 8 recovery drive, resetting windows 8 cleared away the trouble left by messing around with easybcd. It a new computer, so losing all data basically meant losing nothing. Defragmented, shrunk the C: drive partition. I was installing using the 64-bit openSUSE 12.3 iso file burned to a usb stick the first time around, and using it again here, most everything was set up such that it worked fine without changing anything. The EFI partition was clearly marked as such, and was already set to be mounted as “/boot/efi”, etc. The only (small) hitch was that after updating software, a message was displayed that the program would restart the computer, which didn’t happen. But just shutting down via the power button and then rebooting openSUSE, the installation picked up from where it left.

Grub2, openSUSE 12.3 and Windows 8 now all seem to coexist peacefully, and work as they should. :slight_smile:

Great. We are glad to hear it.