Problem booting openSUSE DVD...

Hello to all. Sorry for entering the forum just to beg for help.
I’m a newbie on this stuff… I want to install Linux on my PC, and I chosen openSUSE for it. But I having troubles booting the installer. It’s really annoying, I can’t ever try to install :frowning: but anyway, the installer freezes all the time. I tried booting from text-mode and it locks always when the console is showing:
Loading basic drivers…

I’n not a completely noob. I tried every single piece of boot option to make this run, and it just doesn’t. I tried running with ACPI off, APIC off, with IDE disabled, in safe mode (with all the previous disabled), with EDD off, even tried to run with Execute Disable Bit disabled on the BIOS… And just didn’t work at all. The installer loader just locks up, the DVD drive stops and I got stuck seeing the small white letters… Maybe I sounding annoying, sorry, but I really want to play around on Linux :’(

Thanks for reading this!

Can you do a media check? If you can, try that. You can also try to use the DVD from windows and explore it a bit to see if the disk is ok.

I already checked the media with ImgBurn and actually, I installed openSUSE within VirtualBox using the DVD, so it’s working fine. But I want a true installation, because running it on a VM is slow…

By the way, I’m using a notebook. I think the model doesn’t really matter, because I searched the web and other users reported that other distros work fine. Anyway, can this be a openSUSE issue with my hardware? Should I try other system?

(Oh, the hardware, or what I found about it:
Pentium Dual-Core T2080
Chipset SIS 671 DX + SIS 968
ATI Mobility Radeon HD2300
SATA hard disk
Toshiba DVD drive)

Can you try with the adding the option insmod=ide-generic in the
options section at the bottom of the installation list at the boot
screen where you select installation.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1:45, 1 user, load average: 0.08, 0.05, 0.02
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Actually, you should still use the “media check” on the DVD itself; it won’t take long. Also, the model does matter; please post that back here.

Take a look in the bios for a disk drive setting which includes the option of “AHCI”; if it’s not set to that, do so and try the DVD again. If it doesn’t work, try again with this in the Boot Options on the menu:


For ref, from a Ubuntu forum post, user with SiS968 Southbridge:

I have been successful getting the SATA HDD going by setting the SATA bios IDE setting to a AHCI.

You can also try these in the Boot Options, but its most likely it’s the AHCI setting that is needed:



Your post reminds me an issue i had when trying to install openSUSE 11 (and other distros too: debian etch and foresight) on my desktop which have a P5Q PRO motherboard with ICH10 chipset and intel core Duo extreme as CPU. The system have a sata hard drive (Hitachi) and two ide hardwares (DVD reader NEC and DVD writer PLEXTOR). During the installation the process stopped outputting an error because the cdrom device was not recognized (no driver available) although the system was already reading the cdrom!! Apparently the installer didn’t recognize the ide controller on which the cdrom’s devices were attached. May be you have a similar problem here. Anyway here is what i did: (i tried first setting the option ahci, enhanced and compatible on the harddrive in the bIOS without result)

  • i unplugged the connection cable on the sata harddrive (not the power one but the connection one) then i rebooted to see if the BIOS recognized the ide controller. And yes, i saw the message " enabling the MARWELL 8XXXXXXXXX ide controller" on the screen. Then i re-plugged the connection cable on the sata harddrive and i retryed to install openSUSE from the dvdrom and except some strange message that i don"t remember all the process went fine and now i can use openSUSE 11 on my desktop.
    In your case you can’t disconnect the harddrive but you probably can disable it in the BIOS and do the same thing as i did to initialize first the cdrom controller and than re-enable the harddrive and retry installing openSUSE 11 to see what happens. Let us know if it works for you.
    Good luck

I have been fighting this very same issue with a desktop all afternoon. I went into the BIOS and turned off everything that had to do with CPU throttling and now I have no problems loading or booting my machine. No more freezing.

Hope that helps!

Something else to try from the Boot Options: