Problem booting on Thinpad X1 Carbon 2017

OS: Leap 42.2
HW: Thinkpad X1 Carbon 5th Gen (2017)
CPU: Core i5-7300

I have tried a number of times to install 42.2 from a USB drive onto my brand new Thinkpad. Each time the install appears to complete successfully but the following problems exist:

  1. Cannot boot from HD. Any attempt to boot from the HD ends up at a BIOS screen requesting a temporary boot device with a choice of either the HD or “Windows Boot Manager”. I have completely reformatted and partitioned the HD so there should be no Windows boot manager there. I can boot from the install drive by selecting the “boot from hard disk” option. [NB Boot is set to /boot partition not MBR]
  2. The wifi device is not recognised as being present at all. The wifi (Intel 8265AC+BT 2X2 vPro - PCI device) works perfectly under Windows but is not present in the 42.2 hardware info listing nor recognised (obviously) by Network Manager.

I suspect the booting issue has something to do with UEFI settings but I am not familiar enough to know for sure. I have no idea about the wifi problem.

In order to be able to use the laptop, I have restored Windows from a recovery disk but wish to get rid of it ASAP. I would appreciate any assistance.


Which means we can not get any information about the installed openSUSE anymore.

In any case you seem to have created a separate partition for /boot (and you have set it as the place to boot from, why?), which is not the default. Thus we of course like to know what partitioning you did. Maybe you have notes about that (either on paper or in your head) which you can share with us.

That’s what installer offers by default when you have /boot. Otherwise it defaults to /.

Point taken. But the OP tells this as if it was different from the default. OTOH he only explains he has a /boot (not the default) as a byproduct.

So please OP, make it clear what you did on EFI, partitioning, etc. specially when you deviated from the defaults offered to you by the installer.

So please OP, make it clear what you did on EFI, partitioning, etc. specially when you deviated from the defaults offered to you by the installer.

During install I accepted all defaults other than the following:
Partitioning: Partitioned the SSD as follows (sizes are approximate) -
/boot Ext4 150MB
swap 8GB
/ Btrfs 80GB
/tmp XFS 20GB
/home XFS 300GB
/opt XFS 85GB
/var XFS 10GB

Timezone: Set to Melbourne, Australia

As far as UEFI is concerned, I set the BIOS to boot in legacy more but made no other changes.
(I suspect that I should have checked the EFI option in the installer but the documentation was not clear on this point.)

You need a 200 MB partition for EFI. This is what UEFI is searching for so that it can boot securely.
BTRFS requires that you remove the /boot partition so that it can create snapshots.

Dear davgreen,

I’m running LEAP 42.2 on a Lenovo Thinkpad X1 Carbon 2017 (i7500, 16GB, 512 SSD).
I have folloing partitions:
156MB EFI boot
2.01 GB swap
20 GB Ext4 root (I’m using Ext4, because I had trouble with BRTFS snapshots in the two or three years ago, which completely “spam” my root folder and inhibited booting. Perhaps, the problems with too much snapshot is solved meanwhile)
455 GB Ext4 home

I advise to install a recent Kernel (not using Kernel 4.4) 4.11 and above (I have currently + current kernel firmware to get improved power management, bluetooth and also the functionality of the +/- brightness keys.
I’m using following repository for the kernel:

I also update the BIOS which improved the fan control.



Well… here is another one with an identical problem, and nearly identical hardware. Given the similarities I hope it is ok to post this in the same thread.


Lenovo Thinkpad X1 Carbon 5th Gen.
Processor: i5-7200U
Memory: 8GB DDR3
HD: 512 GB Samsung HDD

The problem: the same one described by the OP, at least concerning the boot troubles (I have not tried the wifi yet). After an apparently succesful installation of Leap 42.2 from an USB stick, the system refuses to boot, simply asking for an alternative boot device. I can boot into the installed system by using the installation/rescue USB stick, though.

This is clearly some sort of UEFI problem. The system came with Windows preinstalled, and I started by wiping it and reformatting the disk upon the first installation. In order to be able to boot from the Leap USB stick for the installation, I had to tell the BIOS to be either in “Legacy” boot mode or in “dual” boot mode. The system won’t boot the USB installer if it is in pure UEFI mode. Right now (in the last installation, as there have been many attempts playing with all these parameters), I have it in “legacy” mode.

In a typical installation attempt I will tell the partitioner to create a setup I like: a first system (/) partition (btrfs), a second (/home) partition (ext4) and a third (swap) partition. There is no EFI partition (the partitioner most certainly does not propose the creation of any EFI partitions, which according to some of the documentation I have read should happen; how did the users that have these EFI partitions get the YAST partitioner to create them?? I don’t see any proposal for such partition, maybe because of the need to boot the stick in legacy mode). Upon this, the partitioner tells me that this configuration is problematic because there is no grub partition (perhaps it calls it grub_bios, I am speaking from memory as I write this), something that is needed with GPT disks, so I also create a small (7.8 MB) unformatted grub partition. After this, the installation seems to go fine, but after finishing the system keeps refusing to boot.

I have tried many ways (with or without the grub partition, for example, with grub in the MBR or in the root partition…), but nothing seems to work. So, let’s start from the beginning. How would you guys perform the installation from scratch? What information do you need me to provide to to diagnose the problem and get to a working installation with an EFI partition?

Thanks in advance!

Ok, after a more thorough reading of these forums, it turns out the problem is a known one, and there is a solution. It is explained in this thread:

Without getting into gorier details, the USB stick I created (using SUSE Studio Imagewriter) is not detected as a UEFI medium by the BIOS (hence the need to put the BIOS in either “Legacy” or “dual” mode for it to boot from the USB stick). After this, the installer performs a non-UEFI installation, and that is why there is no EFI partition and the system is unable to boot.

The solution: as explained by the other poster, grab OpenSUSE’s iso image and create the USB installation disk using Rufus instead of ImageWriter (in my case I had to do it in a Windows computer, running in a Virtualbox virtual machine, since Rufus is essentially a Windows program). Make sure that you create the disk using the “ISO image” mode of Rufus, and not the “DD” mode. There are other options (especially whether you want to create a disk for an UEFI or MBR system, or both), but these are determined by the type of hybrid ISO image downloaded from Opensuse, so Rufus will force you to choose the right one.

After doing this, I was able to boot from the USB stick with the Thinkpad BIOS in pure UEFI mode and perform the installation. It finally works, it has its 155 MB EFI partition… So, everything is OK in that front.

With that problem soved, I am now facing the second one mentioned by the OP: the WLAN card is not detected. I have also found a solution for this in another thread of this forum, although I cannot find it right now to reference it. Anyway… apparently there is some sort of bug in the wireless driver packed with the distribution that prevents it from loading/working properly. This bug is solved in later updates that are in the repositories, but of course one has to install these updates… without a working wireless card the easiest thing to do is to plug the computer into a wired network and use that to download the updates from the repositories. After that, the WLAn card should be detected and work.

I have not tried this myself yet, I plan to do it this evening, but according to what I read I expect everything will be fine.