printing cups/lppasswd

I am using Suse11 with KDE4.2
Printing worked but suddenly the printer stopped. I tried to restart with cups but cups did not accept the root password. Why?
Tried to set password from commandline: “lppasswd -a root” and supplied the password. Although I was using the terminal as root I get the result: “lppasswd: Unable to open password file: Permission denied”.
How come for root is the permission for lppasswd denied? how can I reset the password? Why is cups not accepting the root password? All this was working when I had Suse10.3. After upgrading (some time ago when Suse11 came out) everything worked fine. Now the printer stopped and this?
By the way I could get the printer started with the lpadmin command but I would like to log into cups and reset the password whenever I like.
Any help is very much appreciated.

Not sure why it won’t accept the root password but it has been set up for some time to accept the user password anyway.

It does not accept my user-password either. When I tried to set me up for cups with lppasswd -a <username> I get the same “permission denied” message. (Again I tried this command being root in the console window). Now the question for me is how to fix this without a complete reinstall.

Are you saying you can’t enter ‘root’ and root password for admin via CUPS http interface?

Have a look at these guides re CUPS password.

CUPS Printing Setup Mini-HOWTO

Printer Sharing: Windows Print Server for Suse/openSUSE Linux Clients [Samba and LPD]

Apparently, the command has changed to:

sudo lppasswd -g sys -a root

That’s what I am saying. I cannot enter the password through the http interface and I cannot change the password even as root. THe copy below is a straight copy from the terminal where I logged in as root. Thanks for the links, deano_ferrari, but as I cannot get into Cups or anything they don’t help. I had set up Cups before (approx a year ago when I installed a new network printer) and then I could log into CUPS and set everything up.

linux:~ # lppasswd -g sys -a root
Enter password:
Enter password again:
lppasswd: Unable to open password file: Permission denied
linux:~ #


cups password - openSUSE Forums

If you look at lppasswd, you will see it has this ownership: user lp, group sys. You would have to change ownership to root with chown command first AFAIU.

Mine is showing:

-rwxr-sr-x 1 lp lp 14888 2009-04-16 19:00 /usr/bin/lppasswd

Notice the setuid

I don’t know whether this is relevant but man lppasswd gives

lppasswd -a -g groupname ] username

as the form of the command for adding a new user and implies that you omit the -a to change an existing user’s password.

Mine (openSUSE 11):

linux:/home/dean # ls -l /usr/bin/lppasswd
-rwxr-xr-x 1 lp sys 14496 2009-04-17 03:22 /usr/bin/lppasswd

Thank you very much.
The chown root /usr/bin/lppasswd command did the trick. All is working now.

Glad it worked for you.