Printer problem - please help

I had a Brother MFC 7840 network printer set up and working. Installed a new router and the ip printer address changed, so I used YAST to reconfigure the printer, but it did not work. Changed the printer ip address back to what it was with the old router and tried again, but still cannot connect to the printer. Xsane scans work fine, so I know I blew out something when I tried the Yast change for the printer (I wish I had just changed the ip address before trying to reconfigure with Yast!!). I’ve tried Yast and CUPS printer setups several times, to no avail. The cups error log shows the following lines:

E [10/Nov/2011:21:36:10 -0500] [cups-driverd] Bad driver information file “/usr/share/cups/drv/sample.drv”!
E [10/Nov/2011:22:36:44 -0500] [cups-driverd] Bad driver information file “/usr/share/cups/drv/sample.drv”!
E [10/Nov/2011:22:37:58 -0500] [cups-driverd] Bad driver information file “/usr/share/cups/drv/sample.drv”!
E [10/Nov/2011:22:38:02 -0500] [cups-driverd] Bad driver information file “/usr/share/cups/drv/sample.drv”!

How can I recover???

Thanks for you help!!


I failed to mention that the system is running version 11.4 with KDE if that matters.

Resolved!!! —

Thanks to all who read this post. I’ve found the issue and resolved it. For others who might have a similar problem here is the resolution:

In Yast printer setup, I found that the connection was set to use the MAC address of the printer instead of its ip address. (I’m not sure how this happened since it was working properly before the router change out.) I used the connection wizard to insert the ip address as the lpd connection and printed a test page. It WORKED!!! ;);):wink:

Best to all!!!