Printer not working

I just installed Tumbleweed, connected my b/w Brother Laser printer (HL-2130) which gets successfully added to the system through Gnome settings.
When I go for a test print nothing happened, the dialogs show telling it’s working but nothing happens! Checked “Show Jobs” under the Gnome Printers setting page but no, nothing there.
Last time I tried with Fedora the printer worked straight away I didn’t have anything to do.

Any suggestion please? Thanks

EDIT: Tried to delete it from Gnome settings (ok) and then disconnect and reconnect it (after a reboot). I’m then trying to start the Yast2 printing module… but it just starts and the mouse pointer starts spinning forever, and CPU fan to the max! and I can’t even close Yast, it seems frozen! Tried several time after forcing a reboot… geez, I just wanna print! :slight_smile:
I tried again by leaving the printer disconnected, but again Yast get stuck somehow… please help, I can’t believe this.

It’s not clear to me about why the printer configuration is failing, but perhaps you could try configuring via the CUPS web interface instead


Enter ‘root’ and root password when prompted, and follow the directions given

BTW, there are Brother drivers available for the HL-2130 model which you may wish to install first

I just rolled back the system with snapper to a post-installation snapshot, then added the printer in Yast2 and all worked.
Don’t know what happened the first time, surely Yast2 didn’t like me setting the printer through Gnome.
I wonder if it’s the norm to set the printer with Yast or not… it’s so natural to just go in Gnome Settings and add it there: don’t you think?
I guess there’s no way to customize gnome or add a link somewhere… a bit counterintuitive :slight_smile:

Another thing I struggles with was selecting the proper snapshot (about counterintuitiviness :)… somehow/sometimes you have to press ESC to boot the desired snapshot.
I guess that’s enough for another post in another section of the forum.


Printers are generally system resources where has desktop settings are personal preferences so yes need to at least do initial setup through yast