Hallo! I’m new OpenSUSE user. 11.1
How do i install my printer. In Ubuntu it discovered automatic and installed itself by found drivers.
But not in suse…
Anyone can help me?


You can try configuring the printer in YasT, does it leads you to a correct driver?

Otherwise you can install the official brother driver. However your model is not mentioned in Brother linux driver download site, but perhaps you can try using the 2040 driver?

Brother HL2040 HOWTO - openSUSE

Sorry but my thread heading showed wrong printer. The model is Brother HL 2030. Talked with other Suse users and they also struggles with printing.
Why cant suse auto discover and download apropriate drivers?

Welcome to linux. … Some distros like ubuntu try to cater for the windows user and automate everything. Others like opensuse do this but require a bit of self help and are aimed at more advanced users. So try a bit of searching.
First place to check is the manufacturer’s website.
Have a look at this page:
Brother Solutions Center : Brother Driver for Linux Distributions

A lot depends as well on the driver support provided by the manufacturer.

I refuse to purchase any printer other than HP.

HP is far from perfect in support, but frankly speaking, the support provided by “other” printer manufacturers for Linux is simply pathetic compared to HP. Really. Truly and absolutely pathetic. There is NO comparison. None.

Given how inexpensive printers are today, I myself refuse to THROW money at a manufacturer who provides pathetic support for Linux printers. And that pretty much sums up every printer manufacturer other than HP.

So if for MS-Windows compatibility reasons one prefers to use a non-HP printer, then one has to live with the pain of poor Linux support, and rely on the generous free volunteer effort of hackers to try and get their NON-HP printers working.

Looking at the brother site, it looks like they do support linux … how well, only their users can tell.
I agree with hp printers and linux support. At least hp uses universally recognised printer protocols and not their own which are developed for each new printer.
Even better, get a postscipt printer and the drivers become academic - any ps driver should work.

HP also provide applications to help configure their printers. They provide maintained lists on the internet with an assessment as to how Linux compatible their printers are. AND their support forum provides active Linux support.

I know of no other printer manufacturer that comes even close to providing that. Plus IMHO the HP printer driver themselves (for Linux) are superior to the other manufacturer’s printer drivers (for Linux).

I own an all in one brother printer and works very well on openSUSE.
I went to the brother printer site and seen your brother printer model HL2030.

When you get into the brother site, you have to read the procedure on installing it to openSUSE and all will probably be smooth.

Here is the brother site have a look thru and see your driver.
Brother Solutions Center : Brother Driver for Linux Distributions

Your driver HL2030 is listed here

and here:
Brother Solutions Center : Brother Driver for Linux Distributions

Install instruction
Brother Solutions Center : Brother Driver for Linux Distributions
Brother Solutions Center : Brother Driver for Linux Distributions

The openSUSE you will see in the site that was tested was version 10.3 but in my experience it works with 11.2
Hope this will give you a good start to make your printer work.

Lastly this brother printer I have is the best so far in terms of producing quality colored copies I had tried with linux.

Nice links joerione! Thanks for the post.

I’d say, CUPS is CUPS, on *buntu the same as on openSUSE, so if the device did what it had to do on *buntu, it should work on openSUSE as well. Find out which cups driver was used on *buntu.

Ok. 11.2 did discover the printer and now it works! Thanks for all tip.

That’s excellent, congratulations.

For others needing drivers and in 10.x, 11.x use this:

HowTo Install a Brother Laser Printer HL-2040 in Suse 10.x, 11.x + User Notes