prime-select not working since 20220318

After a recent tumbleweed update (20220318, but have since updated to 20220324) my laptop failed to boot to a graphical desktop, dropping me to a console prompt. The most relevant error messages in the logs seemed to be sddm reporting:

Failed to read display number from pipe
Could not start Display server on vt 7

Web searches on this didn’t get me anywhere useful (though I once had this error due to a typo in a file in /etc/X11/xorg.conf.d).- /var/log/Xorg.0.log also repored (and still reports)

     8.590] (WW) Warning, couldn't open module intel
     8.590] (EE) Failed to load module "intel" (module does not exist, 0)

It also at that time reported “failed to initialize Nvidia kernel module”

This is a laptop with both an nvidia and intel graphics. I have nvidia-glG05 installed and I thought I had intel video drivers installed. Checking, it appears xf86-xf86-video-intel is not installed (though kernel-firmware-i915 and libvulkan_intel is…does libvulkan_intel take the place of xf86-video-intel?). I’m pretty sure that previous to this update I was able to prime-select between intel and nvidia successfully…most recently I’d switched to nvidia for a multi-monitor setup. I’m using suse-prime, not using bbswitch or bumblebee.

Running either
prime-select intel
prime-select nvidia
and rebooting resulted in the same failure to boot into a graphic mode.

However finally I tried
prime-select unset
and THAT got it to boot successfully into a graphical desktop (Plasma).

Since then (after the update to 20220324) I can run
prime-select intel
prime-select nvidia
and it still boots to a graphical desktop but it doesn’t appear to be doing anything since if I run
sudo prime-select get-current
it says

No driver configured.

and it doesn’t put a conf file for either intel or nvidia into /etc/X11/xorg.conf.d (which it did when I was stuck in text mode).
Running inxi -G -c0

Graphics:  Device-1: Intel driver: i915 v: kernel
           Device-2: NVIDIA TU104GLM [Quadro RTX 5000 Mobile / Max-Q] driver: N/A
           Device-3: Luxvisions Innotech Limited HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org driver: loaded: modesetting unloaded: fbdev resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics P630 (CML GT2) v: 4.6 Mesa 22.0.0

and sudo lshw -c video

  *-display UNCLAIMED       
       description: VGA compatible controller
       product: TU104GLM [Quadro RTX 5000 Mobile / Max-Q]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e0000000-e0ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:3000(size=128) memory:e1080000-e10fffff
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 05
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: irq:152 memory:df000000-dfffffff memory:a0000000-afffffff ioport:4000(size=64) memory:c0000-dffff

Can anyone tell me what is going on?

I think intel is in fact being used, from glxinfo

OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics P630 (CML GT2)

Possibly this nvidia driver does not work for my card (see another post about that), but why would prime-select not at least work for intel?

See you other post, that looks like the nvidia G06 driver isn’t installed…

Thanks, Malcolm.
The question of the right nvida driver aside, what about the behavior of prime-select wrt intel? With prime-select unset I understand it is letting xorg decide, and xorg is apparently choosing intel, but after running prime-select intel and rebooting prime-select get-current still reports “No driver configured.” It also puts no intel conf file into /etc/X11/xorg.conf.d as I believe it used to prior to these updates.

Actually I take that back…I don’t know that it did so before. Checking the snapshot directory before the update, there is a 90-nvidia.conf
(and nvidia was the state I’d been using it in), but I’m not sure about an intel file when prime-selecting intel. From the wiki info I’d expect these files to be in /etc/prime
but there are no conf files in the directory under the old snapshot, so the lack of files being copied into /etc/X11/xorg.conf.d may not be meaningful. However I do still expect prime-select get-current to report the intel driver being used.