prevent kernel update on zypper dup

hi, id like to avoid using the new release kernel on TW. How would i prevent the kernel from being updated, and would this cause problems? (is it a good idea)

You can easily do this by locking the kernel version in Yast -> Software Management. It’s not a bad idea I think except that you won’t have the latest kernel.

It’s not a good idea. You would miss security fixes.
What’s the reasoning re. wanting this ?

so have already tried

sudo zypper al kernel-default

but kernel-default-base kernel-default-devel-4.15.0-1.4 kernel-devel-4.15.0-1.4
are all still set for update. does this matter? should i instead lock kernel-*?

Just do it from yast easier to deal with and see what you do

but how does this solve the question of if i need to block kernel-default-base etc? why would using yast be easier than applying locks?

You can lock from yast the GUI makes it easier to see and understand what you are doing and the results. Yes can also be done from zypper but that’s a lot more typing LOL :stuck_out_tongue:

im not sure what you mean by using yast - i see no relevant guidance inside yast - i would still have to select which to lock - kernel-default is already locked but there are 3 other kernel files. Guess ill just lock all of them unless someone comes up with better suggestion.

> What’s the reasoning re. wanting this ?
sorry missed this message - i am under the assumption that the new kernels are more unstable - i.e. new features?

There is no such thing as ‘more unstable’. openSUSE releases and updates are openqa tested and must pass these tests before release. FWIW I’ve been running TW since it exists and have never met ‘unstable’ kernels.

Well, I currently have a reason to keep one particular version of the kernel.

Since 5.8.x, Virtualbox has stopped working with Tumbleweed. I need to keep 5.7.11 to work. I don’t care if zypper installs other verisions, but I would really like it to leave my 5.7.11.

Placing locks do not seem to work. I have tried something like this:

$ zypper addlock kernel-default-5.7.11-1.2 kernel-default-devel-5.7.11-1.2 kernel-syms-5.7.11-1.2 kernel-devel-5.7.11-1.2

or this

$ zypper addlock kernel-default-5.7.11-1.2.x86_64 kernel-devel-5.7.11-1.2.noarch kernel-default-devel-5.7.11-1.2.x86_64 kernel-syms-5.7.11-1.2.x86_64

But zypper dup insists on removing the old kernel versions. Any suggestions?

Best regards,

addlock doesn’t take the package version, as it would be pointless. There’s the multiversion feature which takes versions, I guess you’re mixing them both. You can just addlock with the package name. Re: the multiversion option, there’s plenty of advice on the forum already.

My method is to edit “/etc/zypp/zypp.conf” and change the “multiversion.kernels” line to:

multiversion.kernels = oldest,latest,latest-1,running

This assumes that the 5.7.11 kernel is the oldest currently installed.