PPPoE connection works over wireless lan but dns requests not possible

I have a laptop with an Opensuse 11.1 on it.
The problem is that my girlfriend has a PPPoE connection for her ADSL
which I want to use when I am there. With Windows Vista, which is also
installed on my laptop, I am able to dial-up. Everything is normal then.
Most of the configuration is automatic. You just need the username and
the password when you dial-up the first time. I think you all can
imagine those wizards for configuration and dial-up in Windows.

With Suse I have the problem that I can’t connect to any domain after
the dial-up. I can’t open e. g. google.de in the browser and can’t ping
it either. With the IP-address it works correctly. So I think that an
internet connection is established. In the local network everything is
fine, too. I can connect to the router and the other PC by pinging, http
etc. without any problems. So I suspect the dns requests to be defect
in any way. For sure I am open for other explanations.

In the yast DSL configuration I nearly tried every possible
configuration which didn’t end up in a total blockade of the dial-up. I
also tried to work with a non-automatic dns server. I tried servers from
different providers and the ones of opendns.com . I changed them in my
pc and in the router, too. Nothing works! It is always the same problem.
Google and so on also weren’t very helpful so I am a bit desperate. I am
also no expert on linux so please if you answer have this in mind ;).

Your connection isn’t getting a dns server address. You need to either set up the connection to get the address when it connects or manually add a known dns server address.

Well I already tried a manual dns set up with yast. There is a form in
the dsl configuration wizard where you can either add two dns servers or
set the configuration automatic. It doesn’t work in both cases.

I also changed the dns address in the knetwork manager for the wlan
connection. That doesn’t work either.
Then I changed the dns address in the router because I read it might be
a dhcp problem. No changes.

In addition I wouldn’t say that it doesn’t get any dns address because
in kinternet the configuration overview of the connection shows that
there is an dns address given. Unfortunately it is always the one that I
gave the computer in the yast dsl configuration wizard see above.

I was looking now again what might be wrong and finally it works now. I had to dial up with the router not with kinternet. I have no idea why. In windows it is vice versa.

Now it works. I was searching for the mistake and I found out that the router wasn’t dialed up. Actually no problem in Windows but probably in Linux. Now I musn’t dial up with Linux because the router does it autmaticly. With Windows it seems to be vice versa. Anyway it works lol! .