Post Cannot access any GUI/KDE on OpenSuse 11

This is my first post. I posted this in installation/login first but I might more properly belong here. I am a newbie. I have been using suse 11 for about 3 weeks now and I love it. But I have a serious problem.

I normally run KDE 3.0 but I wanted to try something different. I was using enlightenment which worked great and then I logged out. I then tried to set my windows manager to Metacity.

It attempted to enter the GUI but failed. Ever since I did that I can no longer get into any GUI on Suse.

Basically what happens regardless of whether I run failsafe or the standard version the system starts but I eventually just reach a blank screen and the X cursor appears and then a mouse cursor appears and then it just sits there. I can move the mouse around but nothing happens.

I have tried entering the terminal and using Yast to change my window manager back to kdm3 and startkde but it has not helped. I have also just typed KDM into the command line and it will just boot to the same blank screen with the mouse cursor.

I have also tried to type startkde from the command line and the first things it says is “cannot access display” and then fails to start. I just don’t know what I could have screwed up by simply trying to change the windows manager.

One more thing is that I did recently install Wine, but the computer ran fine after the installation so I don’t think that is the problem.

Any advice would be greatly appreciated and if you need any more info please ask me. Thank you.

Since you switched DE I guess your auto login is not enabled. Read this post to findout how you can switch back to KDE 3. I have KDE 3, KDE 4 and gnome installed and switch between them.:slight_smile:

The problem is I can never even get to KDM, the desktop manager to change the one I am using. Suse just boots to a blank screen as described above.

Problem solved by wmsneal

Re: Cannot start OpenSuse 11 after changing to Metacity
I made the same error. My problem was that my user profile had “Automatic login” turned on. That meant that whatever I did would revert back to the previous login parameters; in this case the Matacity blank screen.

My solution was to go to the boot splash screen (I had to insert the program DVD) and on the boot parameter line write “init 3” I then logged in as root and gave the command “startx” which gave me the root desktop. Since this was a different user login, there was no problem. I then opened YaST and went to the Users section. There I looked up my profile and deslected “Automatic Login” When I finished the process, closed YaST and rebooted, the login splash screen opened. Under session I chose the KDE session I wanted and then logged in. I had my desktop once more!

To avoid problems in the future, I’ve decided to avoid using automatic login.