pLZ HELP!!! Nvidia 330M openSUSE 11.4

I have been a ubuntu user for years and now am attracted to completely shift to OpenSUSE,
But after more than 12 hours of searching z web, trying installing Nvidia driver for GEFORCE 330M in my Samsung RF510 laptop i have reached a crashing point.

I did add the community nvidia repository, but there am meeting a lot of drivers about not less than 3, i don’t know which is which…
I tried installing i did tried the one which states is for newer drivers, but after reboot the GUI couldnt load, i had to reinstall my system, that did hurt!:frowning: So now i want to do it without pain!!

So please, may you help me out a more cleaner way to do it!!!:\

Please z developers should come out with an automatic driver detector and download as in our fellows ubuntu,…i think its a good thing!!!
Please am waiting!!!
Thanks in ADVANCE!!

Install the x11-video-nvidiaG02 and nvidia-gfxG02-kmp-xxxxxxxx where xxxxxxx is found from looking at the return you get in a console from running this: uname -r

For example if you get this:

john@tumbleweed114:~> uname -r

then you would choose nvidia-gfxG02-kmp-desktop

Before you proceed, what’s the return you get from this command: /usr/sbin/hwinfo --gfxcard
and from this command: ls -l /etc/X11 | grep conf


stephen@linux-8rn2:~> /usr/sbin/hwinfo --gfxcard
21: PCI 200.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: B35A.9GQ4tfkfYHB
Parent ID: vSkL.A7hVQ21B8VD
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: graphics card
Model: “nVidia VGA compatible controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0a29
SubVendor: pci 0x144d “Samsung Electronics Co Ltd”
SubDevice: pci 0xc08e
Revision: 0xa2
Driver: “nouveau”
Driver Modules: “drm”
Memory Range: 0xdc000000-0xdcffffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
Memory Range: 0xde000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0x2000-0x2fff (rw)
Memory Range: 0xdd000000-0xdd07ffff (ro,non-prefetchable,disabled)
IRQ: 16 (5296 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000A29sv0000144Dsd0000C08Ebc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Driver Info #1:
Driver Status: nouveau is active
Driver Activation Cmd: “modprobe nouveau”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)

Primary display adapter: #21


stephen@linux-8rn2:~> ls -l /etc/X11 | grep conf
drwxr-xr-x 2 root root 4096 Mar 26 12:27 xorg.conf.d


Yes, green light.

Get it right with ‘uname -r’

If you get a blank screen after install, don’t re-install this time, instead revert to “nouveau” and you’ll get a GUI back. Ask how to do that if the time comes.

I got default after entering uname -r
so i went to install nvidia-gfxG02-kmp-default-260… but YAST has show there is a conflict, ‘NOTHING PROVIDES BINUTILS NEEDED BY NVIDIA…’

Bin utils should be available. I wonder what Software Repositories you have installed…
Run this command and post back here: zypper -ls

Use “advanced” form in your post and put the results in “code” tags – easier to read.