Plymouth fallback screen on Tumbleweed. (Nvidia Drivers)

When booting my system, plymouth uses the fallback screen/theme, a grey screen with 3 green dots.

I have tried adding options nvidia_drm modeset=1 to /etc/modprobe.d/nvidia.conf and

add_drivers+="nvidia nvidia_modeset nvidia_uvm nvidia_drm"
install_items+="/etc/modprobe.d/nvidia.conf" 

to /etc/dracut.conf.d/nvidia.conf.

I ran sudo dracut -f --regenerate-all afterwards, and it did not resolve the issue.

Plymouth works fine when shutting down, but not when booting up the system. It works if I add nvidia_modeset.drm=0 and/or nvidia_modeset.fbdev=0 to my grub config, but this breaks any Wayland DEs.

I am using a GTX 1660Ti, with the latest Nvidia drivers installed. Any idea how to fix this?

Any idea what logs I should check to resolve this? Checking journalctl didn’t really help.

I’m not exactly sure, what you mean. Do you want to see the lines of the boot sequence? As what you see when hitting ESC?
For me, adding “splash=verbose” to the kernel boot parameters did the trick. Any “silent” or “quiet” should be removed from the parameters.

I just tried splash=verbose, didn’t work. I am not trying to see the boot sequence, I want to see the plymouth splash screen (distro logo with spinning loading icon usually).

@aliqut Hi, this is just a system with a Nvidia GPU? If so fire up YaST Bootloader and add nvidia_drm.modeset=1 to the grub kernel options. Caveat, I don’t use plymouth, it gets uninstalled here… So if still not working, suggest checking the output from lsinitrd to see it’s included. Might also need to check what plymouth and libply packages are installed.

I have nvidia_drm.modeset=1 in my grub kernel options.
lsinitrd has both plymouth and the nvidia drivers, everything seems fine.
All packages needed for plymouth should also be installed and working. It actually displays just fine when shutting down my system, just not when booting. Maybe the nvidia drivers aren’t being loaded early enough or there is some sort of conflict.

Also, I’ve tried running sudo dracut -f --add-drivers "nvidia nvidia_drm nvidia_uvm nvidia_modset, didn’t work.

@aliqut No, you need to remove the /etc/modprobe.d/ nvidia config, run dracut -f --regenerate-all then in the grub kernel options also add fbdev=1

When you say should be installed, please verify with zypper se -si libply ply and check

Just tried your suggestion, and it did not work.

zypper se -si libply ply:


S  | Name                       | Type    | Version                   | Arch   | Repository
---+----------------------------+---------+---------------------------+--------+--------------------
i  | libply-splash-core5        | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply-splash-core5        | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply-splash-core5        | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | libply-splash-graphics5    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply-splash-graphics5    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply-splash-graphics5    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | libply5                    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply5                    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | libply5                    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth                   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth                   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth                   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth-branding-openSUSE | package | 84.87.20240405-1.3        | noarch | (System Packages)
i  | plymouth-dracut            | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-dracut            | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-dracut            | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-lang              | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-lang              | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-lang              | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-plugin-label      | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth-plugin-label      | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth-plugin-label      | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth-plugin-two-step   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth-plugin-two-step   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | openSUSE:Tumbleweed
i  | plymouth-plugin-two-step   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth-scripts           | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-scripts           | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-scripts           | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-theme-bgrt        | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-theme-bgrt        | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-theme-bgrt        | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-theme-spinner     | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-theme-spinner     | package | 22.02.122+94.4bd41a3-11.1 | noarch | openSUSE:Tumbleweed
i  | plymouth-theme-spinner     | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss

@aliqut So why didn’t the rebuilt package plymouth-branding-openSUSE get installed?

It should be at -1.4 not -1.3?

@aliqut It also appears you have duplicate repos, added something via 1-click? Suggest you post the output from zypper lr -d as well.

Yes, I have used 1-click before. Why would this result in duplicate repos though?

zypper lr -d:

#  | Alias                                    | Name                                                 | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                        | Service
---+------------------------------------------+------------------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------------------+---------
 1 | NVIDIA:repo-non-free                     | repo-non-free                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/tumbleweed                                                            | NVIDIA
 2 | ftp.gwdg.de-Essentials                   | Packman Essentials Repository                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials                              | 
 4 | https-download.opensuse.org-4d8af06c     | openSUSE:Tumbleweed                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/tumbleweed/repo/oss/                                                         | 
 3 | https-download.opensuse.org-170dba36     | openSUSE:Tumbleweed                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                                  | 
 5 | https-download.opensuse.org-bc15dc3e     | home:luisbocanegra                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/luisbocanegra/openSUSE_Tumbleweed/                        | 
 6 | multimedia_proaudio                      | multimedia:proaudio                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/multimedia:/proaudio/openSUSE_Tumbleweed/                       | 
 7 | openSUSE:repo-non-oss                    | repo-non-oss                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/tumbleweed/repo/non-oss                                                            | openSUSE
 8 | openSUSE:repo-openh264                   | repo-openh264                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Tumbleweed                                                    | openSUSE
 9 | openSUSE:repo-oss                        | repo-oss                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/tumbleweed/repo/oss                                                                | openSUSE
10 | openSUSE:repo-oss-debug                  | repo-oss-debug                                       | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/debug/tumbleweed/repo/oss                                                          | openSUSE
11 | openSUSE:repo-oss-source                 | repo-oss-source                                      | No      | ----      | ----    |   99     | N/A    | http://cdn.opensuse.org/source/tumbleweed/repo/oss                                                         | openSUSE
12 | openSUSE:update-tumbleweed               | update-tumbleweed                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://cdn.opensuse.org/update/tumbleweed                                                                  | openSUSE
13 | packman                                  | Packman                                              | Yes     | (r ) Yes  | Yes     |   70     | rpm-md | https://ftp.fau.de/packman//suse/openSUSE_Tumbleweed/                                                      | 
14 | shells_zsh-users_zsh-autosuggestions     | zsh-autosuggestions (openSUSE_Tumbleweed)            | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://download.opensuse.org/repositories/shells:/zsh-users:/zsh-autosuggestions/openSUSE_Tumbleweed/     | 
15 | shells_zsh-users_zsh-syntax-highlighting | zsh-syntax-highlighting (openSUSE_Tumbleweed)        | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://download.opensuse.org/repositories/shells:/zsh-users:/zsh-syntax-highlighting/openSUSE_Tumbleweed/ | 
16 | utilities                                | all the small tools for the shell (openSUSE_Factory) | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://download.opensuse.org/repositories/utilities/openSUSE_Factory/                                     | 

I have exactly the same issue that user aliqut but my driver is amdgpu (Radeon R3 integrated). I have Tumbleweed, and until the update that broke the Plymouth Splash, it charge and run very well and elegant. But now that grey screen with 3 ugly dots (where now and then i can see some lines of the “text booting”) get the sense of “something is wrong”.
The update that broke the regular Plymouth Splash screen was the first with the 6.9 kernel, if this means.

Regards.

@aliqut so some are provided by the ‘service’ (far right column) some from the install, plus you have duplicate packman ones…

Did you manage to update the branding one?

I’ve removed the duplicate repos, repos 2,3, and 4.
zypper se -si libply ply:

S  | Name                       | Type    | Version                   | Arch   | Repository
---+----------------------------+---------+---------------------------+--------+-----------
i  | libply-splash-core5        | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | libply-splash-graphics5    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | libply5                    | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth                   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i+ | plymouth-branding-openSUSE | package | 84.87.20240405-1.4        | noarch | repo-oss
i  | plymouth-dracut            | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-lang              | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-plugin-label      | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth-plugin-two-step   | package | 22.02.122+94.4bd41a3-11.1 | x86_64 | repo-oss
i  | plymouth-scripts           | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-theme-bgrt        | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss
i  | plymouth-theme-spinner     | package | 22.02.122+94.4bd41a3-11.1 | noarch | repo-oss

Version is now 1.4, but still, plymouth isn’t showing properly on boot, only on shutdown.

@aliqut the only thing I can think of is forcing the reinstall of those packages with zypper…

just tried reinstalling them with zypper in -f, hasn’t fixed the issue. I’ve tried adding plymouth.debug=1 to kernel boot params, but the debug file wasn’t written to /var/log/plymouth-debug.log.
all this for some eyecandy :skull:

@aliqut bug report would be my suggestion then… openSUSE:Submitting bug reports - openSUSE Wiki

1 Like

Yeah, sorry. Then my advice was the exact opposite. :face_with_diagonal_mouth:

UPDATE:

Installing the Nvidia 555.58 drivers fixed the issue.