Plymouth boot screen not appeares on opensuse tumbleweed!

I having a problem with plymouth boot screen when the pc is booting the plymouth boot screen not appears But a screen appears with three green squares with a gray background !!!
I noticed that when restarting or shutting down it works fine.
I’ve tried many plymouth boot screens , but the problem is the same.
my Graphic card Is " amd radeon hd 7480d " , and the drivers is installed and works well .
Is there any solution ?
Thanks a lot

This is text splash screen which Plymouth uses when kernel video drivers with KMS support are not available. You could upload full output of command

journalctl -b --no-pager --full

run as root to to check what happens during boot.

P.S. there is no need in so many exclamation marks, this is just a technical question, not life or death problem.

1 Like
journalctl -b --no-pager --full

I said “run as root”.

I said “run as root”.

I am not sure how to get this output but it does not contain any normal boot messages including kernel. Please try to reboot and immediately collect output of dmesg.

i’m restart pc now and run dmesg
and the result is :

It could be this long delay before AMD driver is initialized

[    5.133537] fbcon: radeondrmfb (fb0) is primary device
[    5.381128] Console: switching to colour frame buffer device 180x56
[    5.474894] radeon 0000:00:01.0: [drm] fb0: radeondrmfb frame buffer device
[    5.488342] [drm] Initialized radeon 2.50.0 20080528 for 0000:00:01.0 on minor 0
[    5.495726] AMD-Vi: AMD IOMMUv2 loaded and initialized
[   11.366616] [drm] amdgpu kernel modesetting enabled.

I am not sure what can be done in this case. I suppose one could make plymouth service depend on the correct device, but it would mean you have most of the initial boot without splash screen anyway.

For testing one could try to blacklist AMD drivers in initrd.

1 Like

Disabled plymouth on the kernel command line. It doesn’t annoy any more:

3400g:~ # journalctl --dmesg -g Command
Jun 17 19:30:33 3400g kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-6.3.7-1-default root=UUID=e7ad401f-4f60-42ff-a07e-f54372bc1dbc quiet loglevel=0 plymouth.enable=0 mitigations=auto
3400g:~ # 
1 Like

It seems that the problem is from the graphics card as it is quite old.
Thank you for the help.

Was plymouth working before?
This could be an edid detection problem or you are using a higher resolution not supported for plymouth to show. In grub shell you can find the resolution that you might be able to use:
The command is videoinfo
You can add the supported video resolution in the kernel lines in yast2 bootloader and see if it will work.

yes it was working before , and resolution is supported .
I tried change video resolution before but it didn’t work.
thank you

How long ago was this “before”? Do you still have previous kernel or previous snapshot that worked?

How long ago was this “before”? Do you still have previous kernel or previous snapshot that worked?

I think about a year ago
I was using leap then switched to tumbleweed.

Well, if you can demonstrate that Leap works and Tumbleweed does not, it can be considered regression and may warrant bug report. The problem is to find out what is responsible - too man changes.

Could you boot with plymouth.debug on kernel command line and provide /var/log/plymouth-debug.log?

Could you boot with plymouth.debug on kernel command line and provide /var/log/plymouth-debug.log?

how to do this ?

Howto change kernel boot parameters temporarily:

1 Like