Please help resolve this

hello all,

could someone help with the following as I’m totally frustrated with my wireless connection.

Network settings show

AR242x 802.11abg Wireless PCI Express Adapter (Not connected)
BusID : 0000:05:00.0
Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

Any advice would be much welcome

Thanks in advance

have you installed the drivers/firmware ? i believe the madwifi drivers are the one’s you want


Thanks for replying Andy

could you be a gent and point me in the right direction on how to find and download them.

Add this to your list of repositories Index of /suse/11.0 or you can use the 1-click install boogie found here Webpin



Thanks for that, I have downloaded and read other bits & bobs on this site but still no joy.

I have tried to blacklist the ATh5 but get permission denied !!

Any ideas anyone?

Thanks in advance

I have tried to blacklist the ATh5 but get permission denied !!

You need to be root user first. Use the ‘su’ command.

Thanks for the reply, I did that and still got this

steve@linux-2s36:~> su
linux-2s36:/home/steve # /etc/modprobe.d/blacklist
bash: /etc/modprobe.d/blacklist: Permission denied
linux-2s36:/home/steve #

any help would be greatly appreciated:(

You were trying to “run” blacklist as a program! It is not a program, it is a simple text file where all blacklisted drivers are listed. Use some simple texteditor to edit it.

apologies, but what should i type then

thanks in advance

On 2008-09-08, spf11 <> wrote:
> apologies, but what should i type then
> thanks in advance

Use cat to display the contents of the file:
cat /etc/modprobe.d/blacklist

If it’s more than 1 page, try:
cat /etc/modprobe.d/blacklist | less
(press ESC to get out of that)

Hanlon’s Razor:
Never attribute to malice that which is
adequately explained by stupidity.

if you want a gui to edit, open a console & type

kdesu kate /etc/modprobe.d/blacklist 

add the device/driver to the list & save


Thanks for replying, I’m a little embarrassed to ask but could one of you kind gents reply with an idiots guide of how to blacklist ath5, as i have opened the text editor and nothing happened and i am now so confused and frustrated with my lack of know how>:(

apologies if this is like pulling teeth but i would be so grateful for your help.

thanks in advance


You need to add the line

blacklist ath5k

to /etc/modprobe.d/blacklist with the editor. (BTW, the file should not be empty- check for typo if this is the case).

copy/paste the line of text i put in my post. You should be asked for a password, give root’s password & it will open