Please help me open port 8303?

I am trying to run a Teeworlds (game) server and am getting the following message;
ERROR: configure your firewall/nat to let through udp onport 8303.
I have my router setup right (I successfully tested the game server on MS Windows using same port).
I have also tried shutting off my OpenSuse 11.1 firewall using Yast but the error still occurs.
All help would be much appreciated.

Michael

adding a port in the firewall is easy

see this thread
A Quick Bittorrent Guide (with screenshots) - openSUSE Forums

Now open Yast - Security and Users and go to Firewall
Yast Security and Users
ImageShack - Best place for all of your image hosting and image sharing needs

ImageShack - Best place for all of your image hosting and image sharing needs

Then to Allowed services
Yast Firewall go to Allowed Services
http://img111.imageshack.us/img111/5…rewall3mj9.jpg

Then the Advanced button. Brings a box. Here add the port numbers you selected for use in ktorrent or Vuze and wrote down!
Allowed Services – Advanced
http://img111.imageshack.us/img111/5…rewall4wq9.jpg

But if you switched the Firewall Off - then you must have something wrong elsewhere.

Suppose your router is at address 192.168.1.1 (for example). Set your PC to have a fixed IP address on the same subnet as the router, e.g. 192.168.1.10. Browse to your router at http address htt p//192.168.1.1 and edit the settings there to “port forward” UDP port 8303 to the address of your computer (e.g. 192.168.1.10). Then open port UDP 8303 in Suse’s firewall ==> goto Yast → security and users → firewall → allowed services → advanced → udp → enter 8303

Try that

@caf4926 – two minds in synchronous thought :wink:

Thanks for your assistance, with your input I think I know where I have gone wrong. The router port forward is set up for my laptop at another ip address.
Unfortunately I now have another problem, in that I am unable to launch executable files in terminal. So now I can’t even launch the server. I must have altered something in my firewall & security settings while trying to overcome the port forwarding problem. I will meddle some more to attempt to resolve this issue (hopefully without ruining other critical part of my installation).

Thanks once more.
Kind Regards
Michael

I have no idea why, but I have discovered that I can execute files if I put ./ in front of the command.
That aside the server is now working.
Cheers for the help.
Kind Regards
Michael

./ is shorthand for “look for the executable in the current directory”

Thanks swerdna.

caf4926 wrote:

> But if you switched the Firewall Off - then you must have something
> wrong elsewhere.

If you switch off SuSE-Firewall, you switch off port-forwarding as well.


RU,
Tobias.

Port forwarding is performed in the router which routes the comms to the IP of the Susebox. Then to get through SuSEfirewall2 you either open the appropriate port/s in SuSEfirewall2 or switch SuSEfirewall2 off.