Please, help me making my tv card work.

I already knew Linux for a while but I’m new to Opensuse. I found it very easy to configure using Yast. In few days I put everything working the way I need and doing everything I used to in Windows. There is just one anoying problem.
No matter what I do I can’t make my TV card work. It is a Zogis Real Angel 330 Plus.
Yast recognized it and automatically created a config file in /etc/modprobe.d, wich I don’t know if is right.
I changed Yast tv card config sometimes and don’t know what is the better way. I don’t know if it is better to check that tv card is connected to HDA or to Conexant (wich is the name of the card’s chipset). In Yast I found no option to Real Angel 330 so I also tried to choose Real Angel 220, unknown card cx8xx driver and Conexant DVD-T reference desing but with no better result. So I removed the card and let Yast recognize it automatically again.
As I saw in another thread, I downloaded the xc3028-v27.fw firmware file and placed it at /lib/firmware. After configuring channels, region and tv norm accordingly to what is recomended to my region (Brazil) the best I got is a very bad image and no sound in xawtv and motv, using Television as input source (the only one that worked).
If I connect tv card externally to soundcard the only sound I get is noise as that of out of tune channels. If I don’t do it I get no sound at all.
Strangely in Windows all the same channels keep working right but no in Linux.
In TVtime I got no results and could not even change channels in it. I tried to install Mythtv but it was worse. In the first config screen it never connected. It also made all video input sources disappear in all other programs leaving only DVD that didn’t work. I had to uninstall it and delete all config directories realted to tv in my home folder to make things go back to the bad image and no sound config I had before. And that is all I get.
Please, help me because Opensuse is so good that I have used it almost all the time and I can’t close everything I’m doing and restart in Windows everytime I want to watch a tv show.
Regards. And thanks for any help.


Have you put the card identification number in yast --Hardware —TV Card?

If not look in the file /var/log/boot.omsg or /var/log/boot.msg. On my system a similar card is stated as :-

<4>    7.434779] saa7134:   card=150 -> Zogis Real Angel 220

Whatever the number is on your system in needs to be placed in the TV and Radio Card Configuration.

Try the above if an exact match cannot be found else try card=0 -> UNKNOWN/GENERIC

If its already done, sorry for wasting your time.

Happy new year.



Just for info my modprobe.d file is as follows. Its no help but just more info.


alias char-major-81 videodev
options i2c-algo-bit bit_test=1

# YaST configured TV card
# Kaa7.XzkttnXJLD4:User-Defined TV Card
alias char-major-81-0 saa7134
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off
options saa7134 card=2

for a card 8681 LV-LifeView FlyVideo 3000.

I see now that selecting card=150 does not do anything as it has no specified parameters.

Happy hunting.


ps. The card works much better under Linux with tvtme, than it ever did in Windows with the supplied software.

Third try at imparting some info,

Note: TV cards normaly need a propriatry video card driver installed.

  1. Delete all installed TV software (the software must be installed after correct hardware detection).

  2. Verify the TV card is correctly recognised,
    e.g. lspci | grep Multimedia
    03:06.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

  3. Verify v4l driver module is correctly installed in the kernel,
    e.g. lsmod | grep v4l
    v4l2_common 19935 2 tuner,saa7134
    videodev 43828 4 tuner,saa7134,v4l2_common
    v4l1_compat 17249 1 videodev
    v4l2_compat_ioctl32 11349 1 videodev

  4. Only if the above is confirmed, install preferred TV software and reboot or restartx.

If all has gone to plan you should see a selection of input sources in the TV installed software.
e.g. Input source: Composite 1 & 2, TV, TV mono, S-video.

Thank you very much for your interest in trying to help me. Sadly my problem still remains. I will appreciate it if you shed more light on it.
I tried to see the card number on /var/log files and it was detected there as Powercolor RA330, card number 62. Amazing! The correct model was already detected.
I cahnged the card number in .conf file at /etc/modprobe.d to card=62 but all I got was a image a little less worse and constantly alternating between colors and black&white&gree.
still no sound at all.
lspci | grep Multimedia returned nothing at all.
lsmod | grep Multimedia nothing at all too.
lsmod | grep Multimedia returned:
v4l2_common 16673 3 tuner,cx8800,cx88xx
videodev 39358 4 tuner,cx8800,cx88xx,v4l2_common
v4l1_compat 14629 1 videodev
i2c_core 26632 10 nvidia,tuner_xc2028,tuner,cx8800,cx88xx,v4l2_common,videodev,i2c_i801,i2c_algo_bit,tveeprom
I see here the tuner as cx8800,cx88xx. The last thing I tried on Yast was to select the card as cx88xx. My surprise here is that lsmod | grep Multimedia dysplayed what seems to be the correct number for chipset of this kind of card: cx8800.
So what is wrong or missing?

Ok, I don’t know your card but I installed already many different brands for friends.
The point is that the distribution endorses just some uncommon brands of tv cards and for the others, common brands included, we have to do manually. So, tonight I’ll take a look around. You could meantime delete ALL traces of your installing, firmware included but we will put it back on the right moment :). My first questions: has your card S2 capabilities? Has your LMB a switch? Is your card a budget one (also called BDA)?
Don’t worry, I never saw a not perfectly working tv card under Linux.

ok, I see:
Placa de TV Zogis Real Angel 330 Plus
Chipset Conexant CX2388X-10bit
Core Software MPEG2 Encoding
TV System NTSC, PAL & SECAM (E todas variações)-Worldwide
Input TV/FM, Video/Audio, S-Video/Composite
Áudio integrado (line out opcional)
Interface PCI
1 conector para a antena da TV
1 conector para a antena do FM
1 Conector de múltiplas funções
1 conector para o sensor do controle remoto

A dvb-c tv card mostly sold in Portugal and Brasil.
You need the last proper driver and perhaps I know were to find it and were to get the right driver name.
Tomorrow I’ll check the solution,

If you can help me with the driver I will be very, very thankful. I don’t know answers to the questions you posed in your first reply but what you found about the card is true. I am brazilian and this card really has this specifications you mentioned. As I told above I placed the xc3028-v27.fw firmware file in /lib/firmware but something really seems to be wrong about it. No configuration leads to fine results. Yesterday I found out in another site that Real Angel 330 is the same as Powercolor RA330. So I chose Powercolor RA330 in Yast and things continued the same: no sound, bad image, colors oscilation.
My tv card is really keeping me tied to MS Windows and preventing me to advertise Linux to my friends.
If it has to do with the driver pelase, help me find the right one and tell me what I ahve to do with it.
Again, it would be an enormous help and I would be very thankfull.

Well, I promised. :slight_smile:
Today is sunday and in the evening (Europe) I will have time to check a couple more of things. Meantime please delete every trace of your previous configuration. firmware included, however we will possibly need it again, but renamed. Please read also the following tread, concerning a different card which I had to install for a friend. Don’t panic if you don’t know about programming. Like you can see, we will get the best assistence from everywere. Oh, install also mercurial, you will wonder about what linux kann do!
Until later.
By the way, I am fluent in spanish, what makes me able to understand a bit portugise. :slight_smile:
the tread:
Substitute hxxp with http :slight_smile:

Have you run the command,


does it make any difference if you do?

Posting its output might he helpful.

hi killambert,
fernando had already the driver installed and a poor reception: we are getting ready to install the last driver, until a positive response from dmesg. Then we will deal with the tv software, and also need your help, I am not very found about :slight_smile:

Hi keellambert and Capodastro. both of you have been of much help. I have often felt in this forum that most Opensuse users seem to polish and give practical and quick replies. It’s very nice and keeps me willing to continue using this distro. I have to tell you about something that happened today to see if you know what is happening and can help me.
After much frustration trying every possible configuration I followed the steps of this site Instalar placas de captura (wirtten in portuguese). I even erased all the content of 50-tv.conf file at etc/modprobe.d and replace it by the content of the conf file of the tutorial. I had already the firmware (downloaded from somewhere I don’t recall) but I decided to delete mine and download it again from the recommended address. Only the extractor link of this tutorial was broken and I had to find the extractor searching in Google.
After that I compiled the firmware according to the instructions of the tutorial and placed it again, with the same folder and the same name. I was a bit discouraged and didn’t think it would work. But after rebooting, to my surprise the image was as good as in Windows softwares.
The only remainig problem is that there is still no sound at all. No matter what I do in system mixers or in audio config in tv softwares I get no sound. If I try to connect the tv card to the soundcard externally using the supplied cable from the vendor I get only loud noise.
Now can you help me through with this?
Thank you in advance for any guidance.

Some more details:
Now when I connect the tv card externally to the auxiliar in the sound card I hear much noise but deeply mixed with the noise it’s possible to a very low sound of what is going on the tv. I tried to connect an mp3 player to the same entrance of soundcard and it worked perfectly with a good quality sound, demonstrate that the system recognizes the input in aux in. It’s also possible to control the volume of the noise adjust the volume of tv in tv applications. With the external connection there is no tv sound. I checked mixers like pulseaudio mixer and gmixer. I found no control in the that correspond s to the aux in of sound card, neither for when tv card is connected there nor when I connected the mp3 player.
In the mixers devices I found one called Capture CX23880/1/2/3 PCI Video and Audio Decoder [Audio port] Analog stereo (Pulseaudio mixer) but moving it doesn’t change anything about tv sound, as moving any other mixer controls doesn’t. There is also a mixer control called Conexant CX8811 (Alsa mixer) but there is no control for it in the mixer. It’s just assinged as playback device but with no control or buttons for it.
Here is the content of etc/modprobe.d 50-sound.conf:

options snd slots=snd-hda-intel

u1Nb.BXcO1cwz+ZE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

And here is the output of lspci:

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 10)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8400 GS] (rev a1)
02:00.0 Ethernet controller: Atheros Communications L2 Fast Ethernet (rev a0)
03:02.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
03:02.1 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [Audio Port] (rev 05)

to verify your sound setup have a look at

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool

it looks from the output of lspci that the HDMI sound is activated in your machine bios (00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01).

if all else fails try disabling it

Also have a look at the TV standard that is selected on the TV card. Different standards have the audio at different frequencies. Select each in turn and see the result. The standards available should be something like: NTSC, SECAM, PAL, PAL-NC etc.

Also check that the sound on the TV card: Preferred audio mode (PAL-I, PAL-BG, PAL-DK), Audio Volume boost, Mute.

All the above should be available via Setup - Input Configuration for you TV card.

Thank you very much! I had already read that for the region where I live the correct norm is Us and PAL-M. Really only PAL-M gives right results with colors and image but combining with PAL-BG in sound I got sound and image. However I got sound only using the external cable connection and allow Tvtime to total audio output.
I got better results in Tvtime since it keeps settings saved for the next run. Xawtv seems easier to configure but it’s exhausting to re-configure it everytime i launch it. I tried to receord in Xawtv but just got a low quality video file separated from the audio, and the audio had nothing recorded on it. While it records it also destorts the image significantly making it hard to watch while recording.
How can I watch tv on Tvtime and record at the same time? Is it possible to have a record with audio and video mixed correctly since I am using an external audio connection?

For controls in tvtime have a look at the file /usr/share/doc/packages/tvtime/html/usage.html.

I was able to perform some recordings using VLC and Xawtv. But at no record I got any sound. The big problem is that I just got sound connecting tv card externally to the soundcard and it seems that recording applications take the sound directly from the video source that in my case has no sound here. I need either a software that records video from tv source but audio from auxiliar in from the soundcard or some configuration that makes system recognize sound of the tv card without external connections.
For this last option is it possible to some line to .conf files related to audio or to related to tv to do it?
Please take a look at the .conf file that I created manually (not using Yast) and that finally worked and the .conf file of audio that was generated in the system installation and always worked for me.

Note about 50-tv.conf: I still didn’t configure the radio tuner and don’t know the right way to do it. I don’t know if it would make system recognize sound from tv card. There is a commented line in .conf file about it. Is there some line where i could mess to make sound directly available to the system?

Here goes the content:


options snd slots=snd-hda-intel

u1Nb.BXcO1cwz+ZE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel


cx88xx módulos

quando inicializar o modulo cx88xx usa estas opções

escrito por Mstr (GLP)

adaptado por (seu nome)

isto também pode ser usado para setar varias placas de captura

alias char-major-81 videodev
options i2c-algo-bit bit_test=1
alias char-major-81-0 cx8800
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off

se precisar alterar os devs vídeo para 1 descomente essa linha

options cx8800 video_nr=1

ainda pode-se incluir na linha acima (só inclua se desejar alterar o valor default)

video_nr=0/1/2/3, default é 0 (/dev/video0)

vbi_nr=0/1/2/3, default é 0 (/dev/vbi0)

radio_nr=0/1/2/3, default é 0 (/dev/radio0)

outra informações podem ser obtidas em ‘modinfo cx8800’

options cx88xx card=62 tuner=71

ainda pode-se incluir na linha acima (só inclua se desejar alterar o valor default)

radio=tuner para o radio (lista de tuners)

outra informações podem ser obtidas em ‘modinfo cx88xx’

Your 50-sound.conf & 50-tv.conf files look ok.

In your audio mixer, I assume you have enabled all channels and tried in turn
each capture channel under the tab for the TV-card.
Check all audio channels are enabled for display for both audio (should be at
least 10) and TV (should be at least 3).

It is very puzzling. I disconnected the external cable to see if it’s possible to get internal audio, what would be recordable by softwares. So I went to Pulseaudio device chooser and chose CX23880 PCI Video and Audio Decoder as the capture input device. I may go to any mixer and put all volumes up that I get no audio from TV. But what is really puzzling is that when I leave some TV software running and go to Pulseaudio mixer and to the tab input I see the bar that displays the volume output of CX23880 moving as the TV characters speak. The bar is constantly filled above 50% of its width and sometimes almost to the limit as if there were some audio being played. It seems that the device is recognized by the system but for some reason the audio doesn’t come out nor is recorded.
All analog TV softwares I have (Tvtime, Motv, Xawtv) doesn’t have any option of audio output (as Alsa, OSS, Pulseaudio…). I don’t know how to route the TV audio output and don’t know if such a thing would work.
Any solution to this?

PS: All my mixers don’t have any option called display or tv.