Playing desktop audio whilst calling compresses its audiometric range

I’ve had this in the drafts for a while now, but wasn’t certain whether it was caused by something I’d done. However, now that I’ve experienced it at Playing desktop audio whilst calling compresses its audiometric range - Fedora Discussion too, I’ll post it because despite it occurring on two OSes, I have no idea what the commonality and thus problem is.

  1. Problem

    If I call someone via Discord whilst playing music (via or, or even locally) when the call connects, the audio immediately sounds as if its dynamic range has been compressed.


    Not yet known.

  2. Workarounds

    Don’t call anyone whilst playing music, unfortunately.

Does anyone here know? The crux is that when OBS is recording, or I’m calling someone, any audio I play has a significantly reduced dynamic range.

What is your audio device - are you using headphones? How are they connected?

What you describe sounds like what happens when using a bluetooth headset - the spec allows for full stereo audio playback, but for a degraded experience when using a bluetooth headset’s microphone.

If that’s what you’re using, it’s a hardware limitation, and I understand that it’s actually part of the bluetooth specifications - so is expected behavior.

1 Like

@hendersj, indeed, I’m using my SONY WH-1000XM5s via a PCIe Bluetooth 5.(1/2) card. However, I’m using a separate microphone, itself connected via USB-C.

Perhaps whatever provides audio is auomatically limiting my playback as if I were using the device’s microphone, even if I’m not? Do you know what software I’d need to investigate to in this instance?

It was misconfigured - Discord has a habit of changing to a different device. Changing back to the dedicated microphone fixed it.

Thank you, @hendersj.

1 Like

If the Sony headphones have a mic plugged in, check to make sure that you’re using it in the mode that isn’t “handsfree” (I want to say it’s “headset” or “headphone” mode).

Where you’d look depends on the desktop environment you’re using. In GNOME, you can look at sound settings and see what the input is set to. If it switched to the Sony headset, it might’ve picked that headphone by default so as to eliminate echo (if the device has echo cancellation, it typically uses the device’s own built-in mic for that since it’s usually a hardware implementation IME).

1 Like

@hendersj, kcmshell6 kcm_sound offers merely:

  1. Codec choice:

  2. Notification preferences:

Although I don’t think that they’re relevant, I don’t see anything else.

I’ve also discovered Scrolling using the mouse scroll wheel in kcm_sound changes preferences - Help - KDE Discuss. Sigh.

Hi Fidelity Playback vs. Headset Head unit is the difference.

Bluetooth doesn’t provide enough bandwidth to handle both input and output, so when the mic is used, the headset head unit is selected automatically to reduce the audio output’s quality to accommodate the mic’s bandwidth needs.

That’s ultimately the issue - as you can see with your change of input device in Discord. Removing the mic input lets you use the high-fidelity output option.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.