Plasmashell freezes

After recent distro upgrades plasmashell began to accidentally freeze several times per day: force to kill it and restart. Very annoying!!! What to do? report a bug to KDE? Any workaround?

https://community.kde.org/Plasma/Debugging

The bug: 465872 – Plasma keeps crashing

Mind sharing your system and graphics hardware details ans that might be relevant here…

inxi -SGa

There is also a bug at openSUSE
https://bugzilla.opensuse.org/show_bug.cgi?id=1208188

I am having a similar problem with Gnome after the latest upgrade. The simplest way to reproduce it is to copy a password from KeePassXC. Terminal freezes, Firefox freezes etc.

Same bug reports from me:

The latter with debug symbols.

> inxi -SGa
System:
  Host: Aleksey Kernel: 6.1.12-1-default arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.1 parameters: BOOT_IMAGE=/boot/vmlinuz-6.1.12-1-default
    root=UUID=24fbaf81-79f0-4b37-b08e-b1d709ed97e7 splash=silent
    resume=/dev/disk/by-uuid/a58af199-9a71-4f77-9547-30a7871438e8
    mitigations=auto quiet security=apparmor nosimplefb=1
  Desktop: KDE Plasma v: 5.27.0 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7 dm: SDDM
    Distro: openSUSE Tumbleweed 20230221
Graphics:
  Device-1: NVIDIA GA106 [Geforce RTX 3050] vendor: ASUSTeK driver: nvidia
    v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0 chip-ID: 10de:2507
    class-ID: 0300
  Device-2: Logitech C920 PRO HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2:3 chip-ID: 046d:08e5
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 192 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Samsung
    serial: 16780800 built: 2021 res: 3840x2160 dpi: 103 gamma: 1.2
    size: 950x540mm (37.4x21.26") diag: 1093mm (43") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce RTX
    3050/PCIe/SSE2 direct render: Yes

Also created a bug report for suse: https://bugzilla.suse.com/show_bug.cgi?id=1209114 - hope somebody starts to fix it! No normal work in KDE currently!