Plasma5 has lost some scrollbar arrows sometime between 20170701 & 20170725.

Hello. I’ve been on the verge of writing this post for the past couple of months, but kept holding off in the hope that “it’ll be alright, surely the next TW zypper dup will fix it”… but it never has.

Native Plasma5 pgms like KInfoCentre, KSysGuard, Dolphin… are not affected by this problem. Certain other pgms are affected, eg, Thunderbird, KMyMoney, LibreOffice… I use these pgms every day, & so the problem is constantly “in my face” & thus very irritating.

The problem is that these various pgms’ vertical & horizontal scrollbars, for the past couple of months, have lost their arrows at both ends of the bars, despite the Settings still showing these as being selected & thus supposedly active. As such, nowadays in all the affected pgms i can only scroll by grabbing the scrollbar with the mouse pointer & dragging it in the desired direction. No longer can i scroll simply by clicking on the arrows, as they no longer exist.

I first began using TW in May this year, & back then this problem did not exist. I have TW KDE on both my Tower & Lappy, & both now exhibit this problem [for months]. In Tower i also have multiple TW VMs [so i can do various tests / experiments without endangering my real TW]. These various TW VMs are all at various different snapshot dates, & so today i have been able to discover that the TW 20170701 snapshot [Plasma 5.10.2] was GOOD, but by the time of the 20170725 snapshot [Plasma 5.10.4] the problem already had begun. All snapshots after that, including up to at least 20170904 [Tower, Plasma 5.10.5] & 20170909 [Lappy, Plasma 5.10.5], have continued to have this problem.

I also have a Leap KDE 42.3 VM, & it does not have this problem. Of course, its Plasma version is much older, so that’s not necessarily a surprise.

The fault seems not to be caused by the specific pgms themselves. I proved this by, in the 20170701 snapshot VM, firstly checking that LibreOffice & KMyMoney scrollbars were good [re arrows], then i manually updated both those pgms with zypper up to the current versions… the scrollbars are still good [arrows still present].

Here’s pics from the 20170701 snapshot; KMyMoney [1st & 2nd] & LibreOffice Writer [3rd]:
https://paste.opensuse.org/images/58041469.png https://paste.opensuse.org/images/21478208.png https://paste.opensuse.org/images/17826423.png

Here’s the corresponding pics from Tower’s real 20170904 snapshot:
https://paste.opensuse.org/images/70083318.png
Oh, there’s a limit of 4 pics per post, so i’ll put these final two in a separate post.

I use identical settings in all these installations, as follows:

  1. Workspace Theme
  • Look & Feel = openSUSE
  • Desktop Theme = Oxygen
  1. Icons
  • Theme = Oxygen
  1. Application Style
  • Widget Style = Oxygen
  • Window Decorations = Plastik
  • GNOME Application Style [GTK]
    [LIST]
  • GTK2 Theme = oxygen-gtk
  • GTK3 Theme = Emacs

[/LIST]

Do other people also experience this problem? Does anyone have any solutions please [note, the problem persists with non-Oxygen themes, but i dislike all those aesthetically, so this would not be an acceptable solution even if they did work]?

The 2nd KMM pic, & then the LO pic, from Tower’s 20170904 TW:

https://paste.opensuse.org/images/85253424.png https://paste.opensuse.org/images/42362066.png

The scrollbar arrows have been disabled by default in the Breeze widget style a while ago, in 5.10.0 IIRC.

You can configure the scrollbar arrows in KDE’s settings though:
Application Appearance->Widget Style, click on the “Configure…” button and switch to the “Scrollbars” tab.

The “Oxygen” style hasn’t been changed (it’s configurable there as well), but in your screenshots without scrollbar arrows you are clearly using “Breeze” (not “Oxygen” as you write).

Thunderbird is a GTK application though, and uses the GTK settings. And for GTK, this is not configurable… You need to use a theme that has the arrows, e.g. oxygen-gtk (only available for GTK2 though, because GTK3 removed support for such theming engines).

PS, for clarification:

In your screenshots without arrows, you definitely do not use these settings, it’s rather Breeze as icon theme and widget style (the desktop theme is not visible in your screenshots… :wink: ).
These settings should give you arrows by default.

I DO NOT use Breeze. I stated that explicitly. I listed my settings very carefully, based on actually being in each respective part of System Settings [to visually confirm they were still selected]. Given you seem to think i am either dishonest or delusional, here now are the actual pics from my System Settings:

https://paste.opensuse.org/images/74886624.png

https://paste.opensuse.org/images/35469190.png

https://paste.opensuse.org/images/3916745.png

https://paste.opensuse.org/images/3472184.png

Three more coming, in next post.

https://paste.opensuse.org/images/46078449.png

https://paste.opensuse.org/images/20643415.png

https://paste.opensuse.org/images/15009415.png

If, as you confidently assert, all my TW installations since 20170725 are truly using Breeze, then i hope you will agree from my supplied pics that i have done all i can to NOT have that happen. That’s why i made this post … there is a problem.

Yes, you stated that.
But your previous screenshots DO SHOW Breeze.

Given you seem to think i am either dishonest or delusional

I was not thinking that at all.

There is a discrepancy between the settings you listed and what the screenshots showed though, whatever the reason is.

One I thing I imagined was that you maybe changed the look&feel setting, which will reset all the other individual settings (widget style, icon theme, …).

here now are the actual pics from my System Settings:

These do look like Oxygen, and the scrollbars should have arrows, don’t they?
You nicely cut them off so that it’s not visible…

Maybe try changing the settings and change them back.
I notice that the applications you showed before are based on kdelibs4, while systemsettings5 is KF5 based, that may explain the discrepancy.
I.e. the KDE4 settings might be wrong and configured to use Breeze.

PS, to be explicit:

Change the widget style to “Breeze”, click Apply, then change it back to “Oxygen” and click Apply again.
That should sync back the setting to KDE4 and hopefully fix your problem.

Also check that the package kdebase4-workspace-liboxygenstyle is installed.
That contains the KDE4 Oxygen widget style.
If that’s not installed, KDE4 applications obviously cannot use it and will fall back to Breeze.

Thanks.

Change the widget style to “Breeze”, click Apply, then change it back to “Oxygen” and click Apply again.
That should sync back the setting to KDE4 and hopefully fix your problem.

It did not help… but i’m not giving up yet, heehee. It’s late here now so i shall resume this challenge tomorrow. Then, i plan to repeat that step you gave, but, also then logout/in, then launch KMM, TB & LO again to see. If they are still no good then, i was wondering about maybe something drastic like removing ALL “oxygen” components with YaST2, rebooting, reinstalling them, reselecting them in System Settings, then crossing my fingers…

BTW, in parallel with all the posts here, i cloned that “good” 20170701 VM, then in the clone i ran “zypper dup --no-allow-vendor-change”. Once that VM was rebooted, & is now 20170909, it continues to be good. That marks it as starkly different to my Tower AND Lappy’s “real” TWs, AND all but one of my TW VMs. Ie, of ~8 TW installations here, currently only ONE of them is correctly showing the scrollbar arrows, despite them all using the same System Settings.

Please note that I gave another suggestion meanwhile too… :wink:

Holy cow – genius!


gooeygirl@linux-Tower:~> zypper if kdebase4-workspace-liboxygenstyle
Repository 'Packman Repository' is out-of-date. You can run 'zypper refresh' as root to update it.
Loading repository data...
Reading installed packages...




Information for package kdebase4-workspace-liboxygenstyle:
----------------------------------------------------------
Repository     : Main Repository (OSS)             
Name           : kdebase4-workspace-liboxygenstyle 
Version        : 4.11.22-9.1                       
Arch           : x86_64                            
Vendor         : openSUSE                          
Installed Size : 1.8 MiB                           
Installed      : No                                
Status         : not installed                     
Source package : kdebase4-workspace-4.11.22-9.1.src
Summary        : The Libraries of the oxygen-style 
Description    :                                   
    This package contains the libraries of the oxygen style.


gooeygirl@linux-Tower:~> 

How on earth could all but one of my TW’s be missing that?

About to install it & see…

As Meatloaf sang, “two out of three ain’t bad”. Following installation in Tower now of that mysteriously missing package [which has caused me months of grief & tail-chasing], then toggling from Oxygen to Breeze to Oxygen again, the new status is that KMM & LO now do have their scrollbar arrows once again… but TB remains without them. Based on your earlier comment, given it is GTK, maybe i’ll have to live with TB not having the arrows. Tomorrow when i pick up this challenge again, i will have a look at how TB appears in that “good” VM clone.

Thanks Wolfi, & goodnight for now.

Final Status:

  1. The previously missing package "kdebase4-workspace-liboxygenstyle
    " is now installed in Tower’s & Lappy’s “real” TWs, & all of Tower’s oS TW VMs. 1. Tower’s & Lappy’s “real” TWs, & all but one
    of Tower’s oS TW VMs, now once again correctly have arrows with the scrollbars [with the GTK3 exception as below]. 1. The one recalcitrant TW VM which has still stubbornly defied all efforts to make the arrows appear, is not regarded as important… it is the 20170725 snapshot, & so i presume this VM should begin to behave itself after i sooner or later get around to zypper dup’ing
    it to latest version.

Thunderbird is a GTK application though, and uses the GTK settings. And for GTK, this is not configurable… You need to use a theme that has the arrows, e.g. oxygen-gtk (only available for GTK2 though, because GTK3 removed support for such theming engines).

I assume then that TB is specifically a GTK3 not GTK2 pgm, given that despite the success now for KMM & LO, sadly TB continues to have only bare [non-arrowed] scrollbars. I must say, the decision made by --whoever-- to remove arrows from Breeze, AND remove GTK3 theming-engine support, seems simply ridiculous from a humble user’s perspective.

I continue to wonder what happened during some older TW upgrade [presumably between the dates of this thread’s subject line], that removed that important package, & no subsequent zypper dup put it back in again. It has really wasted a lot of my time. I say “removed that important package”, because for certain both my Lappy & Tower’s real TWs did once have arrowed scrollbars [in May, June & part of July].

Many thanks Wolfi.

Yes, the Mozilla applications are using GTK3 meanwhile (the upstream downloads even longer than in openSUSE…).
Except for Leap where they are still built with GTK2 for now.

So you’d need to select a GTK3 theme that has scrollbar arrows (they are not configurable in GTK AFAIK, the theme can enable/disable them though).
I cannot name you one, GNOME’s default “Adawaita” theme does not have arrows, and they got removed in KDE’s Breeze GTK theme too as mentioned. (although it should be possible in any case to modify the theme’s file and enable the arrow buttons that way)

The main reason for removing the arrows in Breeze GTK3 was that they caused problems with Firefox (and probably Thunderbird too), but that’s apparently fixed in Firefox 55.
The corresponding commit message says:

This is a workaround to mitigate broken (huge wide) scrollbars in mozilla/Gecko based applications for GTK3 >= 3.20 in versions 52 onwards.
Ref: 377008 – Breeze scrollbar width with Firefox (version >= 52) broken (too wide) and 1343802 - [GTK 3.20] Excessive (fat) scrollbar width KDE breeze GTK theme on Firefox >= 52 (beta)
The mozilla bug is now ‘fixed’ and landing in nightlies v55, but may continue to affect earlier releases if not brought forward upstream.
Regardless of any other concern, applying this brings the appearance of newer breeze and breeze-gtk scrollars into closer accord.

But I just noticed that they apparently will be back in 5.11.0, which will be released in about a month.
https://cgit.kde.org/breeze-gtk.git/commit/?id=01a86601804222929441c0c1c8bb0db6d4ee2769
I tested that change on my Leap 42.3 system with Plasma 5.10, the arrows were not visible for some reason, apparently a missing image file, but they did work…

I continue to wonder what happened during some older TW upgrade [presumably between the dates of this thread’s subject line], that removed that important package, & no subsequent zypper dup put it back in again.

Well, there were some efforts recently to get rid of Qt4 (and KDE4 applications therefore) in a default installation (Qt4 is end-of-life since May 2015 already, and it also cannot be built with the latest OpenSSL 1.1.0…).
Apparently kdebase4-workspace-liboxygenstyle is not installed automatically any more therefore. (although it would probably be a good idea to add sime “Supplements” to the package to avoid “surprises” like yours)

I cannot say why it got uninstalled though, which shouldn’t have happened. Maybe there was some temporary problem (dependency conflict) that caused that.

I’m simply in awe of the deep knowledge many of you whizzbang experts here have – it’s astounding, & i’m so grateful for the generous sharing you repeatedly provide.

Unfortunately 5.11.0’s improved Breeze-gtk won’t help me. i simply dislike almost everything about Breeze’s aesthetics, & eschew it for Oxygen. Oh well, it’s a pity, but i’ll just continue to get by using TB sans-arrows, heehee.

You make an important point re “Qt4 is end-of-life”; i’d read that elsewhere some time ago, but then forgot all about it. Personally i’m not heavily invested in Qt4, only i sincerely hope that once it is gone for good that Qt5 incorporates all its useful functionality… scrollbar arrows being just a case in point. It’d be a great shame if moving forward necessitates going backwards

Once again, my sincere thanks.

Well, then you need to find a different GTK3 theme that has arrows (and which appearance you like).
Hint: there is a “Download new themes…” button in KDE’s GTK config module.

The one you currently use, “Emacs” is no real theme, it only sets some keyboard shortcuts.
IOW, you are actually using GNOME’s standard “Adwaita” theme, which never had scrollbar arrows to begin with (apparently they don’t suit the GNOME philosophy…).

Oxygen cannot be ported to GTK3 because the GTK developers dropped support for theming engines completely in 3.16, as I already mentioned.
(actually Oxygen is ported and available for GTK3, but doesn’t work with 3.16 or newer)
One could of course create a new (CSS based) GTK3 style that looks like Oxygen, but that would be work from scratch. And nothing could be reused from the existing Oxygen style, because that uses C++ code to draw all the elements.
That’s why the Oxygen developers did not do it, and will not do it (as they stated repeatedly).

You make an important point re “Qt4 is end-of-life”; i’d read that elsewhere some time ago, but then forgot all about it. Personally i’m not heavily invested in Qt4, only i sincerely hope that once it is gone for good that Qt5 incorporates all its useful functionality… scrollbar arrows being just a case in point. It’d be a great shame if moving forward necessitates going backwards

Of course Qt5 incorporates scrollbar arrows (why would you even get the idea that it hasn’t? You are using it already for many things and your problem in this thread did actually not affect Qt5, only Qt4 and GTK3). And the Oxygen widget style is available for Qt5 too (it was available even before Breeze was).

Qt5 has been released in 2012, and most applications have been ported from Qt4 by now. There are some applications that are still KDE4/Qt4 based (like kmymoney), but that should change soon too.
With the December release, kdelibs4 and all applications that still use it will be dropped by KDE. Doesn’t affect 3rd party applications like kmymoney of course, but it should increase the efforts to finally release a KF5 port (a working development version using KF5/Qt5 is available since a long time already).

Qt5 should have all useful functionality from Qt4, and actually lots more.

Thank you Wolfi

Well, then you need to find a different GTK3 theme that has arrows (and which appearance you like).
Hint: there is a “Download new themes…” button in KDE’s GTK config module.

The one you currently use, “Emacs” is no real theme, it only sets some keyboard shortcuts.
IOW, you are actually using GNOME’s standard “Adwaita” theme, which never had scrollbar arrows to begin with (apparently they don’t suit the GNOME philosophy…).

Aaaaaha, this info is gold for me. Now that you’ve specifically pointed this out to me, i feel silly for not already having worked it out for myself, but anyway i hadn’t, so your prod in the right direction is very welcome. After now reviewing a plethora of quite ghastly GTK3 Themes via the “Get New Themes” button, i finally stumbled across “Xfce Evolution”. This has acceptable aesthetics for me, & most importantly it provides single-arrow [pity no double-arrow choice like KDE, but beggars can’t be choosers i suppose] functionality to both ends of all associated scrollbars. Thus my Thunderbird has regained some basic functionality that IMO it should never have lost.

BTW, that “Emacs” option was an unfortunate legacy oversight on my part, inherited from my time before oS TW, which solved a genuine problem back then, but which problem is not actually present in TW. When i migrated to TW from the Debian/*buntu world in May this year, i unthinkingly applied that same setting unwisely, & never thought about it again until you highlighted it to me.

If there’s one benefit of my being so dim as to unfortunately keep saying dopey things & asking dopey questions here, it is that it elicits increasingly expansive answers, which then eventually start to make sense to me. I’m sorry for being a slow learner, & struggling with what for me is often obscure jargon & vague concepts – thanks for not just giving up & walking away.

BTW, i know this is slightly OT, but FYI: In doing these recent settings explorations, i’m happy to say i also solved another long-term problem too, wrt my erstwhile usage of “oxygen-gtk” for the GTK2 Theme. My stubbornness in sticking with that meant that i could not use the Pale Moon browser as one of my secondary browsers, because it crashes at launch if that theme is used. However i’ve now found that changing to “QtCurve” instead for the GTK2 Theme, still provides me with acceptable aesthetics, & allows PM to run fine. It’s really marvellous that KDE lets us fine tune our desktops so effectively via its granulated controls for GTK Themes independent of Widget Style, & equally independent of Icon Themes. Though this might be seen as overly complex by some, for those who like this kind of thing [even when they are slow learners], this amount of personalisation control is really appreciated.

Thanks again.