Plasma 5, keyboard repeat

I have gone into the Configure Desktop->Hardware->Input Devices->Keyboard Repeat and set the Delay to 1272 and applied it and it still repeats immediately. So I turned it off and it still repeats right away. I’ve shutdown and restarted without it changing. How do I stop the repeaaat?

As in your other thread: you need to use systemsettings5 to configure Plasma 5.
In the menu that would be Applications->Systemsettings or Settings->Systemsettings in 13.2.

“Configure Desktop” is the KDE4 version in 13.2. It has been renamed to “Configure KDE4 Applications” in Tumbleweed (and systemsettings5 to “Configure Desktop”), because Plasma5 is the default KDE desktop there.

This indeed did the trick and I am most grateful. But why the two sets of control? Is there a way I can set Plasma 5 to have just it’s own version of the tools?

Once again, thank you. The repeated keys were getting to me.

Well, I even have three here: systemsettings5, KDE4’s systemsettings, and KDE3’s kcontrol… :wink:

You need KDE4’s systemsettings to configure the KDE4 desktop (which is the default in 13.2 as you should know), and you need it to configure KDE4 applications (not all KDE applications have been ported to KF5 yet), although systemsettings5 changes at least the style/color settings for KDE4 too.

Plasma5/KF5 uses a different directory for its settings, so KDE4’s are not respected, and it installs its modules to different locations (not /usr/share/kde4/), so it cannot load the KDE4 setting modules (though they wouldn’t work anyway because they are written for a different version).

Is there a way I can set Plasma 5 to have just it’s own version of the tools?

Uninstall kdebase4-workspace-addons.

I appreciate the feedback. Is there some place I can go to learn about which tools belong to which environment or perhaps some details on Plasma 5? Most of what I find when I google the subject are announcements about it and not details.