Pineview Integrated Graphic

Hi all

I am back to running openSuse after a long run of other Linuxs and I am not sure how to go about getting the video to run well. Glxgears show only 58 fps and I read that I should be at about 300 fps. Have been reading around the forms and found that there is a xorg driver xf86-video-intel-2.12 and that it is suppost to be a better driver that the xf86-video-i915 that is loaded at this time. So the question is a download it and how to get the xserver to use it. Or it there a better solution.

With openSUSE, most of the open source drivers (including the intel driver) are provided by the xorg-x11-driver-video package. The i915 module is part of the open source intel driver (which my own laptop uses with its GM965 chipset). While it is possible to compile an upgraded intel driver against the kernel, it is fraught with potential problems for the inexperienced, so I wouldn’t personally recommend it. Maybe someone else with more knowledge in this area can assist further.

I found this thread while searching for info concerning the Pineview (GMA3150 chipset).

Some more general openSUSE intel guides:

openSUSE Graphic Card Practical Theory Guide for Users

HCL:Video - openSUSE

Thank you for you reply and yes the driver in the thread that you posted is the driver I was looking for and I do not know for sure how to bet the xserver to use that one it is now using the i915 but I believe the Intel will give my Acer Aspire one notebook with the pineview chipset a better performance

I was just looking around in the /usr/lib/xorg/module/driver folder and there is no i915 driver in that folder. But the intel driver is in that folder so now I ask if the hardware information is saying that I am running the i915 driver and it is not in the folder what driver am I using to give me the slow fps.

But the intel driver is in that folder so now I ask if the hardware information is saying that I am running the i915 driver and it is not in the folder what driver am I using to give me the slow fps.

The following command (as root)

modinfo i915

will show you where the location of the i915 driver is. Mine for reference


I think you may also be getting confused between the ‘.ko’ and .‘so’ files. Kernel modules (.ko) run in kernel space, while user modules (.so) run in user-space. The latter can really be considered as regular library files, while the former are part of the kernel itself. I’m sure others could provide better clarification on this, but that’s it in a nutshell, so the /usr/lib/xorg/modules/drivers/ directory you referred to contains the user-space counterpart of the graphics drivers.

Hi and welcome back.

I’m afraid your thread may not get very far with your concern. I failed to find any mention of what openSUSE release you are using. I don’t know where you read that glxgears should give you 300fps, you don’t say. There are threads where glxgears and its suitability has been discussed since release of 11.3 (intel 2.12 driver), also concerning lower fps rates with e.g. intel [integrated] chips and intel driver. My intel GM45 chipset delivers 60-63 fps on 11.4 with intel 2.14 driver, similar on 11.3, similar to other users. It has also delivered good 2D and 3D performance on 11.2/3/4, for modern multimedia activities (probably not for serious gameplay). The fact is that glxgears is too simplistic a program to properly test modern graphics chips.

Did you not see this disclaimer displayed by running glxgears including this statement:

*** NOTE: Don't use glxgears as a benchmark.
     OpenGL implementations are not optimized for frame rates >> 60fps

IIRC, that has been there for several openSUSE releases. :slight_smile:

Apart from glxgears, what problem are you seeing with your graphics performance?

I am running openSuse 11.3 and it has done all the updates as for what kind of problems I am having well mostly it is just slowness of graphics like the screen saver is in slow motion and some frame dopes in mp3 movies

I wanted to add that this article suggest that the intel is better for my video chipset
openSUSE Graphic Card Practical Theory Guide for Users

intel - this is an free open source driver for all Intel hardware. The “intel” driver supports the i810, i810-DC100, i810e, i815, i830M, 845G, 852GM, 855GM, 865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, Q35, G35, GM45, G45, Q45, G43 and G41 chipsets. This driver should have much better performance than the VESA driver. It typically comes packaged with openSUSE as part of xorg-x11-driver-video rpm and it is the default graphic driver in openSUSE-11.3/11.4.

checked the kernel modules director and there is no intel driver there so that is why it was not selected.

I use the “intel” driver on my old 11.3 system, still installed and fully updated but not for much longer. You can follow the loading of your graphics driver in the log at /var/log/Xorg.0.log, for example here are those lines from mine:

    25.211] (II) LoadModule: "intel"
    25.216] (II) Loading /usr/lib64/xorg/modules/drivers/
    25.216] (II) Module intel: vendor="X.Org Foundation"
    25.216] 	compiled for 1.8.0, module version = 2.12.0
    25.216] 	Module class: X.Org Video Driver
    25.216] 	ABI class: X.Org Video Driver, version 7.0

Note the info I highlighted in red.

Also, further down the log:

    25.220] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
	4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale

and further on, when the driver really gets going with its setup, e.g.:

    25.237] (==) intel(0): Depth 24, (--) framebuffer bpp 32
    25.237] (==) intel(0): RGB weight 888
    25.237] (==) intel(0): Default visual is TrueColor
    25.237] (II) intel(0): Integrated Graphics Chipset: Intel(R) GM45
    25.237] (--) intel(0): Chipset: "GM45"

Note the indentifier of the driver “intel(0)” repeated on the left side of each line, where the name would be different for some other driver.

BTW, when the system reports “i915” as a driver name, it is referring to the actual kernel driver module for intel graphics. The Xorg log is reporting on the driver module used by the X system.

Have a look at your Xorg log, and tell us if you see the “intel” driver loading.

Well I looked at the /var/log/xorg.0.log and found this and it may be my problem

(WW) Falling back to old probe method for fbdev
31.675] (II) Loading sub module “fbdevhw”
31.675] (II) LoadModule: “fbdevhw”
31.676] (II) Loading /usr/lib/xorg/modules/
31.677] (II) Module fbdevhw: vendor=“X.Org Foundation”
31.677] compiled for 1.9.3, module version = 0.0.2
31.677] ABI class: X.Org Video Driver, version 8.0

it show that it tried to load the intel but fell back to the fbdevhw module.

No, that’s not a problem. I get that and same for vesa. Is your “intel” driver (2.12.0) being loaded, i.e. do you see Xorg.0.log lines similar to those quoted from my log?

Yes there is this

31.645] (II) Loading /usr/lib/xorg/modules/drivers/
31.645] (II) Module intel: vendor="X.Org Foundation"
31.645] 	compiled for 1.9.3, module version = 2.14.0
31.646] 	Module class: X.Org Video Driver
31.646] 	ABI class: X.Org Video Driver, version 8.0

But like I started this out as I have the problem of droped frames in movies and the screen saver with then lighting you can see the lower part of the screen being drawn and it is very slow.

Did you say you were running 11.3?

 31.645] compiled for 1.9.3, module version = 2.14.0

X.Org X Server 1.9.3 and “intel” driver 2.14.0 are versions used on 11.4, so how did you manage that on 11.3?

Well spotted consused.

My Xorg.0.log output reports

    19.801]    compiled for 1.8.0, module version = 2.12.0

(I’m using openSUSE 11.3 currently).

I wonder whether the OP has enabled some 11.4 repo (or similar) in an effort to ‘upgrade’ the intel driver…

there was a lot of updates right after I installed it was maybe installed then

That doesn’t explain it. Both Deano and I are referring to an 11.3 system that has been correctly updated from the “official” sources.

Please run the terminal command zypper lr -d and post the results within CODE tags (go “advanced”; highlight text; and click on “#” icon).

zypper lr -d
# | Alias                | Name                       | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | Packman Repository   | Packman Repository         | Yes     | Yes     |   99     | rpm-md |                     |        
2 | google-talkplugin    | google-talkplugin          | Yes     | Yes     |   99     | rpm-md |           |        
3 | libdvdcss repository | libdvdcss repository       | Yes     | Yes     |   99     | rpm-md |                            |        
4 | repo-debug           | openSUSE-11.4-Debug        | No      | Yes     |   99     | NONE   |  |        
5 | repo-debug-update    | openSUSE-11.4-Update-Debug | No      | Yes     |   99     | NONE   |                 |        
6 | repo-non-oss         | openSUSE-11.4-Non-Oss      | Yes     | Yes     |   99     | yast2  |    |        
7 | repo-oss             | openSUSE-11.4-Oss          | Yes     | Yes     |   99     | yast2  |        |        
8 | repo-source          | openSUSE-11.4-Source       | No      | Yes     |   99     | NONE   | |        
9 | repo-update          | openSUSE-11.4-Update       | Yes     | Yes     |   99     | rpm-md |

I forgot the 11.3 had some trouble and the second try was 11.4

Thanks for the repo info. Looks like you are running 11.4, and from previous post the current intel driver 2.14.0 is loaded. However, there remains some basic info you can provide that may have some bearing on the situation.

How did you move from 11.3 to 11.4? Did you perform a distribution upgrade (e.g. using zypper dup) or a clean install?

Depending at what stage of installation your 11.3 troubles occurred, could they provide any clue to the problems with running movies or screensaver? Did you have the same graphic problems on 11.3 and 11.4?

What Desktop are you running (e.g. KDE or Gnome)? Size of main memory on the laptop and processor(s)?

Which one of our forum’s Multimedia Guides did you follow to install your multimedia packages?

Are the movie playback problems on full-screen and/or windowed operation, and what happens to that if you disable all screensavers?

I did a clean install there was some issues with the 11.3 when I tried to set up the system so wiped and started over just forgot that I had downloaded the 11.4. I have to use a thumbdrive to boot on a notebook and forgot that I had decided to try the 11.4