phpMyAdmin Help

Hi All

After spending a few years in Arch, I decided to make the move to OpenSuse Tumbleweed and I love it … Big learning curve though.

Anyway i’m having trouble installing phpMyAdmin. I have Nginx, Php & Mysql all installed and working great. But tried to install phpMyAdmin and cant login.

I tried to follow this tutorial, but wont work

https://www.linuxbabe.com/linux-server/install-lemp-stack-nginx-mariadb-php-opensuse-leap-42-1

Any help ?

Cheers

You say “tried to install”, not “installed”. Does that mean that you tried, but that something went wrong? As long as the installation as such wasn’t successful, IMHO it has no use starting using the product (and then to find out tthat it does not function to satisfaction).

Thus please, did you install it (using YaST or zypper) and was that successful or not? And when not, what were the messages, etc.

Your reference link describes only how to install LEMP, not the entire PHPMyAdmin app.
I skimmed the reference and it looks fine to me. I see only a few steps I’d recommend be done differently but overall that guide should accomplish the main goals which are to install nginx, php5 and mysql/mariadb, with each verfied functional.

So,
You’ll need to verify you’re downloading your PHPMyAdmin from the following page (reference from the PHPMyAdmin official website)
https://software.opensuse.org/package/phpMyAdmin

But, there is a FYI and probably a glitchy issue. The PHPMyAdmin documentation on the following page describes required manual configurations to the web server which is of course dependent on what web server you choose to install. Although PHPMyAdmin supports just about any web server with PHP6 installed, most packagers assume you’re installing Apache, not nginx or something else.

https://software.opensuse.org/package/phpMyAdmin

So, you’ll probably need to inspect the contents of your package to verify what I suspect… or, instead of or in addition to installing nginx (there is no problem leaving nginx installed while also installing apache, but you should not enable websites to use the same ports)… Run the following to install LAMP which will add to your system Apache webserver plus its PHP5 modules.

zypper in patterns-opensuse-lamp-server

After the above, I’d again recommend running the following to make sure that a website running on nginx doesn’t start accidentally and conflict with a website in nginx

systemctl disable nginx.service

and you’ll need to run this only once if you don’t want to reboot

systemctl stop nginx.service

Now, you can start and enable your LAMP instead with the following commands. If you run into an error connecting to the mysql database, you’ll probably have to re-run the “mysql_secure_installation” script that configures your database security again, setting correct parameters.

systemctl start apache2.service && systemctl enable apache2.service

BTW - It’s optional, but you want to script your use of “mysql_secure_installation” so that you have a record of what you configured and also have a simple way of re-applying or modifying, I describe how to do this in the following Wiki page
https://en.opensuse.org/User:Tsu2/MySQL_and_Mariadb

If you need to re-configure your mysql/mariadb security configuration, like any other app configured and managed by systemd, you’ll likely need to “reload” either that service or all services (which I generally recommend, there is no harm is making sure all are reloaded)

systemctl daemon-reload

The above might be a little confusing because I’m describing how to manage side-by-side installs of nginx and apache2, but if that is what you might want instead of simply uninstalling nginx and its related PHP modules, the above is more or less what you should do.

TSU

Thanks for the advice. I’m going to completely remove nginx, php5, mysql etc and start again and get back to you how I get on

OK.

Inspecting my last post, I see some things that aren’t what I intended…

The page that describes customizations is on the following page (I’ve pointed to the PHP configuration but you should read the entire page)
https://docs.phpmyadmin.net/en/latest/require.html#php

Also, minimum version of PHP is v5.5, not 6, that should be the default version in all fully updated and supported openSUSE.

TSU