PHP5 soap extension not loading

Hello, I have no hair any longer on the sides of my head… after trying to deal with this problem.

I have installed apache2 on a SuSE 11.3 box, with php5, php-pear, php-gd, etc, and I cannot get php-soap to get recognized.

Do I need to see the when I cat /etc/apache2/sysconfig.d/loadmodule.conf ?

  • When I run an installation wizard for the web app I am planning to host, and it says that there is no soap installed.
  • When I place soap php-soap php5-soap in the APACHE_MODULES of /etc/sysconfig/apache2 (just to make sure at least one is the right name) and restart apache2 I get error messages that say, soap (or php-soap, or php5-soap) is not installed, so its being ignored.
  • When I run my phpinfo.php script, I see PHP is working, and soap is one of the successful modules (!?).

So, why can’t apache see soap?

I can find my within /usr/lib/php5/extensions/ (how would I successfully load that into Apache, when it starts?

I have been using yum, so I went to yast, and installed php-soap again. restarted apache, and still no success.

Any help would be appreciated.

Yes. That’s the list of loaded modules. So if some module is loaded, it can be seen there.

PHP extensions and apache modules are different things. Check /usr/lib/apache2 for the list of installed modules.

When you are sure you have the module you want installed, edit /etc/sysconfig/apache2 and add your module name to the APACHE_MODULES variable.

However, the thing you are trying to do is load an extension of php I guess. if so, edit /etc/php5/apache2/php.ini

and add this:

extension=“name of the extension which resides in your extension directory”

Thank you.

It didn’t make a difference with my app’s install wizard, but, since I CAN see that soap is active in my phpinfo.php test, (the typical one), and the fact that I have installed it with yast and yum, I am beginning to think that the app’s wizard (legacy open source) is no longer testing the right thing!

I will go forward. Thank you for your help!

Thank you. for taking the time.

Can you post outcome of this command?


Thank you for the help. When I put that script in a web page an open it up in a browser, the entire page only contains:


My web page is coded as follows: