Phantom NIC in "Network Settings"

Hi everybody.

I’m having some issues that are really getting me stumped. I am new to Linux as of 2 weeks ago but have learned quite a lot through my troubleshooting. Here is what I have done so far. I’m trying to put together a computer lab for an elementary school using the education addon and kiwi-ltsp. I originally had two NICs installed. The first was a PCI card facing an external router (DHCP/eth0). The second was the onboard NIC facing one thin client(static/eth1) with no switch between server and client.When trying to do my PXE boot in debug mode, I noticed that the client received an IP address (DHCP was running woot!) but was asking for the boot image from eth0 which inevitably failed.

In an effort to isolate the problem, I took out the PCI NIC and am now just trying to set up a single interface properly. The problem is that when I look in Network Settings,my NIC is showing up as eth1 along with a second phantom device that is not configured. When I try to edit the phantom device’s settings, all the options are grayed out. When I go back to the main settings area, the phantom device disappears. However every time I go back into Network Settings the mystery device is there again. I’m not sure what to do. I’ve tried all the logical things (in my mind anyway) like renaming the device etc but I can’t seem to figure this out. The frustration is setting in big time!

On a side note, despite all this I am really glad I’m getting to know Linux. I particularly like openSUSE. I hope you guys can help me solve this so my wife’s school can have a nice little SuSE lab!

That phantom NIC is there because of the udev detected settings left behind in /etc/udev/rules.d/70-persistent-net.rules. You can simply delete that device in YaST. In fact you might want to delete all devices and reconfigure, then your onboard NIC becomes eth0. Or you can just do a rename of the interface name under one of the tabs.

You didn’t have to remove the second NIC to fix the netboot problem. Firstly your NICs should have been in distinct subnets. When the client asked for the boot file it should have asked it from the address of the server on the LTSP subnet, not the address on the other subnet. This is configured in the DHCP settings. Maybe you used a domain name instead of an IP address and the domain name resolved to the main address. You should create another domain name for the address on the LTSP subnet.

Finally if you are putting both subnets on the same LAN you might want to use VLANs to isolate the subnets, otherwise you’ll get warnings about martian packets.

Hi Ken and thanks for the response,

I edited the udev file (70-persistent-net.rules). First I took out the secondary interface entry and set my current NIC to eth0. That didn’t remove the second NIC but it did put my actual NIC to eth0. Next, I took out all hardware entries (in the same udev file) and restarted udev (/etc/init.d/boot.udev restart
). However, when I go into Network Settings, both hardware devices are showing. The unknown device has the “Delete” button grayed out so there is nothing I can do in YAST to get rid of it. I ran ifconfig and this is what it printed:

eth0 Link encap:Ethernet HWaddr 00:20:ED:5E:AA:A1
inet addr: Bcast: Mask:
inet6 addr: fe80::220:edff:fe5e:aaa1/64 Scope:Link
RX packets:2533 errors:0 dropped:0 overruns:0 frame:0
TX packets:1837 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1152122 (1.0 Mb) TX bytes:236025 (230.4 Kb)
Interrupt:18 Base address:0xa000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:340 (340.0 b) TX bytes:340 (340.0 b)

pan0 Link encap:Ethernet HWaddr 26:88:F2:EC:84:94
inet6 addr: fe80::2488:f2ff:feec:8494/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:1404 (1.3 Kb)

What is pan0? Do I need to change something in the BIOS?

I have never seen pan0 before but a search says that pan0 is a bluetooth device.

I found that as well. The only problem is that my box does not have a built in bluetooth device. I double checked this in the bios under integrated peripherals and there is nothing of the sort in there. In ifconfig the pan0 device has a unique MAC address so it has to exist somewhere. If all the pan0 info is fabricated then this is a real bug.

I’m going to take a shot in the dark and reconnect my other NIC and see if things are any better now that the real device is eth0.

Ok, second NIC installed. I went through the easy-ltsp setup process and everything was fine. I did this both through the GUI as well as using “kiwi-ltsp-setup -c” I still can’t get past the splash screen on the client. I looked again in debug mode to look for clues and there were two failed errors.

eth0    IP address:                  waiting
eth0    interface could not be set up until now    failed

Setting up service (localfs) network failed

After those messages it starts ssh daemon and mouse support, flashes

(none): / # _
and finally finishes at a screen like this:

Welcome to openSUSE 11.1 - Kernel (tty2).

ws52 login:_

I’ve checked the dhcp settings and the tftp server says it’s enabled, network devices are configured correctly. I don’t know what else to check. Any suggestions?

I never delved that much into kiwi-ltsp, but there’s a mailing list you could ask. Does kiwi-ltsp require some sort of reverse DNS lookup to translate the IP address to a domain name?