Petite Linux?


Could someone share their experience with petite linux?
How well is it. I am looking for a good e17 distro. Currently I am on Bodhi Linux but when they said it is minimal, they dind;t lie, I can;t even find a manager to see how does this version of Linux sees my hardware.

Yes I am still a Linux newbie.
I really liked how well opensuse 11.3 did see my hardware and offered suitable drivers etc. As I understand Petite Linux is same opensuse 11.3 just with a clean e17 desktop envo?

thank you for your patience and time to reply!

Have you tried Linux MangOeS? It’s been tried and tested for more than a year and a half.

MangOeS – SUSE Gallery

Hi Jetbird,

Petite Linux 11.4 should be publicly released over the next few days.
I recommend you give it a whirl.
Most notably on the E17 front, the focus bug has finally been fixed (kudos to e17 developers)
As for petite itself, there have been a few changes, and overall I feel the 11.4 version is faster and more responsive than the 11.3 version.

Hope you like it,


re: Jetbird request:

I am currently running opensuse-11.3-KDE4 on an ASUS eeePC 901 netbook using opensuse LXDE window manager. Opensuse LXDE runs well but it is not fully integrated with KDE (eg. no menu links to kcontrol or system settings) nor all that “easy” to configure. I have KDE4 libraries and other ‘experimental’ window managers installed on the netbook so if I am to stick with LXDE I will need to reinstall.

I am waiting for LXDE 11.4 studio release …

Meanwhile I have tried running both bodhi_0.1.7 and Petite_Linux_11.4-i686-beta (both E17, I think) from live CDs. I had problems getting the E17 gadgets to correctly initialise and manage bluetooth services (both distros) and network services (petite only). I worked around this by installing gnome bluetooth tools on bodhi (works with lots of drop-outs) and, on petite, by configuring eth0 in yast and installing kde bluetooth-applet (which allows connection but seems to cause an Enlightenment Error - restart after a while - though connection still works).

I have not yet found how to access a run command GUI dialogue (eg. Alt-F2, run). This is very useful on a netbook. It must be there somewhere.

Enlightenment is ‘experimental’ but these ‘compilations’ are both worth a look. My grateful thanks to Robert Krambovitis and Jeff Hoogland for their good work.

Overall, I find neither bodhi nor petite as easy to configure and operate as opensuse LXDE, but I suspect this is due to my limited skills with gnome and enlightenment.

But both are faster …

I hope these comments help.

OK found it: Alt + Esc → run command but GUI is not persistent …

Hi Tallowwood, thanks for your comments.
The network services module uses “connman” which unfortunately is not available in the openSUSE repositories.
You should be able to connect to any network using wicd.

I will look into the bluetooth and see what daemon it needs, however I don’t have any hardware to test it with.

Thanks for your comments :slight_smile: