Permissios in /dev caused failure to play video dvd

I would like to tel you about my experience with opensuse 11.1 and video playback with css protected disks.
I installed openSUSE without any problems.
Then added the packman repository and
for libdvdcss and installed al the restricted stuff.

Finally I could play video’s with xine, but only as root.

Checking the permissions i found:
nico@elcheapo:~/Documents> ls -l /dev/dvd
lrwxrwxrwx 1 root root 3 2008-12-22 13:37 /dev/dvd → sr0
nico@elcheapo:~/Documents> ls -l /dev/sr0
brw-rw---- 1 root disk 11, 0 2008-12-22 13:37 /dev/sr0

Note that /dev/sr0 is group disk.
I added myself to this group in /etc/group and after logging out and in again I couls use xine in my own account.

Hope this helps


Hmm, that’s rather dangerous because the hard disks are also in group disk, so it means that anybody with your account privileges can read the raw disk and look for things like passwords. Shouldn’t the DVD devices belong to group cdrom and resmgr gives you access to cdrom when you login at the GUI console?

You me be right, but this is the situation I found after installing from the Live cd.
Could it be because the dvd drive is the only device on the only IDE interface and is jumpered as master? My hard drive is on the sata controller of an 750/630a nforce chipset.


It’s assigned to kde-maintainers… if someone can verify if this also happens with KDE3 and/or Gnome it could help to find the cause.


Thanks for the answer.
My opensuse 11.0 PC that I am working on now does not have the problem, i.e. I can play dvd video without adding myself to the ‘disk’ group.
I will try the workaround as soon as I have the time.

I did a reinstall with the installation dvd.
Selected gnome.
Had the same problem. On my account could not play video with totem
but root could.
I could after adding myself to ‘disk’ group.

I’ve same problem on KDE3, openSUSE 11.1. libdvdcss is installed, but still not be able to paly back DVD movies. I’ve also tried to add myself to DSIK GROUP, but it didn’t help. Any suggestion?

I have the same problem. Did just the same as nvliet, installed OpenSuse 11.1 without problems, added the libdvdcss stuff and presto, no access to dvd. I couldn’t even add programs from the dvd, had to remove it from the list of upgrade sources.

Now when I insert a DVD video in the drive it appears on the Desktop. When I choose open with Totem it starts Totem but it stops with a message: Error: Cannot read the resource (translation from finnish error message)

I will try the same fix…

I forgot to mention that codecs-kde is also installed, but still not any answer. I DVD device is detected, but when i insert DVD videos to device, got errror message from Kaffeine: this version of Xine doesn’t support codecs.

I’ve got the exact same problem, so I went looking on my media center how it comes it CAN play dvd’s as a normal user.

krusty:/dev # ls -all | grep sr
lrwxrwxrwx   1 root root          3 2008-06-05 02:00 cdrom1 -> sr0
lrwxrwxrwx   1 root root          3 2008-06-05 02:00 cdrw1 -> sr0
lrwxrwxrwx   1 root root          3 2008-06-05 02:00 dvd -> sr0
lrwxrwxrwx   1 root root          3 2008-06-05 02:00 dvdrw1 -> sr0
srw-rw-rw-   1 root root          0 2008-12-28 12:00 log
lrwxrwxrwx   1 root root          3 2008-06-05 02:00 scd0 -> sr0
brw-rw----+  1 root disk    11,   0 2008-06-05 02:00 sr0
krusty:/dev # cat /etc/group | grep nijs
krusty:/dev # ls -all | grep sda
brw-r-----   1 root disk     8,   0 2008-06-05 02:00 sda
brw-r-----   1 root disk     8,   1 2008-06-05 02:00 sda1
brw-r-----   1 root disk     8,   2 2008-06-05 02:00 sda2
brw-r-----   1 root disk     8,   3 2008-06-05 02:00 sda3

The reason why my suse 11.0 based media center can play dvd’s is obvious, however I can’t remember adding the user “nijs” to the disk group. I surely wouldn’t have done this myself. The user “admin” also got in there on its own.

So I guess the reason it doesn’t work anymore really is the rights thingy.

The best way to solve this seems to me to add yourself to the “cdrom” group, which seems to exist already and change the group owner of /dev/sr0 to cdrom. I only don’t know how to let this setting survive a reboot.

This is a bug in openSUES-11.1. I hope it will be fixed in the next couple of months. There is a blog here giving work around suggestions (most of which are not typically needed). Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change

Which one of those solutions is the most recommended?

Most recommended? I don’t know.

On two of my openSUSE-11.1 PCs I added users to the group “disk” and the group “cdrom” and that worked for me. It may not work for everyone.

How do I use that patch?

In my case, I do chmod 666 /dev/sr0. It solved my current problem

Try to add your user id to disk and cdrom group by using YAST | Security & Users| User & Group Management. Choose your id and then Edit |Detail

Used acl to give proper access control setting view plaincopy to clipboardprint?
setfacl -m your-user-gid:rw /dev/sr0

setfacl -m your-user-gid:rw /dev/sr0
to /etc/init.d/boot.local

Check status of /dev/sr0 with ls -l /dev/sr0 and checked if it has ‘+’ sign. Please refer to this for assistance

Make your user a member of “cdrom” group by following step 2 and then create /etc/udev/rules.d/99-my.rules file with the following entry : KERNEL==”sr*[0-9]“, GROUP=”cdrom”, MODE=”0660″ and then reboot

Patch /usr/share/PolicyKit/policy/org.freedesktop.hal.device-access.policy. Refer to this patch for assistance.

ok I tested all that, It solved the problem with K3b but I still can`t play any DVD movies, it display the “dvdread could not open the disk /dev/sr0” error even as root, I tested with VLC, mplayer Smplayer and xine.

Ok it only happens when I open mycomputer right click with the mouse and hit play with vlc, if I open Vlc and select open disk no menus I plays fine.

I have the problem with 11.0 / KDE3.5 that Kaffeine can’t play the DVDs either. It was also evident in 11.1 / KDE4, 11.1 with KDE3.